Nginx - name based site - address already in use

    • OMV 4.x (testing)
    • Nginx - name based site - address already in use

      Hi all,
      I just update to OMV 4.x, and i was facing an issue from nginx website config.

      I have sites defined as name based server all listen to 443 with force https option. This config works for years on OMV 3.x, event 2.x.
      But since the update, nginx won't start with address already in use error. and i firure out that error is because of this configuration.

      It seems that the nginx mkconf use an old config syntax, now deprecated.
      By editing the zzz-omv-nginx and comment the ipv4 listen directive, it works like a charm

      Source Code

      1. server {
      2. #listen :443 ssl;
      3. listen [::]:443 ssl;
      4. ....
      5. }
      Have you experience the same thing ?
      May I make a git issue ?
    • Yes, please open an issue at bugtracker.openmediavault.org.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • I could not reproduce this for the OMV WebUI, see github.com/openmediavault/open…onf/nginx.d/10webgui#L116. The config does not look like yours. So i assume we are talking about the nginx plugin? If so, please open a bugreport here.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit

      Post by max bigstone ().

      This post was deleted by the author themselves ().
    • lu6fer wrote:

      Hi all,
      I just update to OMV 4.x, and i was facing an issue from nginx website config.

      I have sites defined as name based server all listen to 443 with force https option. This config works for years on OMV 3.x, event 2.x.
      But since the update, nginx won't start with address already in use error. and i firure out that error is because of this configuration.

      It seems that the nginx mkconf use an old config syntax, now deprecated.
      By editing the zzz-omv-nginx and comment the ipv4 listen directive, it works like a charm

      Source Code

      1. server {
      2. #listen :443 ssl;
      3. listen [::]:443 ssl;
      4. ....
      5. }
      Have you experience the same thing ?
      May I make a git issue ?
      I had the same error... The problem is the ipv6_enabled function inside helper-functions script file...

      replace line 825 in /usr/share/openmediavault/scripts/helper-funcions for this line:
      [ -e /proc/net/if_inet6 -a $(cat /proc/net/if_inet6 | grep -v lo | wc -l) -gt 0 ] && return 0

      If IPv6 is enabled only in loopback network the the function return that your system is configured only for IPv4...

      This works for me!!!
    • Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • max bigstone wrote:

      I had the same error... The problem is the ipv6_enabled function inside helper-functions script file...
      replace line 825 in /usr/share/openmediavault/scripts/helper-funcions for this line:
      [ -e /proc/net/if_inet6 -a $(cat /proc/net/if_inet6 | grep -v lo | wc -l) -gt 0 ] && return 0

      If IPv6 is enabled only in loopback network the the function return that your system is configured only for IPv4...

      This works for me!!!
      For me it's not enought, the mkconf/nginx.d/90-nginx-server must be edited to drop the [ssl_]listen_ipv4

      The post was edited 1 time, last by lu6fer ().

    • Users Online 1

      1 Guest