SMB not working anymore freaking out over here

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • SMB not working anymore freaking out over here

      Today ever since i power up my NAS running OMV, i do not seem to be able to connect to my samba shares from anywhere. My laptop cannot connect, my android phones, nothing. I can connect via web ui to the static ip i have set, and it remains the same, i can connect to the ftp server and see the smb shares from there, but cannot for the life of me access the smb shares directly. I disabled and reenabled the smb service from omv, (applies each time of course) i've reset user accounts, prexeisting and even tried with brand new user credentials, powered off, and rebooted the machine, and for the life of me i cannot connect. I repeat, i can connect to the ftp and see samba from there and to webui from same ip, but access smb directly fails. Seriously wasted all my day trying to fix this and coming up short
    • Shares are of course online, mounted and browseable. Which logs are you refering to. Besides NAS running omv my laptop is running windows. I previously could connect to shares by mapping them as network drives. Now i cannot do that. How do i reach the shares with the jsotname ip method? Im novice in that matter and dont have the nesecary experience. Please tell me which command i should run from either windows or linux console
    • Well none work so...

      I can browse the shares via ftp and remote ssh with putty using my ip, but \\hostname and \\ip do not work

      What logs do you want my to paste here

      Source Code

      1. root@openmediavault3:/var/log/samba# ls
      2. cores log.192.168.1.10 log.desktop-lmkaumh log.nmbd log.smbd
      3. log. log.192.168.1.5 log.mf-tool log.nmbd.1 log.smbd.1.gz
    • donh wrote:

      The logging of samba is off by default. forum.openmediavault.org/index…s-samba-Trouble-shooting/ shows how to enable them.

      Don't know what you changed in fstab but that would be the first thing to look at.
      There is a removable drive that checked for errors at startup and when it was not mounted it nagged me that drive was not fout and had a one and a half minute waiting period ooking to be found. So i removed that line entry from the stab so as not to check for it. But i feel this is harmless. It was an empty test drive, it did not have any files inside and of course no shares or anything at all

      I re-enter the line in fstab, added noauto so it does not automount to check it at bot, but i did not include some of the lines the other drives have like some weird entries that appear (user_xattr,noexec,usrjquota=aquota.user,gr....)

      Could this seriously be it? Why would samba service care that i removed this one line
    • Can you guys please help me fix my fstab

      I also found a tmpfs entry that might be wrong

      I changed it to tmpfs /tmp tmpfs rw,size=1G,noexec,nodev,nosuid 0 0


      which i took from here

      Samba stopped working

      But it did nothing for me still

      Please i have no samba access. Im dying over here
      Images
      • 2018-01-11 16 40 48.jpg

        692.02 kB, 1,366×730, viewed 89 times

      The post was edited 1 time, last by therock003 ().

    • What does systemctl status smbd show?

      Display Spoiler

      root@openmediavault:~# systemctl status smbd
      ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
      Loaded: loaded (/etc/init.d/smbd)
      Active: active (running) since Sun 2017-12-31 19:12:50 MST; 1 weeks 3 days ago
      CGroup: /system.slice/smbd.service
      └─3666 /usr/sbin/smbd -D


      Dec 31 19:12:50 openmediavault smbd[3652]: Starting SMB/CIFS daemon: smbd.
      Dec 31 19:12:50 openmediavault systemd[1]: Started LSB: start Samba SMB/CIFS....
      Dec 31 19:22:38 openmediavault systemd[1]: Reloading LSB: start Samba SMB/CI....
      Dec 31 19:22:38 openmediavault smbd[4797]: Reloading /etc/samba/smb.conf: smbd.
      Dec 31 19:22:38 openmediavault systemd[1]: Reloaded LSB: start Samba SMB/CIF....
      Jan 08 07:35:03 openmediavault systemd[1]: Reloading LSB: start Samba SMB/CI....
      Jan 08 07:35:03 openmediavault smbd[20344]: Reloading /etc/samba/smb.conf: smbd.
      Jan 08 07:35:03 openmediavault systemd[1]: Reloaded LSB: start Samba SMB/CIF....
      Hint: Some lines were ellipsized, use -l to show in full.
      root@openmediavault:~#
      If you make it idiot proof, somebody will build a better idiot.

      The post was edited 1 time, last by donh ().

    • I don't think order is important.
      Display Spoiler

      # /etc/fstab: static file system information.
      #
      # Use 'blkid' to print the universally unique identifier for a
      # device; this may be used with UUID= as a more robust way to name devices
      # that works even if disks are added and removed. See fstab(5).
      #
      # <file system> <mount point> <type> <options> <dump> <pass>
      # / was on /dev/sda1 during installation
      UUID=6aebdd7f-bd8a-44bd-8284-4268b40043e8 / ext4 errors=remount-ro 0 1
      # swap was on /dev/sda5 during installation
      UUID=0c80dc38-2e5b-44e9-8ee0-ccae580f66b6 none swap sw 0 0
      /dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
      tmpfs /tmp tmpfs defaults 0 0
      # >>> [openmediavault]
      /dev/disk/by-label/15TB
      If you make it idiot proof, somebody will build a better idiot.