Failure Sending Webcam Images by FTP

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Failure Sending Webcam Images by FTP

      Hi,

      Yesterday I've installed OpenmediaVault on my Raspberry Pi, it works great, thanks for that!
      There’s only one problem, it’s similar to this thread: Failure Sending Webcam Images by FTP but I’m really new to OMV and Linux, and I don’t understand how the problem is solved.

      I’ve created a shared folder and configure the user access, then I configure the FTP.
      I connect in my own LAN with FileZilla to the PI, I can login, I can access the created folder, I can read and write in that folder without any problem.
      I’ve a Foscam IP camera. FTP upload works fine with another FTP server, but not in OMV.
      Settings:
      Local LAN: 10.0.0.0 / 255.0.0.0
      IP OMV: 10.0.1.250
      IP CAM: 10.0.1.11
      Default Gateway: 10.0.0.1

      Attached you can see some images, hopefully somebody can help me, so I can fix this.

    • Yes, I cannot change it. When I remove it and replace it to /IPCAM, the dot is automatically set again and the Pat is ./IPCAM again. It works fine with the FTP on my Asus router. I’ve insert an USB, setup the FTP, configure the folder, setup the camera with the same, ./folder and it works. I cannot change or remote those dot.
    • subzero79 wrote:

      It could be a permission issue. Even if privilege is enabled for that user in that folder the owner and mod might not be correct.

      Post here
      cat /etc/proftpd/proftpd.conf
      Thank you, here's the output:

      root@raspberrypi:~# cat /etc/proftpd/proftpd.conf
      Include /etc/proftpd/modules.conf
      LoadModule mod_vroot.c
      UseIPv6 on
      ServerName "raspberrypi"
      ServerType standalone
      DeferWelcome on
      MultilineRFC2228 on
      DefaultServer on
      ShowSymlinks on
      DisplayChdir .message true
      ListOptions "-l"
      MaxInstances 30
      DenyFilter \*.*/
      User proftpd
      Group nogroup
      Umask 000 000
      PersistentPasswd off
      TimesGMT off
      AllowOverwrite on
      AuthOrder mod_auth_pam.c* mod_auth_unix.c
      DefaultTransferMode ascii
      #SystemLog /var/log/proftpd/proftpd.log
      <IfModule mod_facl.c>
      FACLEngine on
      </IfModule>
      <IfModule mod_quotatab.c>
      QuotaEngine off
      </IfModule>
      <IfModule mod_ratio.c>
      Ratios off
      </IfModule>
      <IfModule mod_delay.c>
      DelayEngine on
      </IfModule>
      <IfModule mod_ctrls.c>
      ControlsEngine on
      ControlsMaxClients 2
      ControlsLog /var/log/proftpd/controls.log
      ControlsInterval 5
      ControlsSocket /var/run/proftpd/proftpd.sock
      </IfModule>
      <IfModule mod_ctrls_admin.c>
      AdminControlsEngine off
      </IfModule>
      <IfModule mod_vroot.c>
      VRootEngine on
      VRootLog /var/log/proftpd/vroot.log
      </IfModule>
      Port 21
      TransferLog NONE
      IdentLookups off
      UseReverseDNS off
      TimeoutIdle 0
      TimeoutNoTransfer 600
      TimeoutStalled 600
      PassivePorts 49152 65534
      DeleteAbortedStores off
      <Directory />
      HideFiles (welcome.msg)
      </Directory>
      <IfModule mod_vroot.c>
      VRootAlias "/srv/dev-disk-by-label-32GB/IPCAM" "IPCAM"
      </IfModule>
      <Directory /IPCAM>
      <Limit ALL>
      AllowUser OR ejvl
      DenyAll
      </Limit>
      <Limit READ DIRS>
      AllowUser OR ejvl
      DenyAll
      </Limit>
      </Directory>
      <IfModule mod_auth.c>
      DefaultRoot /srv/ftp
      MaxClients 5
      MaxLoginAttempts 3
      RequireValidShell off
      # This option is useless because this is handled via the PAM
      # pam_listfile.so module, so set it to 'off' by default.
      UseFtpUsers off
      </IfModule>
      <IfModule mod_auth_pam.c>
      AuthPAM on
      AuthPAMConfig proftpd
      </IfModule>
      <IfModule mod_ban.c>
      BanEngine off
      BanControlsACLs all allow user root
      BanLog /var/log/proftpd/ban.log
      BanMessage Host %a has been banned
      BanTable /var/run/proftpd/ban.tab
      </IfModule>
      DisplayLogin /srv/ftp/welcome.msg
      <IfModule mod_wrap.c>
      TCPAccessFiles /etc/hosts.allow /etc/hosts.deny
      TCPAccessSyslogLevels info warn
      TCPServiceName ftpd
      </IfModule>
    • Here's the output:

      root@raspberrypi:~# ls -la "/srv/dev-disk-by-label-32GB/IPCAM"
      total 104
      drwxrwxrwx 2 root root 102400 Jan 13 16:38 .
      drwxr-xr-x 7 root root 4096 Jan 12 11:39 ..
      root@raspberrypi:~#

      Today and yesterday I've put files manually in the folder, by Windows folder in File Explorer.
    • subzero79 wrote:

      Permissions look fine in the folder. Does the camera sw produce any logs ?
      Unfortunately it's a very old IPCAM, a Foscam FI8602W.
      I've connected another IPCamera, a Foscam FI9831P, and there all works fine.
      So, OMV works great with FTP because the FI9831P works fine.

      But I'm still wondering why the FI8602W does not work, and the mod_wrap error appears in OMV.
      For now, I've setup my Asus AC51u router as a FTP server, with a USB stick. The FI8602W push the images by FTP to the Asus. In OMV I use a plugin so I can see the shared folder off my Asus as a local shared folder in OMV, so I can use Rsync to push the images to OMV.
    • Try turning on ident protocol. I had to select that to get my foscam C1 to talk to the ftp server. The folder also needed to be manually created with correct permissions for the camera's acct. I wouldn't be concerned about the dot. I'm guessing that's the linux current path reference.
    • jmccusker wrote:

      Try turning on ident protocol. I had to select that to get my foscam C1 to talk to the ftp server. The folder also needed to be manually created with correct permissions for the camera's acct. I wouldn't be concerned about the dot. I'm guessing that's the linux current path reference.
      Could you explain how you manually created the folder with correct permissions? I'm running into a similar issue where it doesn't have list permissions. Thanks!
    • I created a user called IpCameras that the cameras use as a login. That alone should provide a home directory with read/write. I also have a group called grpIPCAMERAS. I have my acct and the cameras acct as members of that group. I created a shared folder and gave that group read/write under priveleges and ACL.

      FYI - I'm not a computer engineer and am fairly new to linux and downloaded OMV for the first time yesterday. I found this thread trying to solve the same problem without being able to get my cams to work. I'll help if I can, but I'm no expert. ;)