Suddenly trouble with root filesystem getting destroyed

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Suddenly trouble with root filesystem getting destroyed


      I recently cloned my OMV-installation onto another USB-stick. To do that I bootet into a live-cd and used the command if=/dev/sdx of=/dev/sdy bs=4K . It all went fine and worked for weeks.

      Yesterday though the system would not boot anymore. It gave me the following error:
      error: file '/boot/grub/i386-pc/normal.mod' not found.
      Entering rescue mode...

      When I tried to fix the problem using a Linux live-cd I discovered that the file system on the USB-stick was damaged and I could not repair it with fsck either.
      I then went for the easiest solution and cloned the old USB-stick again onto the new one. OMV then bootet again.

      I then decided to update it but could not do it since it told me that "/var/cache/apt/archives/partial" was read only. I already assumed that I'm back into trouble and wondered if the root-filesystem is damaged again. To find out I initiated a reboot and sure enough I received the "error: file '/boot/grub/i386-pc/normal.mod' not found."-error again.

      Before all this I had tested the new USB-stick with H2testw for errors, but it looked all good.

      Does anyone have any clue what's going on?

      Thanks for reading!

      *EDIT* I once again checked the USB-stick with H2testw and it tested it successfully.

      The post was edited 2 times, last by villeneuve ().

    • New

      Are you using the Flash Memory plugin on OMV? Your USB stick will likely be worn out without the plugin being used. But you seem to be having problems much sooner that I would expect, if wear was the problem.

      Are your USB sticks well known reliable brand names?
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • Users Online 2

      2 Guests