Deleted /var/cache or How do I reinstall the web-gui?

    • Deleted /var/cache

      Hey,
      as I was running out of diskspace on the systemdisk, I deleted everything in /var/cache - I now know that this was not a good idea...

      I manually created /var/cache/openmediavault/ and /var/cache/openmediavault/archives - Afterwards apt-get was working again.

      However, the web-gui is not working. I get the following message in the browser:
      Error #0:
      OMV\Exception: Failed to open file
      (filename=/var/cache/openmediavault/cache.omv\controlpanel\login_js.json,
      mode=w+). in /usr/share/php/openmediavault/json/file.inc:71
      Stack trace:
      #0 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(183): OMV\Json\File->open('w+')
      #1 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
      #2 {main}

      Makes sense as cache.omv does not exist. However, even after creating this manually, the web-gui is not working. Also, the tools under omv-firstaid did not solve anything. I also tried the release-upgrade to version 4 which was available. No luck either.

      How can I reinstall the web-gui? (And everything else that was in /var/cache/openmediavault/ that I might have lost...)
      Or what folders do I need to setup in /var/cache/ ?

      Thanks for the help!
    • I have the following in my /var/cache which totals 82MB of files.

      60.3 MiB [##########] /apt
      12.0 MiB [# ] /apt-show-versions
      8.5 MiB [# ] /debconf
      1.4 MiB [ ] /man
      572.0 KiB [ ] /samba
      60.0 KiB [ ] /openmediavault
      36.0 KiB [ ] /fontconfig
      4.0 KiB [ ] /pm-utils
      4.0 KiB [ ] /ldconfig

      I would expect the contents to be very specific to my machine and not usable for a recovery effort on another machine.

      Hopefully someone else will chime in with better news.
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • Thanks, but that did not work out...

      When I unpack the file, I see this:
      # ll openmediavault
      total 56K
      -rw-r--r-- 1 root root 13K Jan 12 16:51 CJ31DM~0
      -rw-r--r-- 1 root root 283 Jan 12 16:51 CRJR5D~1
      drwxr-xr-x 2 root root 4.0K Jan 12 15:13 archives
      -rw-r--r-- 1 root root 31K Jan 12 15:13 currently_installed_packages.list

      Is that the same that you see in your folder?

      According to my error message, I am lacking the file "/var/cache/openmediavault/cache.omv\controlpanel\login_js.json"

      I was really hoping to avoid a reinstall of openmediavault... Irgh.
    • Users Online 1

      1 Guest