Feature Request: Option to set Sharedfolder Mounts to execute in OMV Webinterface

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Feature Request: Option to set Sharedfolder Mounts to execute in OMV Webinterface

      Hello Dev Team,

      i use OMV for a while now and replaced my old server with a fresh one, running the new OMV 4.x .
      Since i use many Docker Containers for ease of use and uncomplicated usage and aswell tend to run some servers from my Server I was at least annoyed in the old Versions that every connected mount in the OMV installation that was created via the Webinterface got the option "noexecute" , which is fairly a good use for a fileserver only share but not so great if you want to do more and are limied by the system drive.
      Workaround is to remount the affected mounts with the option execute set or to set additional the flag in the mount setting in fstab. Later setting was forgotten in the last time and so through several reboots caused from Kernel Updates over the last week and other Updates that were needed for Security reasons, every now and then parts of my Software stopped to work.

      Today i found additional that the noexecute option affects aswell Docker Containers with physical mounts on the share after i tried to dockerize my gitlab installation, the included nginx server did not start, after setting the flag for the installation share, it worked again. Same behaviour with gogs, the included webserver did not startup if i did not change the flag before.

      However, since I found several Topics in the forum about this non Execute Setting, I think it would be nice to be able to set the option for this upon creating / changing the shares through the webinterface.
    • And again got in trouble with this.

      If plex is installed the standard path is on the OS partition, which is not a good solution, so I moved it to a shared folder, so that the growing Media Library Folder ( where the Meta Data is stored ), can use more space and not trash the whole system partition.
      However, this lead to another problem: the Media Folder was moved and plex was able to start, but when i tried to see a show on plex the transcoder stopped with an crash, caused from the fact that additional to the MetaData the .so files for the Codecs for Media Transcoding were placed into the same folders.