[SOLVED] Remote Mount Plugin: How to mount an HDD that is connected to a Fritz!Box 7490

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [SOLVED] Remote Mount Plugin: How to mount an HDD that is connected to a Fritz!Box 7490

      Hi,

      OMV 3.0.91 (Kernel Linux 4.13.13-sunxi 64) runs on an OrangePi Zero Plus, which is connected thru LAN directly to a Fritz!Box (FB) 7490. An external USB 3.0 HDD (NTFS) is attached to the FB. Fritz.NAS is configured properly and works fine, particularly access from Windows PCs. Serveral FB users do have read and write authorizations to the main share 'TOSHIBA-ExternalUSB3-0-01' (the entire external HDD). The OMV user 'SonneOrangePi' exists within OMV and the OPI0+ and the FB. This user has everywhere the same password. Within OMV the user 'SonneOrangePi' is currently assigned to all user groups with all priviliges - at the moment, for testing.

      Now, I'd like to configure the OMV Remote Mount plugin (test repo) to mount the FB HDD.

      Mount Type: SMB/CIFS
      Name: FritzBoxFestplatte
      Server: 192.168.178.1
      Share: TOSHIBA-ExternalUSB3-0-01
      Username: SonneOrangePi
      Password: ***
      Options: _netdev,iocharset=utf8



      Unfortunately, this configuration doesn't work. Following error occurs:

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount -v '/srv/6503e140-ec6b-4f09-9728-aff451ccf77a' 2>&1' with exit code '32': mount.cifs kernel mount options: ip=192.168.178.1,unc=\\192.168.178.1\TOSHIBA-ExternalUSB3-0-01,iocharset=utf8,user=SonneOrangePi,pass=******** mount error(79): Can not access a needed shared library Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

      Fehler #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount -v '/srv/6503e140-ec6b-4f09-9728-aff451ccf77a' 2>&1' with exit code '32': mount.cifs kernel mount options: ip=192.168.178.1,unc=\\192.168.178.1\TOSHIBA-ExternalUSB3-0-01,iocharset=utf8,user=SonneOrangePi,pass=********mount error(79): Can not access a needed shared libraryRefer to the mount.cifs(8) manual page (e.g. man mount.cifs)' in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/system/filesystem/remote.inc(427): OMV\System\Process->execute()#1 /usr/share/openmediavault/engined/module/fstab.inc(72): OMV\System\Filesystem\Remote->mount()#2 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleFsTab->startService()#3 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusCt...', '/tmp/bgoutputpG...')#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#8 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#9 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#11 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#12 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#13 {main}

      What changes are required for a proper configuration?

      Thanks in advance for your support,
      Joe
      OrangePi Zero Plus + ext. 2 TB HDD Western Digital WDBAAU0010HBK-01; Pioneer VSX-S520D + BDP-X300; Quadral Tornado; Panasonic Viera TX-L42V20E; Intel NUC 5i5RYH (Win. 10 Pro 64); TT-connect CT-3650 CI; Fritz!Box 7490; Archgon Panasonic UJ-272; DVBViewer Pro+Mediaserver; Kodi; Pulse 8 CEC HDMI; Logitech LR Keyboard K830

      The post was edited 3 times, last by Joe_PS ().

    • Joe_PS wrote:

      mount error(79): Can not access a needed shared libraryRefer to the mount.cifs
      This message says most of what you need. What is the output of: grep -i nls_utf8 /boot/config*
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      grep -i nls_utf8 /boot/config*
      root@sonneorangepi:~# grep -i nls_utf8 /boot/config*
      # CONFIG_NLS_UTF8 is not set

      Sorry, as a newbie I haven't got, where the needed shared library can't be accessed (or is missing)? On the OPI0+ side, or on the Fritz!Box side? And: what to do next, please?
      Thanks, Joe
      OrangePi Zero Plus + ext. 2 TB HDD Western Digital WDBAAU0010HBK-01; Pioneer VSX-S520D + BDP-X300; Quadral Tornado; Panasonic Viera TX-L42V20E; Intel NUC 5i5RYH (Win. 10 Pro 64); TT-connect CT-3650 CI; Fritz!Box 7490; Archgon Panasonic UJ-272; DVBViewer Pro+Mediaserver; Kodi; Pulse 8 CEC HDMI; Logitech LR Keyboard K830
    • Joe_PS wrote:

      Sorry, as a newbie I haven't got, where the needed shared library can't be accessed (or is missing)? On the OPI0+ side, or on the Fritz!Box side? And: what to do next, please?
      Your fritzbox shares have utf8 enabled. Therefore, your orange pi needs the utf8 module to mount those shares. Since it does not have that module enable, there really is no way to mount it without changing the kernel. Are you using one of the OMV images? Why not move the drive to the OMV box?
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Are you using one of the OMV images?
      Yes, I installed OMV_3_0_91_Orangepizeroplus_4.13.13.img.xz. Is it possible to install only the missing nls_utf8.ko module?

      I do have an OrangePi Zero Plus, which has only one classical USB Port that is already used to attach an older external USB 2.0 HDD (Western Digital). My idea has been to mount also the Toshiba-HDD remotely, which is attached to the Fritz!Box (and should be connected to it), because data transfer and miniDLNA (particularly for FLAC files) is much more convenient and faster on the OPI0+ OMV combination than the built-in Fritz!NAS.
      OrangePi Zero Plus + ext. 2 TB HDD Western Digital WDBAAU0010HBK-01; Pioneer VSX-S520D + BDP-X300; Quadral Tornado; Panasonic Viera TX-L42V20E; Intel NUC 5i5RYH (Win. 10 Pro 64); TT-connect CT-3650 CI; Fritz!Box 7490; Archgon Panasonic UJ-272; DVBViewer Pro+Mediaserver; Kodi; Pulse 8 CEC HDMI; Logitech LR Keyboard K830

      The post was edited 1 time, last by Joe_PS: Typo ().

    • Joe_PS wrote:

      Is it possible to install only the missing nls_utf8.ko module?
      You need to compile a new kernel or ask armbian to include it in the default config. I don't have any armhf boxes powered up at the moment but I am guessing it isn't just an orange pi issue.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      ask armbian to include it in the default config
      The armbian experts included the relevant module, which I've got via apt-get upgrade (Armbian 5.3.8, Linux 8 jessie 4.14.15-sunxi64).

      Now, a different error occurs, which is confusing for me: "mount error(112): Host is down"

      In contrast to the error message, the host is definitely up and running. The "SonneMediaserver" is also up and running.

      What should I do to for further investigation?

      Thanks in advance, Joe

      Fehler #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; mount -v '/srv/60448ae7-005a-473c-8c70-2d59cb64b2f8' 2>&1' with exit code '32': mount.cifs kernel mount options: ip=192.168.178.1,unc=\\192.168.178.1\TOSHIBA-ExternalUSB3-0-01,iocharset=utf8,user=SonneOrangePi,pass=********mount error(112): Host is downRefer to the mount.cifs(8) manual page (e.g. man mount.cifs)' in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/system/filesystem/remote.inc(427): OMV\System\Process->execute()#1 /usr/share/openmediavault/engined/module/fstab.inc(72): OMV\System\Filesystem\Remote->mount()#2 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleFsTab->startService()#3 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatus9n...', '/tmp/bgoutputVk...')#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#8 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#9 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#11 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#12 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#13 {main}
      OrangePi Zero Plus + ext. 2 TB HDD Western Digital WDBAAU0010HBK-01; Pioneer VSX-S520D + BDP-X300; Quadral Tornado; Panasonic Viera TX-L42V20E; Intel NUC 5i5RYH (Win. 10 Pro 64); TT-connect CT-3650 CI; Fritz!Box 7490; Archgon Panasonic UJ-272; DVBViewer Pro+Mediaserver; Kodi; Pulse 8 CEC HDMI; Logitech LR Keyboard K830
    • UPDATE

      I used the root share folder within the Remote Mount settings (Share: Sonne; instead of TOSHIBA-ExternalUSB3-0-01). Additionally, I included also the option 'vers=1.0' (Options: _netdev,iocharset=utf8,vers=1.0).

      This works.
      OrangePi Zero Plus + ext. 2 TB HDD Western Digital WDBAAU0010HBK-01; Pioneer VSX-S520D + BDP-X300; Quadral Tornado; Panasonic Viera TX-L42V20E; Intel NUC 5i5RYH (Win. 10 Pro 64); TT-connect CT-3650 CI; Fritz!Box 7490; Archgon Panasonic UJ-272; DVBViewer Pro+Mediaserver; Kodi; Pulse 8 CEC HDMI; Logitech LR Keyboard K830