Data migration

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Data migration

      I just got my hands on a new server. I'm running VMware on it and OMV is one of the VMs. I've installed OMV, added and mounted my data disk (EXT4) and am now ready to migrate my 2TB of data from my old server (fedora with NTFS drive) on to OMV. I think rsync is the way to go here but I'm having some trouble with it. Both servers have SSH access and both have rsync on them. I've read some threads in this forum and understand that OMV's rsync GUI is not interactive so cannot handle passwords.

      I've uploaded OMV's public key to my old fedora server and tested an rsync job using the GUI. The job is configured as a 'pull' from the remote fedora server but I am using the password option. I cannot select anything under the passphrase option so didn't use that. It looks like it can login and connect to that fedora server but the job breaks down pretty quickly with an error about broken pipes and another one about file attributes not being transferred.

      I've tried to find a guide or thread that helps with this process but haven't come across any.

      The post was edited 1 time, last by spinach ().

    • Assuming the data on your remote server is in network share:

      Have you tried the remote mount plugin? With remote mount you can set a user and password, which will get you into the remote servers share. At that point, the remote folder becomes the equivalent of a local filesystem on OMV.

      You'll need two shared folders. One for the remote mount and another one on OMV.
      ________________________________________________

      (Also, note the path when you set up a shared folder for the remotely mounted folder, highlighted as follows:)



      You want the root of the remote folder.
      ____________________________________________________________


      From there, setup up an Rsync job with the source being the locally mounted remote folder (from the remote server), with the destination being an OMV shared folder. (**Note - the Rsync job type is LOCAL.**)
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.99 Erasmus
      ThinkServer TS140, 12GB ECC / 32GB USB3.0
      4TB SG+4TB TS ZFS mirror/ 3TB TS

      OMV 3.0.99 Erasmus - Rsync'ed Backup
      R-PI 2 $29 / 16GB SD Card $8 / Real Time Clock $1.86
      4TB WD My Passport $119
    • Yes, that was helpful. Thanks, subzero79!

      It helped me understand that I can use password authentication to run the rsync job. After screwing up my VM and reinstalling it, I also discovered even using password authentication, I would still need to share my ssh key with my original fedora server before rsync would run. Easily done with the following command on my OMV:

      ssh-copy-id targetmachine

      I also needed to be careful with my "/" when specifying the remote directory in the rsync webgui. I needed one before my folder name.

      Once I figured all this out, my rsync job worked.
    • I spoke too fast. The rsync job started up fine so I walked away. When I came back, I was faced with an error box that screamed, "Communication Failure".

      I thought my rsync job was timing out so I turned off my screensaver and power management stuff, plugged in the laptop and started the job again. It started up OK but threw up the same error.

      Could it be the disk or VM resources? I've got 8 GBs on this with 4 cores, which I assume is enough, but I can add more. LAN is all gigabit. HD is a bit old but it formatted OK.
    • Just realized I didn't close this thread. I did turn on notifications but I think the rsync was still failing. I was unable to tell with such a big job (2TB) whether it was still running or not.

      I ended up rsyncing individual folders and that worked fine, though it did take a bit more babysitting.

      Thanks for the help, everyone.
    • On big job's, I've had the "Com failure" before. @subzero79 is correct in that the rsync job is still running - I've verified it. In fact, if you lose the Web dialog box, you'd have to go in to the CLI to cancel the job.

      For big sync jobs I set the "Keep partially transferred files", schedule it, and check the Rsycn Job log well after the fact. On the rare occasion where the job didn't complete, it was an interruption of the link or on the remote end.
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.99 Erasmus
      ThinkServer TS140, 12GB ECC / 32GB USB3.0
      4TB SG+4TB TS ZFS mirror/ 3TB TS

      OMV 3.0.99 Erasmus - Rsync'ed Backup
      R-PI 2 $29 / 16GB SD Card $8 / Real Time Clock $1.86
      4TB WD My Passport $119