Error activating smb "The property 'nullpasswords' does not exist in the model 'conf.service.smb'."

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Error activating smb "The property 'nullpasswords' does not exist in the model 'conf.service.smb'."

      Running OMV 4 and whenever I try and activate samba i get the following error (in the webgui)

      The property 'nullpasswords' does not exist in the model 'conf.service.smb'.

      Source Code

      1. Fehler #0:
      2. OMV\AssertException: The property 'nullpasswords' does not exist in the model 'conf.service.smb'. in /usr/share/php/openmediavault/config/configobject.inc:71
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/config/configobject.inc(186): OMV\Config\ConfigObject->assertExists('nullpasswords')
      5. #1 /usr/share/php/openmediavault/config/configobject.inc(271): OMV\Config\ConfigObject->set('nullpasswords', false, true)
      6. #2 /usr/share/php/openmediavault/config/configobject.inc(233): OMV\Config\ConfigObject->setFlatAssoc(Array, true, false)
      7. #3 /usr/share/openmediavault/engined/rpc/smb.inc(79): OMV\Config\ConfigObject->setAssoc(Array)
      8. #4 [internal function]: OMVRpcServiceSmb->setSettings(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('setSettings', Array, Array)
      11. #7 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('SMB', 'setSettings', Array, Array, 1)
      12. #8 {main}
      Display All
      I didn't mess around in any conf files.
      Just setup docker and a few shared folders and now I can't start samba.
      Any ideas?
    • I have same problem, but clear cache is not solution. Last time i solved after restore afected files from backup, but after upgrade to openmediavault 4.1.1-1 not work.

      Source Code

      1. Error #0: OMV\AssertException: The property 'nullpasswords' does not exist in the model 'conf.service.smb'. in /usr/share/php/openmediavault/config/configobject.inc:71 Stack trace: #0 /usr/share/php/openmediavault/config/configobject.inc(186): OMV\Config\ConfigObject->assertExists('nullpasswords') #1 /usr/share/php/openmediavault/config/configobject.inc(271): OMV\Config\ConfigObject->set('nullpasswords', '1', false) #2 /usr/share/php/openmediavault/config/configobject.inc(233): OMV\Config\ConfigObject->setFlatAssoc(Array, false, false) #3 /usr/share/php/openmediavault/config/database.inc(90): OMV\Config\ConfigObject->setAssoc(Array, false) #4 /usr/share/openmediavault/engined/module/samba.inc(72): OMV\Config\Database->get('conf.service.sm...') #5 /usr/share/openmediavault/engined/rpc/services.inc(56): OMVModuleSamba->getStatus() #6 [internal function]: OMVRpcServiceServices->getStatus(Array, Array) #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array) #8 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getStatus', Array, Array) #9 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 1) #10 {main}
    • Ok similar problem here. It satrted when I tried to make a systemBU to USB. Had on WebGUI the same as described in the first thread. followed the procedure to empty the cache, no help.
      deletd the nullpassword entry completely in the config.xml
      after a reboot i was faced with this

      Source Code

      1. The property 'shares.share.0.name' does not exist in the model 'conf.service.smb'.
      2. Fehler #0:
      3. OMV\AssertException: The property 'shares.share.0.name' does not exist in the model 'conf.service.smb'. in /usr/share/php/openmediavault/config/configobject.inc:71
      4. Stack trace:
      5. #0 /usr/share/php/openmediavault/config/configobject.inc(186): OMV\Config\ConfigObject->assertExists('shares.share.0....')
      6. #1 /usr/share/php/openmediavault/config/configobject.inc(271): OMV\Config\ConfigObject->set('shares.share.0....', 'Daten', false)
      7. #2 /usr/share/php/openmediavault/config/configobject.inc(233): OMV\Config\ConfigObject->setFlatAssoc(Array, false, false)
      8. #3 /usr/share/php/openmediavault/config/database.inc(90): OMV\Config\ConfigObject->setAssoc(Array, false)
      9. #4 /usr/share/openmediavault/engined/module/samba.inc(72): OMV\Config\Database->get('conf.service.sm...')
      10. #5 /usr/share/openmediavault/engined/rpc/services.inc(56): OMVModuleSamba->getStatus()
      11. #6 [internal function]: OMVRpcServiceServices->getStatus(Array, Array)
      12. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      13. #8 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getStatus', Array, Array)
      14. #9 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 1)
      15. #10 {main}
      Display All

      Lost in space ?( ?( ?( ?(

      BTW: reinstalling the openmediavault-backup 4.0.4 terminated with following message:

      Source Code

      1. xception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fdfd8445730>
      2. Traceback (most recent call last):
      3. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      4. TypeError: 'NoneType' object is not callable
      5. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fdfd8445730>
      6. Traceback (most recent call last):
      7. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      8. TypeError: 'NoneType' object is not callable
      9. Fertig ...
      Don't know if important..............., reinstallation didn't help.............

      The post was edited 2 times, last by pierre2000 ().