OMV on QNAP TS-221: Installation - Does and Don't

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV on QNAP TS-221: Installation - Does and Don't

      Days ago a QNAP TS-221 came across my way. Want to saddle it up with OMV 4. Acc to my first researches there is a way to install Stretch (also good for HS-210, TS-210, TS-212, TS-212-E, TS-212P, TS-219, TS-219P, TS-219P+, TS-219P II, TS-220) on the QNAP-Device. Is it straight forward to install OMV? Is there a tut for doing so?

      Bye
      Micha
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras

      The post was edited 2 times, last by mipi ().

    • These are generic instructions that miss all the necessary performance tweaks for ARM devices. Better follow these instructions and use our optimized installation variant for slow ARM devices that run off flash media: OMV 4 image for Raspberrypi

      Basically it's just copy&paste of three simple lines and then choosing --> Install OMV in a menu driven application called 'softy':

      Source Code

      1. sudo apt install git
      2. git clone https://github.com/armbian/config
      3. sudo /bin/bash config/softy
    • Good advice, thank you! But I don't understand, shall use the tutorial to install debian and then your article ... Think I will progress in a few days ....

      PS: Ich habe mal in den thread reingelesen, aber das verstehe ich nicht im einzelnen, ist nicht eben ein tutorial. Wie geht man denn damit um, dass das NAS kein Display zum Feedback gibt? Das Tut das ich oben genannt habe geht zumindest auf solche unüberwachten Installionsschritte ein ....


      Bye Micha from Berlin
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras

      The post was edited 2 times, last by mipi ().

    • mipi wrote:

      shall use the tutorial to install debian and then your article
      Use serial console or SSH (or whatever you used to install Debian in the first place) and then it's still this rather simple copy&paste job (then choosing 'Install OMV'):

      Source Code

      1. sudo apt install git
      2. git clone https://github.com/armbian/config
      3. sudo /bin/bash config/softy
    • Hmmm ... tried to install debian after the tutorial, but it crashes when downloading the additional components. I have no idea how to get it up and running. Unfortunately it boots only every 2-3 bootcycles completely into the shell/ssh

      Any hints what I can do?
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras

      The post was edited 2 times, last by mipi ().

    • Trickled a little around, know how to boot it correctly, but the installer breaks after 10, sometimes 20 Files with (for example) "Failed to load installer component - Loading partman-btrfs failed for unknown reasons. Aborting." tested it more th xx times --- means xx + one more time rebooting ...
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras

      The post was edited 1 time, last by mipi ().

    • The installer for Stretch wont work for my qnap device. Installed Jessie insted ... While OMV 3 would be enough for my needs, would OMV change the Debian-Version when it updates to 4 ... is this a suitable way for updating from Debian 8 to 9 by using the above mentioned code

      Source Code

      1. sudo apt install git
      2. git clone https://github.com/armbian/config
      3. sudo /bin/bash config/softy
      What is on the other side the correct way to install OMV 3 on Jessie?

      Bye Micha
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras
    • mipi wrote:

      While OMV 3 would be enough for my needs, would OMV change the Debian-Version when it updates to 4
      Yes, OMV4 relies on Debian 9 and an upgrade will also uopdate the underlying OS. Stretch requires a rather recent kernel (IIRC 3.14) for all features to work so better check this first.

      And yes, on your slow ARM device the only advisable way to install OMV 3 or 4 is via armbian-config since then you end up with settings that increase performance and endurance of your installation media.
    • tkaiser wrote:

      And yes, on your slow ARM device the only advisable way to install OMV 3 or 4 is via armbian-config since then you end up with settings that increase performance and endurance of your installation media.
      Sorry, I'm not sure I got it right: Can you tell me the way to install OMV 3 on Debian 8 via armbian-config. Sorry if it is redundant ...

      Is this forum-bpi.de/viewtopic.php?f=52&t=297#p1278 the right way?
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras

      The post was edited 1 time, last by mipi ().

    • Get this:

      Source Code

      1. root@qnap:~# /bin/bash config/softy
      2. config/softy: Zeile 1087: /etc/resolvconf/resolv.conf.d/head: Datei oder Verzeichnis nicht gefunden
      3. config/softy: Zeile 1088: resolvconf: Kommando nicht gefunden.
      4. W: Operation wurde unterbrochen, bevor sie beendet werden konnte.
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras
    • more detailled:

      Source Code

      1. -su: sudo: Kommando nicht gefunden.
      2. root@qnap:~# apt install git
      3. Paketlisten werden gelesen... Fertig
      4. Abhängigkeitsbaum wird aufgebaut.
      5. Statusinformationen werden eingelesen.... Fertig
      6. Die folgenden zusätzlichen Pakete werden installiert:
      7. git-man liberror-perl rsync
      8. Vorgeschlagene Pakete:
      9. git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svn
      10. Die folgenden NEUEN Pakete werden installiert:
      11. git git-man liberror-perl rsync
      12. 0 aktualisiert, 4 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.
      13. Es müssen 4.384 kB an Archiven heruntergeladen werden.
      14. Nach dieser Operation werden 21,2 MB Plattenplatz zusätzlich benutzt.
      15. Möchten Sie fortfahren? [J/n]
      16. Holen: 1 http://ftp.de.debian.org/debian/ jessie/main liberror-perl all 0.17-1.1 [22,4 kB]
      17. Holen: 2 http://security.debian.org/ jessie/updates/main rsync armel 3.1.1-3+deb8u1 [373 kB]
      18. Holen: 3 http://ftp.de.debian.org/debian/ jessie/main git-man all 1:2.1.4-2.1+deb8u5 [1.268 kB]
      19. Holen: 4 http://ftp.de.debian.org/debian/ jessie/main git armel 1:2.1.4-2.1+deb8u5 [2.721 kB]
      20. Es wurden 4.384 kB in 1 s geholt (4.206 kB/s).
      21. Vormals nicht ausgewähltes Paket liberror-perl wird gewählt.
      22. (Lese Datenbank ... 27886 Dateien und Verzeichnisse sind derzeit installiert.)
      23. Vorbereitung zum Entpacken von .../liberror-perl_0.17-1.1_all.deb ...
      24. Entpacken von liberror-perl (0.17-1.1) ...
      25. Vormals nicht ausgewähltes Paket git-man wird gewählt.
      26. Vorbereitung zum Entpacken von .../git-man_1%3a2.1.4-2.1+deb8u5_all.deb ...
      27. Entpacken von git-man (1:2.1.4-2.1+deb8u5) ...
      28. Vormals nicht ausgewähltes Paket git wird gewählt.
      29. Vorbereitung zum Entpacken von .../git_1%3a2.1.4-2.1+deb8u5_armel.deb ...
      30. Entpacken von git (1:2.1.4-2.1+deb8u5) ...
      31. Vormals nicht ausgewähltes Paket rsync wird gewählt.
      32. Vorbereitung zum Entpacken von .../rsync_3.1.1-3+deb8u1_armel.deb ...
      33. Entpacken von rsync (3.1.1-3+deb8u1) ...
      34. Trigger für man-db (2.7.0.2-5) werden verarbeitet ...
      35. Trigger für systemd (215-17+deb8u7) werden verarbeitet ...
      36. liberror-perl (0.17-1.1) wird eingerichtet ...
      37. git-man (1:2.1.4-2.1+deb8u5) wird eingerichtet ...
      38. git (1:2.1.4-2.1+deb8u5) wird eingerichtet ...
      39. rsync (3.1.1-3+deb8u1) wird eingerichtet ...
      40. Trigger für systemd (215-17+deb8u7) werden verarbeitet ...
      41. root@qnap:~# git clone https://github.com/armbian/config
      42. Klone nach 'config'...
      43. remote: Counting objects: 1071, done.
      44. remote: Compressing objects: 100% (3/3), done.
      45. remote: Total 1071 (delta 0), reused 1 (delta 0), pack-reused 1068
      46. Empfange Objekte: 100% (1071/1071), 1.58 MiB | 1.11 MiB/s, Fertig.
      47. Löse Unterschiede auf: 100% (649/649), Fertig.
      48. Prüfe Konnektivität... Fertig.
      49. root@qnap:~# sudo /bin/bash config/softy
      50. -su: sudo: Kommando nicht gefunden.
      51. root@qnap:~# /bin/bash config/softy
      52. config/softy: Zeile 1087: /etc/resolvconf/resolv.conf.d/head: Datei oder Verzeichnis nicht gefunden
      53. config/softy: Zeile 1088: resolvconf: Kommando nicht gefunden.
      54. W: Operation wurde unterbrochen, bevor sie beendet werden konnte.
      Display All
      ____________________
      Grüße aus Berlin

      Q29000-ITX
      omv 4.1.8.2 | 64 bit | backport kernel | omvextras
    • mipi wrote:

      -su: sudo: Kommando nicht gefunden.
      Since you're already root no need for sudo. So simply use the commands without prefixing with sudo.

      Besides that many people will tell to never work as root, create an own sudo enabled user account but that would also require to install the sudo package before ('apt install sudo'). Seems your Debian install is pretty limited :)
    • This script is not written for performance improvement or I wrote that it should improve performance,
      it's a stink-normal installer script.,
      Armbian & forum.banana-pi.org/ are responsible for the performance.
      One should think before when one writes something, oh something else this idea. Armian & OMV was from Benny, I had contact with at this time.
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)