Plex media server won't start

    • OMV 3.x
    • Resolved
    • Plex media server won't start

      After reinstalling Plex it wil not start anymore. Needed to reinstall because for some weird reason it wouldn't connect to my parents tv as i moved the nas to their house.

      Tried the uninstall, apt-clean, restart, instal, restart,

      Did some searching and got some more details;

      root@nas-hans:~# sudo service plexmediaserver start
      root@nas-hans:~# sudo service plexmediaserver status
      ● plexmediaserver.service - Plex Media Server for Linux
      Loaded: loaded (/lib/systemd/system/plexmediaserver.service; disabled)
      Active: activating (auto-restart) (Result: exit-code) since Fri 2018-02-02 22:19:11 CET; 1s ago
      Process: 3932 ExecStart=/bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/lib/plexmediaserver/Plex Media Server" (code=exited, status=134)
      Process: 3929 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=0/SUCCESS)
      Main PID: 3932 (code=exited, status=134)

      Feb 02 22:19:11 nas-hans systemd[1]: plexmediaserver.service: main process exited, code=exited, status=134/n/a
      Feb 02 22:19:11 nas-hans systemd[1]: Unit plexmediaserver.service entered failed state.



      root@nas-hans:~# systemctl status plexmediaserver.service
      plexmediaserver.service - Plex Media Server for Linux
      Loaded: loaded (/lib/systemd/system/plexmediaserver.service; disabled)
      Active: failed (Result: start-limit) since Fri 2018-02-02 22:19:21 CET; 1min 19s ago
      Process: 3952 ExecStart=/bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/lib/plexmediaserver/Plex Media Server" (code=exited, status=134)
      Process: 3948 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=0/SUCCESS)
      Main PID: 3952 (code=exited, status=134)

      Feb 02 22:19:16 nas-hans systemd[1]: plexmediaserver.service: main process exited, code=exited, status=134/n/a
      Feb 02 22:19:16 nas-hans systemd[1]: Unit plexmediaserver.service entered failed state.
      Feb 02 22:19:21 nas-hans systemd[1]: plexmediaserver.service holdoff time over, scheduling restart.
      Feb 02 22:19:21 nas-hans systemd[1]: Stopping Plex Media Server for Linux...
      Feb 02 22:19:21 nas-hans systemd[1]: Starting Plex Media Server for Linux...
      Feb 02 22:19:21 nas-hans systemd[1]: plexmediaserver.service start request repeated too quickly, refusing to start.
      Feb 02 22:19:21 nas-hans systemd[1]: Failed to start Plex Media Server for Linux.
      Feb 02 22:19:21 nas-hans systemd[1]: Unit plexmediaserver.service entered failed state.


      root@nas-hans:~# journalctl -xn
      -- Logs begin at Fri 2018-02-02 22:14:10 CET, end at Fri 2018-02-02 22:21:27 CET. --
      Feb 02 22:21:26 nas-hans systemd[1]: Activated swap /dev/sdb5.
      -- Subject: Unit dev-sdb5.swap has finished start-up
      -- Defined-By: systemd
      -- Support: lists.freedesktop.org/mailman/listinfo/systemd-devel
      --
      -- Unit dev-sdb5.swap has finished starting up.
      --
      -- The start-up result is done.
      Feb 02 22:21:26 nas-hans systemd[1]: Activated swap /dev/disk/by-id/ata-ST91000640NS_9XG2GZEY-part5.
      -- Subject: Unit dev-disk-by\x2did-ata\x2dST91000640NS_9XG2GZEY\x2dpart5.swap has finished start-up
      -- Defined-By: systemd
      -- Support: lists.freedesktop.org/mailman/listinfo/systemd-devel
      --
      -- Unit dev-disk-by\x2did-ata\x2dST91000640NS_9XG2GZEY\x2dpart5.swap has finished starting up.
      --
      -- The start-up result is done.
      Feb 02 22:21:26 nas-hans systemd[1]: Activated swap /dev/disk/by-id/wwn-0x5000c5004de979c0-part5.
      -- Subject: Unit dev-disk-by\x2did-wwn\x2d0x5000c5004de979c0\x2dpart5.swap has finished start-up
      -- Defined-By: systemd
      -- Support: lists.freedesktop.org/mailman/listinfo/systemd-devel
      --
      -- Unit dev-disk-by\x2did-wwn\x2d0x5000c5004de979c0\x2dpart5.swap has finished starting up.
      --
      -- The start-up result is done.
      Feb 02 22:21:26 nas-hans systemd[1]: Started Plex Media Server for Linux.
      -- Subject: Unit plexmediaserver.service has finished start-up
      -- Defined-By: systemd
      -- Support: lists.freedesktop.org/mailman/listinfo/systemd-devel
      --
      -- Unit plexmediaserver.service has finished starting up.
      --
      -- The start-up result is done.
      Feb 02 22:21:26 nas-hans sh[4056]: terminate called after throwing an instance of 'std::runtime_error'
      Feb 02 22:21:26 nas-hans sh[4056]: what(): Codecs: Initialize: 'boost::filesystem::create_directory: Too many levels of symbolic links: "/var/lib/plexmediaserver/Library/Applicatio
      Feb 02 22:21:26 nas-hans sh[4056]: ****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Crash Reports/1.10.
      Feb 02 22:21:27 nas-hans sh[4056]: Aborted
      Feb 02 22:21:27 nas-hans systemd[1]: plexmediaserver.service: main process exited, code=exited, status=134/n/a
      Feb 02 22:21:27 nas-hans systemd[1]: Unit plexmediaserver.service entered failed state.



      And then the Crash Report has no errors

      all out of ideas now, and due to all the rsync jobs and configuring, i really don't like the thought of reinstalling (omv) yet again