omv-engined terminate (SIGCHLD received ...)

    • omv-engined terminate (SIGCHLD received ...)

      Hello,

      I did install nullmailer today (via apt-get) and for some reason this triggered the uninstall of several openmediavault packages (which I did not spot in time).
      After re-installing according to this post, I get the web-interface, but cannot login (no connection to daemon).
      Journalctl hints me at omv-engined not running.

      When I start
      omv-engined -f -d I get this output

      Source Code

      1. timezone
      2. webadmin
      3. webserver
      4. zeroconf
      5. SIGCHLD received ...
      6. Child process forked (pid=12625)
      7. Executing RPC (service=UserMgmt, method=authUser, params={"username":"admin","password":"till1234"}, context={"username":"admin","role":1,"_SERVER":{"SERVER_PROTOCOL":"HTTP\/1.1","GATEWAY_INTERFACE":"CGI\/1.1","SERVER_SOFTWARE":"nginx\/1.10.3","REMOTE_ADDR":"::ffff:192.168.177.9","REMOTE_PORT":"61189","SERVER_ADDR":"::ffff:192.168.177.3","SERVER_PORT":"80","SERVER_NAME":"openmediavault-webgui","REDIRECT_STATUS":"200","HTTP_HOST":"192.168.177.3","HTTP_ORIGIN":"http:\/\/192.168.177.3","HTTP_USER_AGENT":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/63.0.3239.132 Safari\/537.36","HTTP_CONTENT_TYPE":"application\/json","HTTP_REFERER":"http:\/\/192.168.177.3\/"}}) ...
      8. RPC response (service=UserMgmt, method=authUser): {"response":{"authenticated":true,"username":"admin"},"error":null}
      9. SIGCHLD received ...
      10. Child (pid=12625) terminated with exit code 0
      11. Child process forked (pid=12703)
      12. Executing RPC (service=Config, method=isDirty, params=null, context={"username":"admin","role":1}) ...
      13. RPC response (service=Config, method=isDirty): {"response":false,"error":null}
      14. SIGCHLD received ...
      15. Child (pid=12703) terminated with exit code 0
      16. Child process forked (pid=12704)
      17. Executing RPC (service=Services, method=getStatus, params=[], context={"username":"admin","role":1}) ...
      18. Child process forked (pid=12710)
      19. Executing RPC (service=System, method=getInformation, params=[], context={"username":"admin","role":1}) ...
      20. RPC response (service=Services, method=getStatus): {"response":{"total":5,"data":[{"name":"ftp","title":"FTP","enabled":true,"running":true},{"name":"nfs","title":"NFS","enabled":true,"running":false},{"name":"rsyncd","title":"RSync server","enabled":false,"running":false},{"name":"samba","title":"SMB\/CIFS","enabled":true,"running":true},{"name":"ssh","title":"SSH","enabled":true,"running":true}]},"error":null}
      21. SIGCHLD received ...
      22. Child (pid=12704) terminated with exit code 0
      23. RPC response (service=System, method=getInformation): {"response":[{"name":"Hostname","value":"homeserver.fritz.box","type":"string","index":0},{"name":"Version","value":"4.0.17-1 (Arrakis)","type":"string","index":1},{"name":"Processor","value":"Intel(R) Pentium(R) CPU G3220 @ 3.00GHz","type":"string","index":2},{"name":"Kernel","value":"Linux 4.14.0-0.bpo.3-amd64","type":"string","index":3},{"name":"System time","value":"Mi 07 Feb 2018 15:30:07 CET","type":"string","index":4},{"name":"Uptime","value":"0 days 0 hours 17 minutes 53 seconds","type":"string","index":5},{"name":"Load average","value":"0.19, 0.23, 0.14","type":"string","index":6},{"name":"CPU usage","value":{"text":"1%","value":1},"type":"progress","index":7},{"name":"Memory usage","value":{"text":"12% of 3.76 GiB","value":12},"type":"progress","index":8}],"error":null}
      24. SIGCHLD received ...
      25. Child (pid=12710) terminated with exit code 0
      26. Child process forked (pid=12756)
      27. Child process forked (pid=12757)
      28. Executing RPC (service=Config, method=isDirty, params=null, context={"username":"admin","role":1}) ...
      29. RPC response (service=Config, method=isDirty): {"response":false,"error":null}
      30. Executing RPC (service=System, method=getInformation, params=[], context={"username":"admin","role":1}) ...
      31. SIGCHLD received ...
      32. Child (pid=12756) terminated with exit code 0
      33. RPC response (service=System, method=getInformation): {"response":[{"name":"Hostname","value":"homeserver.fritz.box","type":"string","index":0},{"name":"Version","value":"4.0.17-1 (Arrakis)","type":"string","index":1},{"name":"Processor","value":"Intel(R) Pentium(R) CPU G3220 @ 3.00GHz","type":"string","index":2},{"name":"Kernel","value":"Linux 4.14.0-0.bpo.3-amd64","type":"string","index":3},{"name":"System time","value":"Mi 07 Feb 2018 15:30:12 CET","type":"string","index":4},{"name":"Uptime","value":"0 days 0 hours 17 minutes 58 seconds","type":"string","index":5},{"name":"Load average","value":"0.18, 0.23, 0.14","type":"string","index":6},{"name":"CPU usage","value":{"text":"1%","value":1.5075376884422},"type":"progress","index":7},{"name":"Memory usage","value":{"text":"12% of 3.76 GiB","value":12},"type":"progress","index":8}],"error":null}
      34. SIGCHLD received ...
      35. Child (pid=12757) terminated with exit code 0
      Display All

      These packages are installed:

      Source Code

      1. root@homeserver:~# dpkg -l | grep openmedi
      2. ii openmediavault 4.0.17-1 all openmediavault - The open network attached storage solution
      3. rc openmediavault-borgbackup 4.0 all borgbackup plugin for OpenMediaVault.
      4. rc openmediavault-docker-gui 4.0.1 all OpenMediaVault plugin for Docker
      5. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      6. rc openmediavault-letsencrypt 3.4.5 all Generate free and valid SSL certificates for OMV
      7. rc openmediavault-omvextrasorg 4.1.2 all OMV-Extras.org Package Repositories for OpenMediaVault
      8. rc openmediavault-rsnapshot 4.1.3 all OpenMediaVault rsnapshot backup plugin.

      The web-interface looks incomplete, e.g. Snapraid is missing. And I cannot install it, because the entry for omv-extras does not apper in the Web-Interface.

      But I think that the main problem is the omv-engined termination.

      What can I do?

      Regards,
      Hendrik
    • Hi,

      reinstall (apt-get install openmediavault --reinstall)
      and

      Source Code

      1. systemctl enable openmediavault-engined
      2. systemctl start openmediavault-engined
      3. systemctl status openmediavault-engined
      helped.
      The Service is running now.

      Still, the omv-extras are missing. I will investigate. But do not hesitate to give me a hint.

      Greetings,
      Hendrik
    • Hello, I have/had the same problem after a fresh install. Not being able to login to the web ui, and then after running omv-engined -f -d I have the contiual executing rpc sigchild blah blah error, it's starting to fill up my boot drive. The command you mentioned "apt-get install openmediavault --reinstall", I've not run that in the past, will I lose all of my current configurations and/or have to rebuild my docker containers if I run it? I need to get this error taken care of. Thanks.
    • Users Online 1

      1 Guest