Cannot login via any method

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Cannot login via any method

      Hi all,
      I'm stuck.

      About a month ago (20th Dec 2017) I could ssh in on my username without issue, life was good.
      Now I am greeted in putty with "Could not chdir to home directory /home/<username-here>: No such file or directory"

      Source Code

      1. Could not chdir to home directory /home/dbe: No such file or directory

      I posted on here when I realized, and then forgot about it until I had time to try fix things. (What happened? No idea, I have not been installing anything new for months.)
      I am however, booting off USB, and we've had some power-outages due to severe weather.

      So here's where I'm stuck, I've forgotten the root password, and the web gui admin password is not working (don't think I changed it...)
      To reset the root password I've edited the recovery boot options in grub to drop me into /bin/bash, mounted the drive, set password, and then reboot caused a kernel panic.

      Thinking things are not going very well, I tried to login as root locally, it accepts the password but immediately loops back to the login screen, same thing from putty - immediate logout.
      Reading that an empty home dir is not a good omen, I connected the USB stick to an Ubuntu machine, and tried to fsck the partition, it comes up clean.
      I have 0 files or folders in /home.

      I rebooted OMV, took recovery mode in grub, entered the password to perform maintenance (JOY, it is accepted) and tried to run omv-firstaid. It fails to execute RPC, webgui password seems to remain unchanged.

      I'm currently stuck with a brick of a system that I have no idea how to recover.

      Worst case, will I be able to reconnect my raid drives if it turns out I need to re-install?


      Thanks for reading,
      dbell
    • Yes, after a rebuild, your RAID array should reconnect. (If nothing is wrong with the array.) And from the sound of it, you'll need to rebuild. Given what you're describing, that's what I would do.

      To be sure nothing happens to your drives, before rebuilding, I'd consider disconnecting the sata power plugs (not the data connections) from your RAID drives if you can get to them. Once OMV is up, and you have a basic configuration, shut down and plug power back into the drives.

      The second time around, consider cloning your USB boot drive. (With a backup, you can avoid these issues.)
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.95 Erasmus
      ThinkServer TS140, 12GB ECC / 32GB USB3.0
      4TB SG+4TB TS ZFS mirror/ 3TB TS

      OMV 3.0.95 Erasmus - Rsync'ed Backup
      R-PI 2 $29 / 16GB SD Card $8 / Real Time Clock $1.86
      4TB WD My Passport $119