Problem with php5 dependencies

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Problem with php5 dependencies

      Hi,

      I've removed php5 and i cant install again. OMV has stopped working!! :cursing:

      When I try to install it again, I get the next output:

      root@raspberrypi:/# apt-get install php5
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      You might want to run 'apt-get -f install' to correct these:
      The following packages have unmet dependencies:
      openmediavault-flashmemory : Depends: openmediavault (>= 3.0.40) but it is not going to be installed
      php5 : Depends: libapache2-mod-php5 (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed or
      libapache2-mod-php5filter (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed or
      php5-cgi (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed or
      php5-fpm (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed
      Depends: php5-common (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
      root@raspberrypi:/#

      I need help because I have many services installed, such as plex, web server, svn ... and I do not want to install everything again ;( ;(

      Thanks!!
    • Yes, I've tried that you say. The same:

      root@raspberrypi:/# apt-get -f install php5
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      You might want to run 'apt-get -f install' to correct these:
      The following packages have unmet dependencies:
      openmediavault-flashmemory : Depends: openmediavault (>= 3.0.40) but it is not going to be installed
      php5 : Depends: libapache2-mod-php5 (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed or
      libapache2-mod-php5filter (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed or
      php5-cgi (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed or
      php5-fpm (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed
      Depends: php5-common (>= 5.6.30+dfsg-0+deb8u1~) but it is not going to be installed
      E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


      I think there must be another solution before reinstalling everything again...
    • Ok, sorry. I think now that php5 has been installed. But OMV still it doesn`t work...

      I execute this again:

      root@raspberrypi:/# apt-get -f install
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      0 upgraded, 0 newly installed, 0 to remove and 433 not upgraded.
      2 not fully installed or removed.
      After this operation, 0 B of additional disk space will be used.
      Setting up openmediavault (3.0.97) ...
      Updating configuration database ...
      Traceback (most recent call last):
      File "/usr/sbin/omv-confdbadm", line 23, in <module>
      import openmediavault
      ModuleNotFoundError: No module named 'openmediavault'
      dpkg: error processing package openmediavault (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault-flashmemory:
      openmediavault-flashmemory depends on openmediavault (>= 3.0.40); however:
      Package openmediavault is not configured yet.

      dpkg: error processing package openmediavault-flashmemory (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      openmediavault
      openmediavault-flashmemory
      Traceback (most recent call last):
      File "/usr/sbin/omv-mkaptidx", line 35, in <module>
      import apt
      ModuleNotFoundError: No module named 'apt'
      E: Sub-process /usr/bin/dpkg returned an error code (1)


      Thanks...
    • As the error stated, there are now errors in openmediavault and one of it's plugins itself.
      Have you trief re-installing the "openmediavault" package?

      I don't really know if a re-installation of the omv package keeps the configuration etc.
      Just sayin..

      I think it would be better to reinstall it, but you can try to rescue it of course.
    • Users Online 2

      2 Guests