Connection Failed on arrakis

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Connection Failed on arrakis

      Hey there,

      I'm trying to set up afp but I can't get it to work. I have a Shared Folder, Delorean, that I want to use as Time Capsule.
      The server shows up in my Finder's sidebar. When I try to login with my account ("pseudonym", member of group "pseudonym"; the one I set up when installing omv) I get the notification "Connection Failed" (in Finder, macOS 10.13.3). I use the unix password of that account. When I use another password I get the typical macOS shaking dialog that signifies a wrong password.

      A screenshot of how the share for netatalk is configured is attached. In the Settings Tab all I did was check "enabled".

      Permissions are set up as follows:

      Source Code

      1. $ ll /sharedfolders/
      2. drwxrws---+ 3 root users 4096 Jan 27 17:35 Delorean


      My afp.conf looks like this:

      Source Code: afp.conf

      1. [Global]
      2. max connections = 20
      3. mac charset = MAC_ROMAN
      4. unix charset = LOCALE
      5. guest account = nobody
      6. uam list = uams_dhx.so,uams_dhx2.so
      7. save password = no
      8. [Delorean]
      9. path = /srv/dev-disk-by-label-WD/Delorean
      10. read only = no
      11. unix priv = yes
      12. file perm = 0664
      13. directory perm = 0775
      14. umask = 0002
      15. invisible dots = no
      16. time machine = yes
      17. password = ########
      18. vol size limit = 256000
      19. valid users = "pseudonym" "@pseudonym"
      20. invalid users =
      21. rolist =
      22. rwlist = "pseudonym" "@pseudonym"
      Display All


      Versions:
      Kernel: 4.14.8-sunxi
      OMV: 4.0.19-1 (Arrakis)
      openmediavault-netatalk: 4.0.6-1

      Installed manually on armbian 5.38 (Stretch).

      Any advice how to debug this?
      Images
      • Screenshot-2018-2-14 openmediavault control panel - localhost.png

        155.04 kB, 1,454×1,508, viewed 54 times
    • It’s clear that it can’t connect with the unix permissions set above.
      You have set only read and write for user root and group users.
      Set the following:
      chown -R pseudonym:pseudonym /sharedfolders/Delorean
      OMV 4 Arrakis | Kernel 4.14 ... running on
      SelfBuilt NAS -- Asrock Q1900-ITX -- 4x 2,4 GHz in Burst Mode -- 4 GB DDR3 RAM -- RAID 5 -- 3x 3TB WD Red
    • wastez wrote:

      It’s clear that it can’t connect with the unix permissions set above.
      You have set only read and write for user root and group users.
      Ah crap. pseudonym is in the user's group, I forgot to mention that / edited it out by accident. There is another thread about group permissions not working, but that was due wrong syntax in afp.conf caused by OMV (which is why I posted that snippet in the first place). As far as I understand this should be sufficient, no? Explicitly setting rwx-rights for pseudonym:pseudonym worked.

      Also @subzero79 you're right, setting an additional password for netatalk doesn't really help much anyways (given it's max length i 8 chars) and only complicates the setup.