Start alternative Clonezilla iso

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Start alternative Clonezilla iso

      I'd like to ask where it's configured that the specified clonezilla iso is booted when clicking the 'Reboot to Clonezilla once' button.

      The old Clonezilla iso that comes with the OMV-Extras unfortunately isn't working for me. I'm aware that newer versions don't bring up the network after booting out of the box, but I have modified a newer testing iso, as stated in the Clonezilla docs, to match my local IP setup and this works pretty good. Then I've copied the new iso to /boot/ and renamed it to the old. That's working atm. However I consider this renaming thing to be a dirty hack and would love to access the iso by its true name/ version... that way I won't forget about my modifications as well.
      So can anyone tell me where to find the config for the 'reboot button'

      Thanks for your efforts,
      Thomas
    • Stramm wrote:

      So can anyone tell me where to find the config for the 'reboot button'
      Unfortunately, to get the changed ISO to work with omv-extras, it would require changing omv-extras. If you did that on just your system, the changes would be overwritten by an update. If you just want the grub menu entry, copy /etc/grub.d/42_clonezilla to /etc/grub.d/43_whatever and you can probably tell what to modify in that file.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Thanks for the clarification... I already was afraid of something like that and stay with the modded and renamed Clonezilla iso. Just as a reference for others who have also problems with their old Clonezilla version here's what I did:

      1. OMV-Extras - > Kernel -> Install Clonezilla
      2. Download a for you working Clonezilla iso (I tried the testing clonezilla-live-2.5.5-27-amd64.iso)
      3. Extract some files from the iso
      - /EFI/boot/grub.cfg
      - /syslinux/isolinux.cfg
      - /syslinux/syslinux.cfg

      Just one of these files needs to be modified to add additional info to the Clonezilla boot.

      grub.cfg, if you have a UEFI based system, isolinux.cfg if booting from a CD and syslinux.cfg if you're booting from a USB drive/ stick. If you do not know what to mod, go with grub.cfg and syslinux.cfg, that should do in most cases.

      Within these files find the default menu entry

      Source Code

      1. MENU LABEL Clonezilla live (Default settings, VGA 800x600)

      the next IP= a few lines below replace with eg.

      Source Code

      1. ip=eth0:192.168.x.x:255.255.255.0:192.168.x.y:8.8.8.8 ocs_daemonon="ssh"
      You need to adapt this to fit into your needs ->> :IP:NETMASK:GATEWAY:DNS

      Replace the files with the modded ones within the iso and save the iso.

      In a cli


      Source Code

      1. rm /boot/clonezilla-live-2.3.2-22-i686-pae.iso
      Copy the modded iso into /boot and raname it to clonezilla-live-2.3.2-22-i686-pae.iso


      As last step we take care of permissions

      Source Code

      1. chown root:root /boot/clonezilla-live-2.3.2-22-i686-pae.iso
      2. chmod 644 clonezilla-live-2.3.2-22-i686-pae.iso

      That's it. Now you can boot into a new Clonezilla version from within OMV admin.
      The IP is the one you've chosen above, user and password are user:live
      Once logged in you need to
      sudo clonezilla
      to bring up the Clonezilla interface.
    • Hi,

      I've just registered to contribute my own experiences. With the "original" clonezilla iso (clonezilla-live-2.3.2-22-i686-pae.iso) I had a serious lag within ssh (~5 second delay after every command) and a awful performance while backing up 14 GB from SSD to HDD (100-300 mb/min). My nas is based on a ASRock J3455-ITX.

      I'm glad I found this post and I tried to follow the steps from post 4. But I didn't find a way to edit the *.iso-file. So I couldn't follow the instructions...
      Eventually I looked into the original *.iso and opened the grub.cfg and the other *.cfg files because I wanted to see which modifications had been made there. Surprisingly the "ip=" had not been changed as shown in the above. So I decided to try a new iso without the modifications.

      I just copied a new iso (clonezilla-live-2.5.5-38-amd64.iso.) to /boot. I renamed the orignal file to .org and gave the new one the old name. Then I changed permissions to chmod 666 and set startup via webinterface.

      Et'voila: everything worked! Network (ip assigned via DHCP), ssh (headless setup, so this is vital) and restoring a backup worked and performance was perfect: no more lag and restoring with 5 GB/min...

      Why does it work? What do you say?

      PS: I always thought you needed a matching operating system for x64 and was surprised that the x86 version was even running at all? Is that the reason for the bad performance, or is it jsut the "old" version?

      The post was edited 2 times, last by jcd: typo ().

    • Users Online 1

      1 Guest