Duplicati will not installed after upgrade from OMV 3 to OMV 4

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Duplicati will not installed after upgrade from OMV 3 to OMV 4

      Hi,
      Today I’ve upgraded to release 4. OMV is installed on my Raspberry Pi.

      There was a problem with Duplicati, so I’ve installed Duplicati and want te install it again.

      But received the following error:



      root@raspberrypi:~# apt-get install duplicati

      Reading package lists... Done

      Building dependency tree

      Reading state information... Done

      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:



      The following packages have unmet dependencies:

      duplicati : Depends: libmono-system-drawing4.0-cil but it is not going to be installed

      Depends: libmono-system-servicemodel4.0a-cil but it is not going tobe installed

      Depends: libmono-system-servicemodel-discovery4.0-cil but it is notgoing to be installed

      Depends: libmono-system-serviceprocess4.0-cil but it is not going to be installed

      Depends: libmono-system-web4.0-cil but it is not going to be installed

      Depends: libmono-system-web-services4.0-cil but it is not going tobe installed

      Depends: gtk-sharp2 but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.



      I’ve tried the apt-get dist-upgrade.

      root@raspberrypi:~# apt-get dist-upgrade

      Reading package lists... Done

      Building dependency tree

      Reading state information... Done

      Calculating upgrade... Done

      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



      I’ve tried the

      root@raspberrypi:~# apt-get -f install

      Reading package lists... Done

      Building dependency tree

      Reading state information... Done

      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



      I’ve tried the apt-clean in OMV webbrowser.



      I’ve tried to install from OMV webbrowser:

      Reading package lists...

      Building dependency tree...

      Reading state information...

      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:



      The following packages have unmet dependencies:



      >>> *************** Error ***************

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-duplicati 2>&1' with exit code '100': Reading package lists...



      Building dependency tree...



      Reading state information...



      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:



      The following packages have unmet dependencies:

      openmediavault-duplicati : Depends: duplicati but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.

      <<< *************************************



      >>> *************** Error ***************

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-duplicati 2>&1' with exit code '100': Reading package lists...



      Building dependency tree...



      Reading state information...



      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:



      The following packages have unmet dependencies:

      openmediavault-duplicati : Depends: duplicati but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.

      <<< *************************************



      >>> *************** Error ***************

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-duplicati 2>&1' with exit code '100': Reading package lists...



      Building dependency tree...



      Reading state information...



      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:



      The following packages have unmet dependencies:

      openmediavault-duplicati : Depends: duplicati but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.

      <<< *************************************



      >>> *************** Error ***************

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-duplicati 2>&1' with exit code '100': Reading package lists...



      Building dependency tree...



      Reading state information...



      Some packages could not be installed. This may mean that you have

      requested an impossible situation or if you are using the unstable

      distribution that some required packages have not yet been created

      or been moved out of Incoming.

      The following information may help to resolve the situation:



      The following packages have unmet dependencies:

      openmediavault-duplicati : Depends: duplicati but it is not going to be installed

      E: Unable to correct problems, you have held broken packages.

      <<< *************************************



      What can I do more to make Duplicati working?



      Thanks
    • Duplicati is installed now:
      I don't know whith commands are nessecary, but I've done it as follows:

      apt-get remove mono-complete mono-devel mono-runtime
      apt-get autoremove
      apt-get remove --purge libmono*
      sudo apt-get purge mono-runtime
      sudo apt-get purge mono-complete

      Now Check for some mono remaining parts as lib or others things and unistall them

      dpkg --get-selections | grep mono
      Now unistall them

      apt-get remove remainings-parts
      Now clean apt cache

      apt get clean
      apt-get autoclean

      New Mono install:
      sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
      echo "deb download.mono-project.com/repo/debian stable-stretch main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
      sudo apt-get update


      Check the exact version of Mono.
      apt-cache showpkg mono-devel
      And install it

      aptitude install mono-devel=version
      In my case: aptitude install mono-devel=5.8.0.108-0xamarin1+debian9b1

      First choice to keep versions, choice is no.
      Next choice is Yes and Yes.