Remove Certificate settings

    • OMV 3.x
    • Remove Certificate settings

      Hi all,
      my NAS is running on version OMV 3.0.97 with a certificate of letsencrypt. A few days ago I tried a renewal of my certificate by using the letsencrypt plugin, but it failed with an error. Since this operation it is no longer possible to store any changes in OMV settings.
      I started to remove the certificate, which did not work ... and a few other things, maybe stupid one ... I know. At least I removed the letsencrypt plugin and installed it new and tried to generate or renew the certificate, but this did now work either. It shows an authorization error - all challenges failed (when trying to renew or generate a certificate with letsencrypt).
      At the moment OMV is accessible via port 80, but an SSL connection or setting is no longer possible.

      Webserver: nginx

      exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] SSL_CTX_use_PrivateKey_file("/etc/ssl/private/openmediavault-....key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch)
      nginx: configuration file /etc/nginx/nginx.conf test failed' in /usr/share/php/openmediavault/system/process.inc:175


      Now I would like to get rid of all these settings, which require a certificate ... and then start SSL again from the beginning with my self-signed certificate. But I don't know where to remove the settings, which still require the letsencrypt certificate?

      Does someone know what to do best in this case? Are there certain configuration and configuration files, which I have to delete/change?

      Cheers,
      Mike

      The post was edited 1 time, last by Mike_L ().

    • Thanks for your help, subzero - I will give it a try again.
      I did this before, but after a restart of OMV I have the entries with the cert again in my nginx-configuration (sites-enabled) and nginx did not start. After commenting out these two lines in the configuration, nginx starts and OMV is accessible on port 80. But I will try again - maybe I did something wrong with omv-firstaid.

      Cheers,
      Mike
    • HI, it's me again: I tried omv-firstaid once more, but this does not work - error occured - console shows (I changed the name of the key in the error output):

      Updating web control panel settings. Please wait ...
      ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] SSL_CTX_use_PrivateKey_file("/etc/ssl/private/openmediavault-..........key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch)
      nginx: configuration file /etc/nginx/nginx.conf test failed

      So I really don't know, how to get out of this situation, which prevents every configuration change.

      Cheers,
      Mike
    • This error is shown, when attempting to set http / port 80 in omv-firstaid.

      However, my OMV-NAS is accessible via http / port 80 (and no longer via https). But this error is shown, if I try to set the configuration via omv-firstaid. And also the webinterface shows the yellow info-line to store the configuration, which also ends up in this error. That's why I'm no longer able to change any configuration. And I don't know, how to remove the settings, which cause this error.

      Cheers,
      Mike
    • Hi Subzero, same error again.
      Settings in omv-firstaid:
      http - 80 - OK
      https - NEIN

      Updating web control panel settings. Please wait ...
      ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] SSL_CTX_use_PrivateKey_file("/etc/ssl/private/openmediavault-.........key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch)
      nginx: configuration file /etc/nginx/nginx.conf test failed

      What shoud be the result for your command?

      Cheers,
      Mike
    • Mike_L wrote:

      Hi Subzero, same error again.
      Settings in omv-firstaid:
      http - 80 - OK
      https - NEIN

      Updating web control panel settings. Please wait ...
      ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] SSL_CTX_use_PrivateKey_file("/etc/ssl/private/openmediavault-.........key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch)
      nginx: configuration file /etc/nginx/nginx.conf test failed

      What shoud be the result for your command?

      Cheers,
      Mike

      Hey Mike_L
      I do have the exact same error, like you described here. SSL who screwed up everything. I also think nextcloud ist the solution for my problem. Sadly i do not have any access to the web control or my nextcloud page.
      Where did you edit the nextcloud configuration? Via SSH or did you edit it in the web panel?