How to force SMBv1

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • How to force SMBv1

      First of all, thank you for your job on openmediavault. :)

      I have a use case where I must enable SMBv1, very old legacy application that only uses that protocol for file transfert.
      To limit the risks, I'm removing the share used by that app to a dedicated openmediavault as a "rebound" storage.

      After testing a bit it seems SMBv1 is disable on last version of OMV. Is that right ?
      How can I verify it and idealy force OMV to accept SMBv1 ?

      I've looked into the smb.conf without luck.

      Thank you.

      Loo.
    • I believe SMB1 is enabled by default but there's a client negotiation process. The following should start that process at a level that may work for you.

      Under Services, SMB/CIF, In the Shares TAB, Edit the share. Under extra options - insert the line shown in the screen shot:



      This can be done, as shown above, on a "by share" basis. The same line will work in the Settings tab and it would apply to all shares on the server.
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup Server:
      OMV 4.1.8.2-1, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB+4TB Rsync'ed disks+SNAPRAID
      2nd Data Backup
      R-PI 2B, 16GB boot, 4TB WD MyPassport
    • Hello,

      Thank you for your time and reply.
      Unfortunately it doesn't work for me.

      I suspect the same thing, it's not a matter of ports, OMV listens on tcp139 etc.. Seems really related to the way the device communicates with the server.
      The only OS I've managed to work with is Windows 2003....

      Any other ideas or places where I could check to help understand and correct behavior ?

      Thank you.

      Loo
    • I am pretty sure smbv1 is disabled by an update on windows on supported versions of windows since it is a big security risk. That is why it probably works on server 2003 since it has been out of support for a long time.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Your issue might not be with OMV. @ryecoaaron is correct in that SMB1 has been disabled in most Windows installs - if they're exposed to the net and accept security updates.

      If this is an application issue (you say it requires SMB1?) - this HOW-TO will show you how to set Registry keys for SMB, that will work in Windows OS's, with Power Shell. (Windows 7 and up, Server 2008 and up.)

      (In Power Shell - run as administrator)
      For your use case, the command line for the PC that is hosting the SMB1 app would be:

      Source Code

      1. Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB1 -Type DWORD -Value 1 –Force
      Afterward SMB1 would be enabled, the key will be accessible by regedit.exe and can be changed with the same.

      There's a real risk in running SMB1, but it could be managed if the PC hosting the SMB1 application and the server with the SMB1 share are not exposed to the Net. (No E-mail, no Web Surfing, updates only)
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup Server:
      OMV 4.1.8.2-1, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB+4TB Rsync'ed disks+SNAPRAID
      2nd Data Backup
      R-PI 2B, 16GB boot, 4TB WD MyPassport

      The post was edited 2 times, last by flmaxey: edit ().

    • You guys are correct.
      That's why I'm looking into OMV, to avoid dealing with MS server that will disable SMBv1 each time we update it etc...

      But it seems it's not that easy to have a Linux based server communicating or acting as an insecure Windows server. ;)

      As far as I understand it seems my device (based on WinCE) uses a SMBv1 quite old and the way it communicates is not supported with recent versions of SMBv1. Only Windows 2003 servers seem to respond properly.

      I'm trying to find a way of simulating the way Windows 2003 communicates with my device.

      Thank you again for your time.

      Loo
    • I looked at some of the possible settings for "client max protocol", for earlier implementations, that are still supported by Samba.

      You might try:
      client max protocol = LANMAN1

      This setting supported long file names which would help with forward (file) compatibility.

      The reference is here. -> Samba

      I'd try to nail it down with something like the following:
      client max protocol = LANMAN1
      client min protocol = LANMAN1

      If it worked, I'd step up one level at a time until it fails with; LANMAN2, NT1, etc.
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup Server:
      OMV 4.1.8.2-1, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB+4TB Rsync'ed disks+SNAPRAID
      2nd Data Backup
      R-PI 2B, 16GB boot, 4TB WD MyPassport

      The post was edited 1 time, last by flmaxey: edit ().