Please Help: "Failed to partition the selected disk" error during installation

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Please Help: "Failed to partition the selected disk" error during installation

      OK, I screwed up by not deleting incompatible plugins before upgrading from OMV 3.x to OMV 4.x. I just assumed the installation script would either disable incompatible plugins or remove them with a warning message. Silly me. It did neither, which resulted in an annoying "Invalid RPC" error message almost everywhere in OMV. So since my server was barely configured with OMV 3.x, I decided just to do a clean install of OMV 4.x. What could possibly go wrong?

      The installation went fine until it came time to configure a boot drive. For OMV 3.x, I was using a 16GB SLC USB drive with the Flashmemory plugin. It seemed to work fine. Then, when installing OMV 4.1, right after entering the root password, I got error messages: "Failed to partition the selected disk" followed by "No root file system is defined." At first, I also saw the installer ynoticed earlier OMV files from the 3.X installation on the drive.

      So the first thing I did was pop the USB drive into my iMac, fire up Disk Utility, and erased the drive. After trying this a couple of time without it working, I set the erase level to 7, which erases existing data, writes over it, etc. Still had the problem.

      Then I read this page, this page, and this page. I tried all three suggested solutions: ryecoaaron's 7/10/14 suggestion to zero out what was on the drive, Raj Kumar's 5/12/13 suggestion to use GParted to create new swap and system partitions on the drive, and ryecoaaron's 12/10/16 post, which was like his earlier one but increases the number of zeros by a factor of 10, from 1000 to 10000. I tried each of them, but still no luck.

      One thing I don't understand, is that the error messages mention fixing the partitions from the partition menu. If I escape back to the menu of everything one can do during installation and select the partition item in the menu, the system throws another error, saying there's no root directory. But if I'm using a different USB with the OMV installation iso, there's obviously a root directory there. And isn't the purpose of a partition utility, at least sometimes, to create partitions? So if you're preparing a blank drive, of course there won't be a root directory before you've configured the drive. What am I missing?

      Could someone please help me with this? ;(

    • Each time I had this error ""Failed to partition the selected disk" it was not due to destination drive (where I was trying to install OMV). It was due to the program I was using to write OMV on the install drive. So I have been using unetbootin, I know some people have reported problems with it too but it works for me.
    • Users Online 1

      1 Guest