Failed to start Raise Network Interface - after upgrade from OMV3 to OMV4

    • OMV 4.x
    • Failed to start Raise Network Interafce - after upgrade from OMV3 to OMV4

      Hey Guys,

      today I did the upgrade from OMV3 to OMV4 and everything went just fine. But at the fisrt boot I mentioned a very long boottime (about 7 min). So I pluged in a monitor and saw, that the network could not be raised and timed out. But after the timeout, eth0 is up and running and everything seems fine.

      The networking.service is in failed state, but the interface ist up. Can anybody tell me whats gonig on here?

      thanks in advance

      Denqbar

      Shell-Script

      1. root@OMV:~# systemctl status networking.service
      2. ● networking.service - Raise network interfaces
      3. Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
      4. Active: failed (Result: timeout) since Fri 2018-03-16 19:37:54 CET; 15min ago
      5. Docs: man:interfaces(5)
      6. Process: 1025 ExecStart=/sbin/ifup -a --read-environment (code=killed, signal=TERM)
      7. Process: 995 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exc
      8. Main PID: 1025 (code=killed, signal=TERM)
      9. CPU: 38ms
      10. Mär 16 19:32:54 OMV systemd[1]: Starting Raise network interfaces...
      11. Mär 16 19:32:54 OMV ifup[1025]: ifup: waiting for lock on /run/network/ifstate.eth0
      12. Mär 16 19:37:54 OMV systemd[1]: networking.service: Start operation timed out. Terminating.
      13. Mär 16 19:37:54 OMV systemd[1]: networking.service: Main process exited, code=killed, status=15/TERM
      14. Mär 16 19:37:54 OMV systemd[1]: Failed to start Raise network interfaces.
      15. Mär 16 19:37:54 OMV systemd[1]: networking.service: Unit entered failed state.
      16. Mär 16 19:37:54 OMV systemd[1]: networking.service: Failed with result 'timeout'.
      Display All


      Source Code

      1. root@OMV:~# journalctl -b | grep network -i
      2. Mär 16 19:31:24 OMV kernel: e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k
      3. Mär 16 19:31:24 OMV kernel: e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
      4. Mär 16 19:32:54 OMV systemd[1]: Starting Raise network interfaces...
      5. Mär 16 19:32:54 OMV avahi-daemon[1072]: Network interface enumeration completed.
      6. Mär 16 19:32:54 OMV ifup[1025]: ifup: waiting for lock on /run/network/ifstate.e th0
      7. Mär 16 19:37:54 OMV systemd[1]: networking.service: Start operation timed out. T erminating.
      8. Mär 16 19:37:54 OMV systemd[1]: networking.service: Main process exited, code=ki lled, status=15/TERM
      9. Mär 16 19:37:54 OMV systemd[1]: Failed to start Raise network interfaces.
      10. Mär 16 19:37:54 OMV systemd[1]: networking.service: Unit entered failed state.
      11. Mär 16 19:37:54 OMV systemd[1]: networking.service: Failed with result 'timeout' .
      12. Mär 16 19:37:54 OMV systemd[1]: Reached target Network.
      13. Mär 16 19:37:54 OMV systemd[1]: Reached target Network is Online.
      Display All

      Source Code

      1. root@OMV:~# systemctl -l | grep network -i
      2. ● networking.service loaded failed failed etwork interfaces
      3. network-online.target loaded active active is Online
      4. network.target loaded active active

      Source Code

      1. root@OMV:~# cat /etc/network/interfaces
      2. # Include additional interface stanzas.
      3. source-directory interfaces.d
      4. # The loopback network interface
      5. auto lo
      6. iface lo inet loopback
      7. iface lo inet6 loopback
      8. # eth0 network interface
      9. auto eth0
      10. allow-hotplug eth0
      11. iface eth0 inet static
      12. address 192.168.1.159
      13. gateway 192.168.1.1
      14. netmask 255.255.255.0
      15. dns-nameservers 192.168.1.1
      16. iface eth0 inet6 dhcp
      17. pre-up echo 1 > /proc/sys/net/ipv6/conf/$IFACE/accept_ra
      18. pre-up echo 0 > /proc/sys/net/ipv6/conf/$IFACE/disable_ipv6
      Display All
    • Hi,

      Same problem here every time I reboot/start my server... Network interface is down.
      My server is build from scratch (Debian 9.x + OMV 4.x install via package).

      I need to connect to the console, and restart the networking service manually with /etc/init.d/network restart and the network comes up !!!


      Shell-Script

      1. root@home-server:~# cat /etc/network/interfaces
      2. # Include additional interface stanzas.
      3. source-directory interfaces.d
      4. # The loopback network interface
      5. auto lo
      6. iface lo inet loopback
      7. # enp3s0 network interface
      8. auto enp3s0
      9. allow-hotplug enp3s0
      10. iface enp3s0 inet static
      11. address 192.168.0.10
      12. gateway 192.168.0.1
      13. netmask 255.255.255.0
      14. dns-nameservers 8.8.8.8
      15. dns-search famille-bocquet.local
      16. pre-down ethtool -s $IFACE wol g
      17. iface enp3s0 inet6 manual
      18. pre-down ip -6 addr flush dev $IFACE
      Display All

      Still searching a solution...
      Lian Li PC-V354 with Be Quiet fans | Gigabyte GA-G33M-DS2R | Intel E8400@3,6Ghz | 6GB DDR2 RAM
      1x500MB SSD for System/Backup | 7x2To HDD with ZFS RAIDz2 for Datas/Snapshots
      Powered by OMV v4.1.7 / Kernel 4.16.x / ZFS 0.7.9
    • None at the moment... Very strange issue and my NAS is gone headless in its cupboard.
      I need to take it out, plug a screen and a keyboard to retry...
      Lian Li PC-V354 with Be Quiet fans | Gigabyte GA-G33M-DS2R | Intel E8400@3,6Ghz | 6GB DDR2 RAM
      1x500MB SSD for System/Backup | 7x2To HDD with ZFS RAIDz2 for Datas/Snapshots
      Powered by OMV v4.1.7 / Kernel 4.16.x / ZFS 0.7.9
    • Users Online 1

      1 Guest