Can't mount RAID10 "more filesystems detected"

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't mount RAID10 "more filesystems detected"

      Hello folks,

      I upgraded a few days ago from OMV 3.* to OMV 4.
      But now I can't mount anymore my RAID10. Do you have any sugesstions?



      [IMG:https://abload.de/thumb/cantmountu9ql7.png]
      [IMG:https://abload.de/thumb/cantmount2dvpd5.png]


      Error of sudo mount /dev/md0 /srv/dev-disk-by-label-Raid10

      Source Code

      1. sudo mount /dev/md0 /srv/dev-disk-by-label-Raid10
      2. mount: /dev/md0: more filesystems detected. This should not happen,
      3. use -t <type> to explicitly specify the filesystem type or
      4. use wipefs(8) to clean up the device.


      This is the blkid output:

      Source Code

      1. root@NAS-Server:~# blkid
      2. /dev/sdc: UUID="10ee0e11-06f4-bdcc-2402-7b704ab53d25" UUID_SUB="01cdd2a3-b86b-691b-a213-b5ca3cbd878c" LABEL="NAS-Server:RAID10" TYPE="linux_raid_member"
      3. /dev/sdb: UUID="10ee0e11-06f4-bdcc-2402-7b704ab53d25" UUID_SUB="48c7850e-4c34-6651-7bb2-8224c4062565" LABEL="NAS-Server:RAID10" TYPE="linux_raid_member"
      4. /dev/sda1: UUID="0a228258-4d3a-4cfe-b87e-b837f4f19183" TYPE="ext4" PARTUUID="c66cdb84-01"
      5. /dev/sda5: UUID="b3c59904-4ca4-49f1-80c1-ec4998c43471" TYPE="swap" PARTUUID="c66cdb84-05"
      6. /dev/sde: UUID="10ee0e11-06f4-bdcc-2402-7b704ab53d25" UUID_SUB="2c0c01de-3547-50aa-d14c-b77b426ae2a7" LABEL="NAS-Server:RAID10" TYPE="linux_raid_member"
      7. /dev/sdd: UUID="10ee0e11-06f4-bdcc-2402-7b704ab53d25" UUID_SUB="ba632853-5ba6-3b24-b0f0-245c66d33fa8" LABEL="NAS-Server:RAID10" TYPE="linux_raid_member"

      Source Code

      1. root@NAS-Server:~# cat /proc/mdstat
      2. Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
      3. md0 : active raid10 sdd[4] sde[0] sdb[3] sdc[2]
      4. 15627790336 blocks super 1.2 512K chunks 2 near-copies [4/4] [UUUU]
      5. bitmap: 0/117 pages [0KB], 65536KB chunk
      6. unused devices: <none>


      Output of: sudo mdadm --detail /dev/md0

      Source Code

      1. sudo mdadm --detail /dev/md0
      2. /dev/md0:
      3. Version : 1.2
      4. Creation Time : Tue Oct 3 13:04:58 2017
      5. Raid Level : raid10
      6. Array Size : 15627790336 (14903.82 GiB 16002.86 GB)
      7. Used Dev Size : 7813895168 (7451.91 GiB 8001.43 GB)
      8. Raid Devices : 4
      9. Total Devices : 4
      10. Persistence : Superblock is persistent
      11. Intent Bitmap : Internal
      12. Update Time : Sat Mar 17 08:45:06 2018
      13. State : clean
      14. Active Devices : 4
      15. Working Devices : 4
      16. Failed Devices : 0
      17. Spare Devices : 0
      18. Layout : near=2
      19. Chunk Size : 512K
      20. Name : NAS-Server:RAID10 (local to host NAS-Server)
      21. UUID : 10ee0e11:06f4bdcc:24027b70:4ab53d25
      22. Events : 16942
      23. Number Major Minor RaidDevice State
      24. 0 8 64 0 active sync set-A /dev/sde
      25. 4 8 48 1 active sync set-B /dev/sdd
      26. 2 8 32 2 active sync set-A /dev/sdc
      27. 3 8 16 3 active sync set-B /dev/sdb
      Display All


      Should work, shouldn't it?

      Would be awesome to get help!

      Have a good day,