Mounting not possible on Zyxel NAS542

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Mounting not possible on Zyxel NAS542

      Hello,

      I was very happy when I found somebody who build Debian with OMV for the Zyxel NAS542 running from USB or SD card, because the original firmware is a mess.
      zyxelforum.de/debian-8-auf-usb…oder-sd-karte-t11232.html

      The system is very experimental, but it works, if you finally have the drives mounted. And that is the problem:

      In the WebGUI section filesystems (hope I'm translating correct from a German OMV) I always get "communication failure", what means timeout as I already understood. The only chance is to put only one (of four) drive into the NAS at a time. Then filesystems shows the partitions of the drive and it is possible to mount. When I repeat this procedure for all 4 drives I have a running system ;)

      But I often had to reinstall the system for some experiments. And always doing this procedure is very annoying.

      So I would like to know a way to mount the drives without WebGUI. I already tried to edit fstab directly, but could nothing get mounted.

      Then I tried to edit the OMV config.xml. I copied the <mntent> sections from a working system and then did a [i]omv-mkconf fstab. The mounts are then shown in fstab, but this also didn't work. I see the folders in /media, but they are empty.

      Which files have to be edited, to get the drives mounted?

      Thank you all!
    • efyzz wrote:


      Then I tried to edit the OMV config.xml. I copied the <mntent> sections from a working system and then did a [i]omv-mkconf fstab. The mounts are then shown in fstab, but this also didn't work. I see the folders in /media, but they are empty.

      Which files have to be edited, to get the drives mounted?

      Thank you all!
      you need to actually make the mountpoint folders, then finally reboot, or run mount -a
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Edit: Please read next post first!


      Hi,

      just tested with a fresh system - no success!

      This is my output of blkid:

      Source Code

      1. /dev/sda1: UUID="829a9d3f-7601-4893-009d-27c18956d83c" UUID_SUB="07fb0aa1-e09a-5247-268a-a4d8e1dda5eb" LABEL="NAS542:0" TYPE="linux_raid_member" PARTUUID="09a30ee8-b6a2-48a9-8262-208df66f37fd"
      2. /dev/sda2: UUID="eef5bbd9-af38-b16c-010c-adcb0ff6a017" UUID_SUB="0ed7e282-3428-cd6c-84b8-80bdf607c808" LABEL="NAS542:1" TYPE="linux_raid_member" PARTUUID="a269e2d7-d342-409a-99f5-d00c943429ec"
      3. /dev/sda3: UUID="73a70f7b-fcbc-6817-6a08-2c61fd87dae8" UUID_SUB="b8332071-40a8-ad74-3720-218e908ebf72" LABEL="NAS542:2" TYPE="linux_raid_member" PARTUUID="2d03b9b0-d56d-4a88-a8bc-f0a23adc5585"
      4. /dev/sdc1: UUID="829a9d3f-7601-4893-009d-27c18956d83c" UUID_SUB="bfff1969-5b81-5190-6451-616b4daebc3f" LABEL="NAS542:0" TYPE="linux_raid_member" PARTUUID="68e338ba-7003-4313-8d35-a726b90bc0b8"
      5. /dev/sdc2: UUID="eef5bbd9-af38-b16c-010c-adcb0ff6a017" UUID_SUB="16a4cbc3-13ff-9001-98f2-e53eaa2066d0" LABEL="NAS542:1" TYPE="linux_raid_member" PARTUUID="42fd2c79-1237-4676-b1a8-bca2af4aa18e"
      6. /dev/sdc3: UUID="c9dd07b9-8a4d-add4-22e0-7600947d1880" UUID_SUB="d8cb859d-cf37-5743-6a48-67fdca2bea64" LABEL="NAS542:3" TYPE="linux_raid_member" PARTUUID="37f976e1-54c8-4f98-b8b8-35f72de80bb3"
      7. /dev/sdb1: SEC_TYPE="msdos" LABEL="TC_BOOT" UUID="9EF7-9B5C" TYPE="vfat" PARTLABEL="TC_BOOT" PARTUUID="54cdf5da-deb1-b007-a694-32880502ef34"
      8. /dev/sdb2: LABEL="TC_ROOT" UUID="6475c7d6-5f26-4bf4-b718-01d0f2c296a0" TYPE="ext4" PARTLABEL="TC_ROOT" PARTUUID="54cdf5da-deb1-f007-a694-32880502ef34"
      9. /dev/sdd1: UUID="829a9d3f-7601-4893-009d-27c18956d83c" UUID_SUB="b2e103cb-2e31-8429-be03-839dcd855d19" LABEL="NAS542:0" TYPE="linux_raid_member" PARTUUID="7523384e-b7cf-45f0-82f8-885fc4cb2694"
      10. /dev/sdd2: UUID="eef5bbd9-af38-b16c-010c-adcb0ff6a017" UUID_SUB="1533ebd5-017e-135f-205c-3b170c6b75b5" LABEL="NAS542:1" TYPE="linux_raid_member" PARTUUID="34a18c8c-d1b4-460d-be69-05c404d0f64e"
      11. /dev/sdd3: UUID="74d6221f-f5c2-842b-7cbe-81342812becf" UUID_SUB="1a0a5f7d-b47d-7ff0-ca03-da15cc998835" LABEL="NAS542:4" TYPE="linux_raid_member" PARTUUID="644a8a64-0c5a-4c7e-acff-af09da39595b"
      12. /dev/sde1: UUID="829a9d3f-7601-4893-009d-27c18956d83c" UUID_SUB="dc292ddd-5e6b-55b2-7dd9-144870379d37" LABEL="NAS542:0" TYPE="linux_raid_member" PARTUUID="422597ff-2c04-4bf1-9f7a-5d396cb28d72"
      13. /dev/sde2: UUID="eef5bbd9-af38-b16c-010c-adcb0ff6a017" UUID_SUB="372c99b9-85c5-4a72-e4b6-304fa79fc6a6" LABEL="NAS542:1" TYPE="linux_raid_member" PARTUUID="400a3328-1ebe-4413-ab7b-47f704faee9d"
      14. /dev/sde3: UUID="12da1b87-4bc0-ace1-b1d0-856a1b1a3130" UUID_SUB="e01540d3-ae62-6939-fc0a-648dc4f24526" LABEL="NAS542:5" TYPE="linux_raid_member" PARTUUID="0e8d7b8c-edc6-404a-97a1-a7a23751933f"
      Display All

      sda, sdb, sdd and sde are the harddrives, sdc is the sd card with the root system.

      It is strange that for the hdds only UUIDs are shown but no labels or something. Also the UUIDs for sda1 / sdb1 / sdd1 / sde1 and for sda2 / sdb2 / sdd2 / sde2 are the same!

      The data partitions are sdx3, I think. Mounting those partitions directly over UUID gives:


      Source Code

      1. sudo mount -a
      2. mount: wrong fs type, bad option, bad superblock on /dev/sda3,
      3. missing codepage or helper program, or other error

      So the file systems are not found. Seems like some kind of driver problem?!

      Also very strange is that the UUIDs are different in a working system (other Debian image). Normally, UUIDs of partitions would not change, even with another Debian, right? :S
      This Debian image seems to have a problem reading the hdds in general ...

      Any suggestions?

      The post was edited 1 time, last by efyzz ().

    • Users Online 1

      1 Guest