nginx.service startet nicht wegen folgender Meldung

    • OMV 4.x
    • Update
    • nginx.service startet nicht wegen folgender Meldung

      Hi, after I install the PXE plugin and try to change the Access Port for the Webgui from 80 to 888 and try to save the Settings I get already an Error Message in the Gui like this below:

      nginx: [emerg] invalid number of arguments in "listen" directive in /etc/nginx/sites-enabled/openmediavault-pxe:2

      What can i do? Webgui is not accessible anymore, omv-* no help found... After reboot of the whole Server the Gui isn't accessible anymore.

      It is a clean fresh install of stretch first and then i use this:
      Install OMV4 on Debian 9 (Stretch)


      And then omv4extras from their website



      Thx


      EDIT:

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] invalid number of arguments in "listen" directive in /etc/nginx/sites-enabled/openmediavault-pxe:2nginx: configuration file /etc/nginx/nginx.conf test failed
      Fehler #0:OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] invalid number of arguments in "listen" directive in /etc/nginx/sites-enabled/openmediavault-pxe:2nginx: configuration file /etc/nginx/nginx.conf test failed in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/openmediavault/engined/module/webserver.inc(40): OMV\System\Process->execute()#1 /usr/share/openmediavault/engined/rpc/config.inc(168): OMVModuleNginxAbstract->applyConfig()#2 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusXM...', '/tmp/bgoutputGy...')#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#7 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#8 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#9 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)#10 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#11 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#12 {main}


      EDIT:

      WEBGUI accessible again but always i we try to change the main gui access port (80) to another one we get this error message above

      The post was edited 2 times, last by Nightcrawler ().

    • Please post the content of /etc/nginx/sites-enabled/openmediavault-pxe.

      Also describe step by step how we can reproduce this issue.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • hi,
      here the content:

      server {
      listen ;
      #listen [::]:;
      set $root_path "";
      root $root_path;
      index index.html;
      access_log /var/log/nginx/openmediavault-pxe-access.log;
      error_log /var/log/nginx/openmediavault-pxe-error.log;
      autoindex on;
      large_client_header_buffers 4 32k;
      }

      I install stretch first, then use the guide from votdev: Install OMV4 on Debian 9 (Stretch)
      Then install omvextras4 and then install few packages like vim, bwm-ng, nmap, iptraf etc. Then i reboot the System and install some plugins from omvextras. Then after i try to change the gui port from 80 to another one get this issue

      regards

      I attached the Package list from the Server created by # dpkg --get-selections
      Files
      • paketliste.txt

        (25.41 kB, downloaded 33 times, last: )

      The post was edited 2 times, last by Nightcrawler ().

    • According to github.com/OpenMediaVault-Plug…ult/mkconf/nginx.d/90-pxe your config file is not the one that is created by the plugin. Do you have modified manually?

      To get the origin file execute

      # omv-mkconf nginx
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • This is a problem with the pxe plugin on your system. It looks like your don't have the port set in the pxe plugin or it is set to a conflicting port.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • nginx: [emerg] directive "listen" is not terminated by ";" in /etc/nginx/sites-enabled/openmediavault-pxe:2
      Mär 23 13:56:33 bonn nginx[656]: nginx: configuration file /etc/nginx/nginx.conf test failed

      ^^ Now the nginx is offline and won't restart anymore, gui is not accessible

      It isn't set by my, just installed it

      How to purge or remove the plugin over cmd?

      Done, aptitude remove open....-pxe

      Now back online again without pxe plugin first

      EDIT: Hi, how to setup the PXE plugin correctly? I mean especially how to setup the port?

      Best

      The post was edited 4 times, last by Nightcrawler ().

    • Nightcrawler wrote:

      EDIT: Hi, how to setup the PXE plugin correctly? I mean especially how to setup the port?


      Best
      If have found a solution.
      The PXE plugin doesn't like not being used ^^.
      There is a bug in a script of the PEX plugin that writess the configs for NGNIX which causes a error when NGINX (the webserver) tries to start.
      PXE tries to create its config file for NGINX but it fails to get the port right.

      How to fix:
      1. login as root to your linux machine
      2. delete the pex file of openmediavault:

        rm /etc/nginx/sites-enabled/openmediavault-pxe
      3. start the NGINX server

        systemctl start nginx
        There should be no errors when you check the status with
        systemctl status nginx

      4. login to the webinterface like always
      5. goto Services -> PXE and give it a Shared Folder (i created a shared folder with the name EMPTY on my main drive) and press save.


      Works for me :)