Need help - Files won't copy to Open Media Vault [More details inside]

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Need help - Files won't copy to Open Media Vault [More details inside]

      Hello,

      My main machine that I work from is a Mac running Yosomite 10.10.5

      My OMV server runs 2.2.14 Stoneburner.


      Recently when I try to copy files from the back to the OMV server I get this message "The operation can’t be completed because the item “oPiRemoteSSHBackup.dmg” is in use." (See image below).

      This stops the file from copying over to the sever.

      Can anyone help me solve this so I can start copying files from the Mac to the server.

      Thanks in advance.

      [IMG:https://i.imgur.com/Bgc8z5G.png]
    • 1uke_ wrote:

      2.2.14 Stoneburner
      Why are you using such a horribly outdated version? Do you use Samba or Netatalk to access OMV? In any case using a more recent OMV version (which contains much much more revent Samba and Netatalk versions) will most probably result in the problem being gone.

      AFAIK the old OMV versions even use Debian's own horribly outdated and unpatched Netatalk version so no way to fix any problem...
    • tkaiser wrote:

      1uke_ wrote:

      2.2.14 Stoneburner
      Why are you using such a horribly outdated version? Do you use Samba or Netatalk to access OMV? In any case using a more recent OMV version (which contains much much more revent Samba and Netatalk versions) will most probably result in the problem being gone.
      AFAIK the old OMV versions even use Debian's own horribly outdated and unpatched Netatalk version so no way to fix any problem...
      I haven't updated yet for a few reasons,


      • The main reason for not updating being is that I don't know Linux very well and I don't know how to update. Can you point me in the right direction for updating my system please?


      • Copying and pasting stuff over never used to be a problem. Why will this issue have cropped up now?
    • I've never done an upgrade from OMV 2. Only read in the forum that it could be problematic so my best advice is to start over with a fresh OMV 4 installation. You can use your data disk(s) without problems but have to set up all the configuration stuff from scratch.

      Me being a Mac user as well wouldn't use Samba without a ton of patches on top (see here for some technical details) but that's nothing you would get with a stock OMV installation.

      But accessing same set of data with Samba and Netatalk in parallel can result in a real mess (due to metadata representation being incompatible) so my best advise is to continue with Samba on OMV 4.
    • New

      tkaiser wrote:

      I've never done an upgrade from OMV 2. Only read in the forum that it could be problematic so my best advice is to start over with a fresh OMV 4 installation. You can use your data disk(s) without problems but have to set up all the configuration stuff from scratch.

      Me being a Mac user as well wouldn't use Samba without a ton of patches on top (see here for some technical details) but that's nothing you would get with a stock OMV installation.

      But accessing same set of data with Samba and Netatalk in parallel can result in a real mess (due to metadata representation being incompatible) so my best advise is to continue with Samba on OMV 4.
      Hi @tkaiser,

      I have started a new thread as I am looking at upgrading again and have a few more questions before I make the leep.

      I was hoping you might drop by to my new thread to offer some advice.

      Thanks in advance :)