Ntfs hard drives not visible - permissions?

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Ntfs hard drives not visible - permissions?

      i just installed OMV on my Raspberry Pi 3, and when I mount my 2 NTFS hard drives, everything goes well until I try to access them through SMB. The shares show up, but the drives do not. Ive already tried the internal reset permissions tool but it didn't help. I did create a text file using the terminal, and THAT was visible over SMB, but nothing else. Could anyone please help me out? Thanks ☺
    • Nibb31 wrote:

      OMV is Linux. You should not be using NTFS with Linux.
      Thanks but that wasn't what I was asking. My home drive is of course ext4. Im aware of the FS difference. I can browse files in the ssh terminal, but nothing is visible over SMB. I have to use these drives with multiple windows systems, so converting to ext4 is not an option. I have used these drives in other Linux setups. NTFS is supported through NTFS-3g. Not perfectly, but its worked just fine. I really like the setup of OMV and would love to use it if i can figure out this problem. Any ideas on troubleshooting?
    • NTFS is no POSIX filesystem, so it does not work with OMV which is using ACLs to handle privileges.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Pdetweiler86 wrote:

      Thanks but that wasn't what I was asking. My home drive is of course ext4. Im aware of the FS difference. I can browse files in the ssh terminal, but nothing is visible over SMB. I have to use these drives with multiple windows systems, so converting to ext4 is not an option. I have used these drives in other Linux setups. NTFS is supported through NTFS-3g. Not perfectly, but its worked just fine. I really like the setup of OMV and would love to use it if i can figure out this problem. Any ideas on troubleshooting?
      I'm somewhat at a loss about why you'd want to connect Windows drives, to a Linux server, and share them to the network on a Linux server in a Samba share. If they're Windows formatted "NTFS" drives, and you want to maintain the format, how about sharing them to the network using a Windows client? (A laptop?) I mean, think about it for a minute; would it make sense to share an EXT4 drive to the network, on Windows Server 2012?

      Why not format them in OMV (a native Linux format), mount it, and share out their data directories using Samba, which acts as a Linux to Windows file/folder permissions translator?
      _________________________________________________

      ntfs-3g is resident in OMV (Debian), on the command line. This is probably why you can see your files on the command line. However to add a drive, with an entry in OMV's database, it must be mounted in the GUI. Therein lays the problem.

      There may be ways around this, like using Rsync (on the command line) to replicate NTFS data from the external drive, into an existing Samba share, but that's really going to an extreme.
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)