SMTP Settings for Notifications to=<openmediavault-notification@localhost.localdomain> ??

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • SMTP Settings for Notifications to=<openmediavault-notification@localhost.localdomain> ??

      I hope someone can tell me what I missed in setting up my SMTP to send notifications. When I click on "send a test message", no email ever gets received. I am using my hosting account at GoDaddy and entering the SMTP server, port (465), account login and password. But, when I look at the logs, I am puzzled by this line:
      Apr 5 15:46:03 myNAS postfix/pipe[8244]: 9DC03688C3: to=<openmediavault-notification@localhost.localdomain>, relay=omvnotificationfilter, delay=0.06, delays=0.02/0.01/0/0.03, dsn=2.0.0, status=sent (delivered via omvnotificationfilter service)

      All of the email addresses in /etc/postfix/recipient_canonical look good. I also tried sending an email from the command line with:
      echo "message body" | mail -s "Test Subject" Steve
      where Steve is in the recipient_canonical file and associated with my email address. But, no email.

      So, why is the to=<openmediavault-notification@localhost.localdomain> in the log file? Is this normal or did I fail to set something up?

      Thanks.
    • subzero79 wrote:

      I am under the impression the support for using port 465 was wrongly done. I will have to check your postfix files. Is this omv4?
      If is not, then port 465 is not supported.
      Thanks for the prompt reply. I am using Version 3.0.99 (Erasmus).
      This is a newbie question, but where are the postfix files that you could glean any information from?
      openmediavault.readthedocs.io/en/latest/various/files.html shows the location of everything else, but not postfix, and a find command finds a dozen or so postfix folders.

      But, since I am using Version 3, and my email provider only supports SSL on port 465, the question is moot.
      So, I turn off SSL in Notifications and use port 25. But still no email.
      just for grins, I tried Port 80 and, wow, all of my queued test messages were sent.

      So, again thanks for the quick reply- problem solved.
    • openmediavault-notification@localhost.localdomain is used to trigger bash scripts to support other notification types than email.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit