Replace OMV GUI with wordpress

    • OMV 3.x
    • Resolved
    • Replace OMV GUI with wordpress

      Hello,

      I have searched the forum and didn't see much details in replacing omv front GUI page with a forum or wordpress etc..

      Anyone knows how can i make the front end GUI as a forum without destroying server?

      I have tried moving OMV GUI in to another folder and placing wordpress as the main page but that broke the OMV GUI.Also change the GUI to use SSL and placed Wordpress in the main openmediavault folder that didn't work.

      If anyone got this to work would you be able to share the steps to get it to work without killing the server.

      Regards
      Wafic
      System: Openmediavault
      Processor: intel Core i7 970 3.20GHz
      Ram: Corsair 12GB DDR3 1066Mhz Dominator-GT
      Motherboard: asus rampage iii extreme Upgrading to asus rampage iv extreme next month
      Hdd: 8TB upgrading to 4 x 2tb hdd

      Services running on the system:
      Gaming Server: CS:Go, CS 1.6, Minecraft Bukkit x2, Killing floor x 2, L4D2, Team fortress 2, Garry's Mod, BF2, Teamspeak 3.
      TCadmin, Subsonic, SABnzbd, Headphone, Plex, Couchpotato, Sickbeard, Owncloud,
    • Not sure if I understand you well. Do you want to use the IP of your OMV to open WordPress?

      In that case you would just have to change the port of OMV GUI from 80 to something else. If you change it to 79, then you can reach OMV GUI with

      ip.of.your.nas:79

      Or you change the standard port of WordPress.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x | Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems in OMV - OMV setup videos - OMV4 Documentation :!:
    • Hello Macom,

      Thanks for your reply. Thats correct i want to use my ip for WordPress instead of omv. Would it be better to use nginx plugin for WordPress of would it be better to just place the files directly in the openmediavault folder?

      I have tried my forum in nginx but its not loading any of the images and other problems with it such as the picture attached.

      Which way would be the best to go with.
      Images
      • broken images.png

        48.04 kB, 1,888×922, viewed 79 times
      System: Openmediavault
      Processor: intel Core i7 970 3.20GHz
      Ram: Corsair 12GB DDR3 1066Mhz Dominator-GT
      Motherboard: asus rampage iii extreme Upgrading to asus rampage iv extreme next month
      Hdd: 8TB upgrading to 4 x 2tb hdd

      Services running on the system:
      Gaming Server: CS:Go, CS 1.6, Minecraft Bukkit x2, Killing floor x 2, L4D2, Team fortress 2, Garry's Mod, BF2, Teamspeak 3.
      TCadmin, Subsonic, SABnzbd, Headphone, Plex, Couchpotato, Sickbeard, Owncloud,
    • I got it to work perfectly.

      Many thanks for the help.
      System: Openmediavault
      Processor: intel Core i7 970 3.20GHz
      Ram: Corsair 12GB DDR3 1066Mhz Dominator-GT
      Motherboard: asus rampage iii extreme Upgrading to asus rampage iv extreme next month
      Hdd: 8TB upgrading to 4 x 2tb hdd

      Services running on the system:
      Gaming Server: CS:Go, CS 1.6, Minecraft Bukkit x2, Killing floor x 2, L4D2, Team fortress 2, Garry's Mod, BF2, Teamspeak 3.
      TCadmin, Subsonic, SABnzbd, Headphone, Plex, Couchpotato, Sickbeard, Owncloud,
    • Users Online 1

      1 Guest