[SOLVED] Raspberry Pi 3 B+ wlan0 not working

    • OMV 3.x
    • Resolved
    • [SOLVED] Raspberry Pi 3 B+ wlan0 not working

      Just flashed a microSD card for my new Pi 3B+. I left the Pi untouched and plugged in via ethernet for a couple of hours before I messed with it, per the instructions in the txt file.

      Everything appears to be working fine except wifi. I hit the Network tab, Interfaces, added wlan0, entered in my SSID and password, set method to DHCP, Saved, Applied, and wifi doesn't work. What am I missing?

      System dashboard reports kernel 4.14.30-v7+

      I'm aware that performance might not be great over wifi (and it's a Pi) but I want to see for myself.
    • I also tried adding the following to /etc/wpa_supplicant/wpa_supplicant.conf (file did not previously exist), doesn't seem to have any affect.

      ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
      update_config=1
      country=US

      network={
      ssid="wireless-service-set-identifier"
      psk="wireless-WPA2-security-key"
      key_mgmt=WPA-PSK
      }
    • klatox wrote:

      It finds my network and actually allows me to connect to my wifi network and I get an IP address.

      So Wi-Fi works flawlessly on the newest RPi as well with our image. And the method outlined in the announcement thread is still the right one. Thanks for confirming.

      klatox wrote:

      Unfortunately, when I remove the patch cable, I can no longer connect. Strange

      That's not 'strange' but usual behaviour when you connect a device with two or more interfaces to the same network and then disconnect the interface that has established the connection first. When you try this the next time simply power cycle your router or AP immediately after you remove the patch cable (will fix the 'problem') or have some patience (will also fix the 'problem' but depends on your router or AP how long it takes to adjust routes).

      It's about your router/AP defining host routes (the one for wlan0 going through eth0 as long as eth0 is available).

      If you really want to use Wi-Fi on this hardware then I would call nmtui again to assign a static IP address, then shut the board down, remove the patch cable, power cycle router/AP and switch the Raspi on again. Will work.

      And yes, that's not nicely integrated into OMV's UI but there's no need for this since Wi-Fi on all these SBC is crap anyway (way too slow. 802.11ac on the new RPi 3+ doesn't change anything since they do not make use of MIMO and only use an onboard aerial instead of a real external antenna).

      Would be interesting to see some Helios LanTest numbers from your Wi-Fi setup though...

      klatox wrote:

      I also tried adding the following to /etc/wpa_supplicant/wpa_supplicant.conf
      Why do people fiddle around with this file? Only reason I can imagine... since the Internet is flooded with all those crappy and outdated Raspberry Pi tutorials that tell you to do it the anachronistic way?

      The post was edited 1 time, last by tkaiser ().

    • klatox wrote:

      Guess I'm just spoiled by all my other devices switching automatically when I plug/unplug patch cables
      Would just work if eth0 would be under NetworkManager's control too (but OMV is not designed for that).

      BTW: Can you please provide a LanTest screenshot (Gigabit settings or even 10GbE settings, no printing, looks then like this). It's free and available from here: helios.de/web/EN/products/LanTest.html
    • klatox wrote:

      Guess I'm just spoiled by all my other devices switching automatically when I plug/unplug patch cables.
      Usually a NAS isn't roaming :D
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!