No Web GUI after moving OMV to SSD on RPI3

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • No Web GUI after moving OMV to SSD on RPI3

      This is a original RPi3 and was an attempt to boot OMV 3 from an SDD rather than an SD card. I first tried to use the hardware and software solutions used by Raspian to boot from USB, neither of these worked for OMV. So I went through the earlier process:

      • I started by booting an SD card image (3.0.99) and that installs in about 40 minutes and worked fine, including web access.
      • Formatted the SSD as a single ext4 partition on another Linux then attached it to the OMV RPi3.
      • File system showed it as sda1, so I mounted it from there.
      • On the command line, I used rsync to copy all of / to the blank SSD card.
      • Changed /boot/cmdline.txt to boot from sda1.
      • Source Code: /boot/cmdline.txt

        1. dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/sda1 rootfstype=ext4 elevator=deadline rootwait quiet rootdelay=5
      • Changed /etc/fstab to boot from sda1

      Source Code

      1. proc /proc proc defaults 0 0
      2. /dev/disk/by-id/usb-Apacer_A_S220_128GB_4646313830373733313630383037323637313239-0-0-part1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 1
      3. /dev/mmcblk0p1 /boot vfat defaults 0 2
      4. #/dev/mmcblk0p2 / ext4 defaults,noatime 0 1
      5. /var/swap none swap sw 0 0
      6. tmpfs /tmp tmpfs defaults 0 0
      7. # >>> [openmediavault]
      8. # <<< [openmediavault]
      • Reboot.
      Everything appears to be OK and I get the logo on the console. If I login to root, I get the Raspberry Pi 3 logo as normal. But I can no longer connect via the web interface - ERR_CONNECTION_REFUSED.

      Anyone got any suggestions where to look?
    • Up and working booting from SSD, no SD card inserted. This is an RPi3 with a bit set in the OTP (One Time Programmable) memory that enables booting from a USB mass storage device (this had already been done). In case this is useful to anyone else, these are the steps I [eventually followed after many failures] with the offline steps mostly on WIndows 10:
      1. Download latest RPi image (…/Raspberry%20Pi%20images/) currently 3_0_99. See also New approach for Raspberry Pi OMV images by tkaiser. Burn to known good SD card with Etcher (I formatted mine beforehand as well).
      2. Boot OMV on the RPi using the SD card with the SSD not connected. Let it complete the install (up to 40 mins) and make sure web access is working when it is done (if you have already set the SoC the green LED will blink when doing nothing!).
      3. Shutdown OMV from web.
      4. Take the SD card and make an .img file of it (I used Win32DiskImager).
      5. Burn the image onto the SSD using Etcher. This will create sda1 as the boot directory, sda2 for OMV, and sda3 unformatted exactly like on the SD card. I didn't mess with the sizes.
      6. Put the SD card back on the RPi.
      7. Connect the SSD to the RPi.
      8. Power on and let it boot from the SD card again.
      9. Login to the web and mount sda1 and sda2 from there.
      10. Go to console or SSH (in this case you need to allow superuser in SSH settings on web) and use lsblk -l to check mount points for sda1 and sda2.
      11. Modify sda1's cmdline.txt to point to /dev/sda2 when booting. I didn't change anything else.
        dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 [b]root=/dev/sda2[/b] rootfstype=ext4 elevator=deadline rootwait quiet
      12. Modidy sda2's /etc/fstab to forget about the SD card and mount sda1 + sda2 instead:

        Source Code

        1. proc /proc proc defaults 0 0
        2. /dev/sda2 / ext4 defaults,noatime 0 1
        3. /dev/sda1 /boot vfat defaults 0 2
        4. #/dev/mmcblk0p1 /boot vfat defaults 0 2
        5. #/dev/mmcblk0p2 / ext4 defaults,noatime 0 1
        6. /var/swap none swap sw 0 0
        7. tmpfs /tmp tmpfs defaults 0 0
        8. # >>> [openmediavault]
        9. # <<< [openmediavault]
      13. Shutdown from web.
      14. Remove the SD card and power back on - and hey presto you should have the SSD running the show!