VirtualBox and ZFS plugins installation issue after fresh OMV install

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • D.Wagner89 wrote:

      root@OMV:~# grep -ir backport /etc/apt/*
      /etc/apt/apt.conf.d/01autoremove: "linux-backports-modules-.*";
      /etc/apt/apt.conf.d/01autoremove-kernels: "^linux-backports-modules-.*-4\.14\.0-0\.bpo\.3-amd64$";
      /etc/apt/apt.conf.d/01autoremove-kernels: "^linux-backports-modules-.*-4\.15\.0-0\.bpo\.2-amd64$";
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      Strange. You don't have a file to enable the backports repo. Try:
      omv-mkconf apt
      then post the output again:
      grep -ir backport /etc/apt/*
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Well, I got the package compiled but it requires some changes to the plugin and phpvirtualbox package. Those changes will break backward compatibility. Need to think about what to do.

      My happiness was too early. I could install the Virtualbox-plugin but didn't start it after installation. Today I started Virtualbox (under OMV v4 with 4.15 backport kernel) and got this error message:

      Source Code

      1. Fehler #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'virtualbox-web' 2>&1' with exit code '1': A dependency job for virtualbox-web.service failed. See 'journalctl -xe' for details. in /usr/share/php/openmediavault/system/process.inc:175
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      5. #1 /usr/share/php/openmediavault/system/systemctl.inc(104): OMV\System\SystemCtl->exec('start', NULL, false)
      6. #2 /usr/share/openmediavault/engined/module/virtualbox.inc(107): OMV\System\SystemCtl->enable(true)
      7. #3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMV\Engined\Module\VirtualBox->startService()
      8. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(536): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusAX...', '/tmp/bgoutputnw...')
      12. #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      13. #9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      14. #10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      15. #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      16. #12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      17. #13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      18. #14 {main}
      Display All
      I guess that the VBox-plugin is incompatible with the latest kernel
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 4x3TB WD Red's Snapraid w/ mergerfs, 2x DVB-S2 card DVBSky s952v3,

      OMV-Server-SW: Debian Stretch with 4.15.x-Backports-Kernel (always up-to-date), OMV 4.1.x (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.1.x), PlexMediaServer, SMB-Shares, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • ryecoaaron wrote:

      Strange. You don't have a file to enable the backports repo. Try:omv-mkconf apt
      then post the output again:
      grep -ir backport /etc/apt/*
      Something changed but it dont work... :(

      root@OMV:~# omv-mkconf apt

      root@OMV:~# grep -ir backport /etc/apt/*

      /etc/apt/apt.conf.d/01autoremove: "linux-backports-modules-.*";
      /etc/apt/apt.conf.d/01autoremove-kernels: "^linux-backports-modules-.*-4\.14\.0-0\.bpo\.3-amd64$";
      /etc/apt/apt.conf.d/01autoremove-kernels: "^linux-backports-modules-.*-4\.15\.0-0\.bpo\.2-amd64$";
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/omv-extras-org:Pin: release a=stretch-backports
      /etc/apt/preferences.d/openmediavault-kernel-backports.pref:Pin: release a=stretch-backports
      /etc/apt/preferences.d/openmediavault-kernel-backports.pref:Pin: release a=stretch-backports
      /etc/apt/preferences.d/openmediavault-kernel-backports.pref:Pin: release a=stretch-backports
      /etc/apt/preferences.d/openmediavault-kernel-backports.pref:Pin: release a=stretch-backports
      /etc/apt/sources.list.d/openmediavault-kernel-backports.list:deb httpredir.debian.org/debian stretch-backports main contrib non-free

      root@OMV:~# apt-get install -t stretch-backports linux-headers-4.15.0-0.bpo.2-amd64
      Paketlisten werden gelesen... Fertig
      E: Der Wert »stretch-backports« ist für APT::Default-Release ungültig, da solch eine Veröffentlichung in den Paketquellen nicht verfügbar ist.
    • I imported my Pool back and i can access my Data via SMB and Putty but the device isnt shown on the webinterface of OMV
      Any idea why omv didnt recognise there ist another volume?
      I checked /etc/fstab ... my zfs pool is missing here but i'm not sure if it has to be there



      my shared foldes all show "n/a" as selected device



      If i edit an existing shared folder this error appears



      And the filesystem shows no reference

    • Hello, first post here.
      I can install the Vbox 5.2.10 with OMV 4.x.
      First i install the plugin with 4.14 kernel, after i add the sud repo in apt and download the vbox5.2.deb from vbox site.
      I modifye de deb pack , removing the dependences and re-create it.
      I run apt update and install the virtualbox-dkms from sid, it was build fine. After i install the modifyed vbox deb pack, and the ext-pack. Restart the system, enable the vboxphp and start the vm. I dont think it will work, but the vm start fine and runs great.

      I can share the mode vbox.deb if anyone wants.
      Images
      • vbox.jpg

        203.29 kB, 1,261×678, viewed 105 times
    • VirtualBox and ZFS plugins installation issue after fresh OMV install

      That would be great


      Gesendet von iPhone mit Tapatalk
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 4x3TB WD Red's Snapraid w/ mergerfs, 2x DVB-S2 card DVBSky s952v3,

      OMV-Server-SW: Debian Stretch with 4.15.x-Backports-Kernel (always up-to-date), OMV 4.1.x (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.1.x), PlexMediaServer, SMB-Shares, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • Please don't use the virtualbox package from anywhere other than the Debian repos if you plan on using the plugin. There are major differences in the virtualbox packages and it will probably break on an upgrade and/or the plugin won't work correctly with it. I have it working on my system but I have to worry about breaking users systems...
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      I have it working on my system but I have to worry about breaking users systems...

      What about putting your VM-plugin into the testing repo with a warning under comments that's only working with kernel 4.15 so that we users, who want to have it too, can test the plugin as well.
      What do you think about @ryecoaaron
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 4x3TB WD Red's Snapraid w/ mergerfs, 2x DVB-S2 card DVBSky s952v3,

      OMV-Server-SW: Debian Stretch with 4.15.x-Backports-Kernel (always up-to-date), OMV 4.1.x (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Virtualbox (with DSM 6.1.x), PlexMediaServer, SMB-Shares, TVHeadendServer (unstable release)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • virtualbox 5.2.8 with updated plugin, phpvirtualbox, and virtualbox-ext-pack-installer are in the omv 4.x omv-extras testing repo. And to answer future questions, this will not get backported to OMV 3.x and I'm not going to build virtualbox packages for i386.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      virtualbox 5.2.8 with updated plugin, phpvirtualbox, and virtualbox-ext-pack-installer are in the omv 4.x omv-extras testing repo. And to answer future questions, this will not get backported to OMV 3.x and I'm not going to build virtualbox packages for i386.
      Installed without problem now. I will test it today. THANK YOU FOR YOUR GREAT WORK! And patience for us :)

      Edit:

      Everything is working fine now. I can set up my OMV Server completely now. Thank you one more time.

      The post was edited 4 times, last by vonPaulus ().