ZoneMinder on Raspberry Pi

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • ZoneMinder on Raspberry Pi

      New

      Hi all,

      I’ve a Raspberry Pi2 installed with OpenMediaVault, (Debian 8 Jessie), changed the webinterface port to 81. That works fine.
      I want to use ZoneMinder, advise for OpenMediaVault is in Docker, but Docker does not work on Raspberry Pi, so I want the install ZoneMinder manually.
      I’ve installed Zoneminder with those instructions,
      wiki.zoneminder.com/Debian_8_6…inder_1.29.0_the_Easy_Way

      The installation is fine, but the webinterface does not works.
      In Internet Explorer, I’ve seen a blank page.
      In Chrome, the PHP file is appear:

      <?php
      //
      // ZoneMinder main web interface file, $Date$, $Revision$
      // Copyright (C) 2001-2008 Philip Coombes
      //
      // This program is free software; you can redistribute it and/or
      // modify it under the terms of the GNU General Public License
      // as published by the Free Software Foundation; either version 2
      // of the License, or (at your option) any later version.
      //
      // This program is distributed in the hope that it will be useful,
      // but WITHOUT ANY WARRANTY; without even the implied warranty of
      // MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
      // GNU General Public License for more details.
      //
      // You should have received a copy of the GNU General Public License
      // along with this program; if not, write to the Free Software
      // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
      //
      Etc.

      But nothing opened yet. No webbrowser.

      The ZoneMinder service is working well for so far I know:

      root@raspberrypi:~# systemctl status zoneminder.service
      ● zoneminder.service - ZoneMinder CCTV recording and surveillance system
      Loaded: loaded (/lib/systemd/system/zoneminder.service; enabled)
      Active: active (running) since Tue 2018-04-17 09:34:46 CEST; 5min ago
      Process: 2029 ExecStart=/usr/bin/zmpkg.pl start (code=exited, status=0/SUCCESS)
      Main PID: 2200 (zmdc.pl)
      CGroup: /system.slice/zoneminder.service
      ├─2200 /usr/bin/perl -wT /usr/bin/zmdc.pl startup
      ├─2251 /usr/bin/perl -wT /usr/bin/zmfilter.pl
      ├─2283 /usr/bin/perl -wT /usr/bin/zmaudit.pl -c
      └─2306 /usr/bin/perl -wT /usr/bin/zmwatch.pl

      Apr 17 09:34:45 raspberrypi sudo[2255]: pam_unix(sudo:session): session closed for user www-data
      Apr 17 09:34:45 raspberrypi sudo[2287]: root : TTY=unknown ; PWD=/usr/share/zoneminder/www ; USER=www-data ; COMMAND=/usr/bin/zmdc.pl star...watch.pl
      Apr 17 09:34:45 raspberrypi sudo[2287]: pam_unix(sudo:session): session opened for user www-data by (uid=0)
      Apr 17 09:34:46 raspberrypi zmdc[2200]: INF ['zmwatch.pl' starting at 18/04/17 09:34:46, pid = 2306]
      Apr 17 09:34:46 raspberrypi zmdc[2306]: INF ['zmwatch.pl' started at 18/04/17 09:34:46]
      Apr 17 09:34:46 raspberrypi sudo[2287]: pam_unix(sudo:session): session closed for user www-data
      Apr 17 09:34:46 raspberrypi zmfilter[2251]: INF [Scanning for events]
      Apr 17 09:34:46 raspberrypi systemd[1]: Started ZoneMinder CCTV recording and surveillance system.
      Apr 17 09:34:47 raspberrypi zmwatch[2306]: INF [Watchdog starting]
      Apr 17 09:34:47 raspberrypi zmwatch[2306]: INF [Watchdog pausing for 30 seconds]

      I don’t know how to fix it, any idea?

      Thanks.



      Update, I've changed the "short_open_tag = Off" to "shart_open_tag=On" and restart the apache services, but no result.

      The post was edited 1 time, last by ejvl ().