RTC Module on a RPI 2 with the OMV 3.x Debian Armbian (armhf) image

    • RTC Module on a RPI 2 with the OMV 3.x Debian Armbian (armhf) image

      Link to old guide

      In the old RPi image the ntp server was not working after installing it. In the OMV 3.x Debian armhf image it does work. So the part in the old guide on the ntp server can be skipped. I just had to modify 3 files and install i2c-tools to get the RTC module recognized by the system. I will give the file edits now.

      /etc/modules

      Source Code

      1. mv_cesa
      2. r8152
      3. ax88179_178a
      4. i2c-bcm2708
      5. i2c-dev
      6. rtc-ds1307



      /boot/config.txt
      With this file all you have to do is add this line at the end of the file and save it:

      Source Code

      1. dtparam=i2c_arm=on



      /boot/cmdline.txt
      Add the following line to the end of this file and save it.

      Source Code

      1. bcm2708.vc_i2c_override=1

      After making those changes:
      apt-get install i2c-tools

      Then turn off your rpi, "shutdown -h now", and install your RTC module. See old guide via link above for more info. on correct pins if needed. If your rpi already has the RTC module installed you can reboot instead, "shutdown -r now".

      After reboot, or starting, your RPi should now recognize the RTC module. You can check with this command:
      i2cdetect -y 1

      The post was edited 2 times, last by tekkb ().

    • Source Code

      1. root@rpi-2:~# i2cdetect -y 1
      2. 0 1 2 3 4 5 6 7 8 9 a b c d e f
      3. 00: -- -- -- -- -- -- -- -- -- -- -- -- --
      4. 10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
      5. 20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
      6. 30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
      7. 40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
      8. 50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
      9. 60: -- -- -- -- -- -- -- -- 68 -- -- -- -- -- -- --
      10. 70: -- -- -- -- -- -- -- --
      11. root@rpi-2:~#
      Display All
    • omv-mkgraph script failing. exiting script on check if service is disabled.

      /usr/sbin/omv-mkgraph

      Put # in check for service running and script ran:

      Source Code

      1. # Exit here if the rrdtool service is disabled.
      2. #[ "1" != "0" ] && exit 0



      The omv-mkgraph script is created by:
      /usr/share/openmediavault/mkconf/collectd

      Info. from this file that creates that line in the omv-mkgraph script:

      Source Code

      1. # Check if the system performance statistics service is enabled.
      2. enabled=$(omv_config_get "//system/monitoring/perfstats/enable")
      3. # Exit here if the rrdtool service is disabled.
      4. [ "1" != "${enabled}" ] && exit 0
      In the Web GUI under System/Monitoring the slider must be "Enable" or the omv-mkgraph script will exit early without creating graphs.
      Enabled the System/Monitoring slider and the omv-mkgraph script was rewritten. Graphs working normally now without editing the omv-mkgraph script.

      From the newly written omv-mkgraph script:

      Source Code

      1. # Exit here if the rrdtool service is disabled.
      2. [ "1" != "1" ] && exit 0

      The post was edited 10 times, last by tekkb ().