Plex reinstall error

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex reinstall error

      Hi all!
      First of all sorry for my bad english...
      Yesterday my NAS crashed due to a blackout (UPS is coming...). After some problems I restarted OMV and always works fine but Plex!
      I reinstalled the plugin but now I can't even open it...
      I found my problem here: Plex issue :-/
      Same error message:


      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. The following extra packages will be installed:
      5. avahi-utils git git-core git-man liberror-perl plexmediaserver
      6. Suggested packages:
      7. git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk
      8. gitweb git-arch git-cvs git-mediawiki git-svn
      9. The following NEW packages will be installed:
      10. avahi-utils git git-core git-man liberror-perl
      11. openmediavault-plexmediaserver plexmediaserver
      12. 0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
      13. Need to get 0 B/114 MB of archives.
      14. After this operation, 264 MB of additional disk space will be used.
      15. Selecting previously unselected package avahi-utils.
      16. (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 78484 files and directories currently installed.)
      17. Preparing to unpack .../avahi-utils_0.6.31-5_amd64.deb ...
      18. Unpacking avahi-utils (0.6.31-5) ...
      19. Selecting previously unselected package liberror-perl.
      20. Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
      21. Unpacking liberror-perl (0.17-1.1) ...
      22. Selecting previously unselected package git-man.
      23. Preparing to unpack .../git-man_1%3a2.1.4-2.1+deb8u5_all.deb ...
      24. Unpacking git-man (1:2.1.4-2.1+deb8u5) ...
      25. Selecting previously unselected package git.
      26. Preparing to unpack .../git_1%3a2.1.4-2.1+deb8u5_amd64.deb ...
      27. Unpacking git (1:2.1.4-2.1+deb8u5) ...
      28. Selecting previously unselected package git-core.
      29. Preparing to unpack .../git-core_1%3a2.1.4-2.1+deb8u5_all.deb ...
      30. Unpacking git-core (1:2.1.4-2.1+deb8u5) ...
      31. Selecting previously unselected package plexmediaserver.
      32. Preparing to unpack .../plexmediaserver_1.12.3.4973-215c28d86_amd64.deb ...
      33. Unpacking plexmediaserver (1.12.3.4973-215c28d86) ...
      34. Selecting previously unselected package openmediavault-plexmediaserver.
      35. Preparing to unpack .../openmediavault-plexmediaserver_3.8.2_all.deb ...
      36. Unpacking openmediavault-plexmediaserver (3.8.2) ...
      37. Processing triggers for man-db (2.7.0.2-5) ...
      38. Processing triggers for systemd (215-17+deb8u7) ...
      39. Processing triggers for mime-support (3.58) ...
      40. Processing triggers for openmediavault (3.0.99) ...
      41. Restarting engine daemon ...
      42. Setting up avahi-utils (0.6.31-5) ...
      43. Setting up liberror-perl (0.17-1.1) ...
      44. Setting up git-man (1:2.1.4-2.1+deb8u5) ...
      45. Setting up git (1:2.1.4-2.1+deb8u5) ...
      46. Setting up git-core (1:2.1.4-2.1+deb8u5) ...
      47. Setting up plexmediaserver (1.12.3.4973-215c28d86) ...
      48. Created symlink from /etc/systemd/system/multi-user.target.wants/plexmediaserver.service to /lib/systemd/system/plexmediaserver.service.
      49. Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      50. dpkg: error processing package plexmediaserver (--configure):
      51. subprocess installed post-installation script returned error exit status 1
      52. dpkg: dependency problems prevent configuration of openmediavault-plexmediaserver:
      53. openmediavault-plexmediaserver depends on plexmediaserver | plexmediaserver-installer; however:
      54. Package plexmediaserver is not configured yet.
      55. Package plexmediaserver-installer is not installed.
      56. dpkg: error processing package openmediavault-plexmediaserver (--configure):
      57. dependency problems - leaving unconfigured
      58. Errors were encountered while processing:
      59. plexmediaserver
      60. openmediavault-plexmediaserver
      61. >>> *************** Error ***************
      62. <<< *************************************
      Display All

      The indicated solution was to delete a symlink "Codecs" under /opt/plexcodecs, but I haven't this directory in my system.
      Anyone can save me please? ;(
    • Okay I think I solved the problems. After uninstalling the Plex Media Server plugin in OMV GUI, I remotely did a search for every reference to "plexmediaserver" using the command:
      find / -type d -name "plexmediaserver" -l, finding many of theme in my server.
      I removed all the ones I found except those inside my media drives to keep the libraries safe.
      Once I have ascertained that I had no references to Plex I reinstalled the plugin from the GUI, everything seems to work fine.

      EDIT: I also removed "plexpy.service" in /lib/systemd/system/

      The post was edited 1 time, last by CarfRip ().