[SOLVED] New Disk Not in Dropdown Lists for Selection

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [SOLVED] New Disk Not in Dropdown Lists for Selection

      I added a new 8TB disk to my OMV 4.1.6 server today to use as an additional SnapRAID parity drive but I am having a problem.

      The steps I took to add the disk were as follows:

      1) Shut down OMV
      2) Added the disk to the machine.
      3) Booted OMV
      4) Went to the OMV GUI | Storage | Disks and pressed the Scan Button, then saw the new disk appear in the list as /dev/sdg with g being the highest letter in the list.
      5) Went to Storage | File Systems and pressed the Create button. selected HGST HDN728080AL [/dev/sdg, 7.27 TiB] from the Device drop-down list (the only available item in the list), gave it a Label: dp2, and selected EXT4 for the File system, then pressed the OK button.
      6) Filesystem was successfully created, so I pressed the Close Button and then on the same page in the GUI I mounted the disk. Attached is a screenshot of this.
      7) Next in the GUI I went to Services | SnapRAID | Drives and pressed the Add button. Under Select a drive drop-down list, all previously existing drives are available for selection, but not the newly added drive.
      8)) I also tried to add a Shared folder under Access Rights Management but the newly added disk is not available in the Device drop-down list there either.
      9) Next I rebooted the machine, but still the problem remains. The newly added disk does not appear in any drop-down lists.
      10) In a shell I can navigate to /srv/dev-disk-by-label-dp2 and can create files and directories on the disk. But it still will not appear in any drop-down list withinthe OMV GUI.

      What am I doing wrong?
      Images
      • Selection_004.jpg

        70.47 kB, 1,031×407, viewed 130 times
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • subzero79 wrote:

      and also I remember supprt for labels was removed last week, maybe a bug was introduced.
      That change was reverted - github.com/openmediavault/open…9539a2dd15b4026313227368a
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • The disk is there in conf.system.filesystem.mountpoint:

      Source Code

      1. {"uuid": "7600de21-f23d-440b-883a-9a3ad542b12b", "type": "ext4", "hidden": false, "opts": "defaults,nofail,user_xattr,exec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl", "dir": "srv/dev-disk-by-label-dp2", "passno": 2, "freq": 0, "fsname": "/dev/disk/by-label/dp2"}]

      But there seems to be a missing / before srv just after the "dir":

      So, what I did was unmount the drive in the GUI and verified that it was gone in fstab, then mounted it again in the GUI. Looking in fstab again it looks like a bug as the / is missing there too (see line 6.)


      Source Code

      1. UUID=41991950-4d12-4475-86b8-ba54ec09323b /srv/dev-disk-by-label-d1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,a$
      2. UUID=01e83c5a-5688-4963-b671-0c7ee6d4652d /srv/dev-disk-by-label-d4 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,a$
      3. UUID=a6e6252d-5a8f-4e9b-88b3-46bef35b01a0 /srv/dev-disk-by-label-d2 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,a$
      4. UUID=1237e230-7f7b-4d27-9a48-0ec0d7fd6d4e /srv/dev-disk-by-label-d3 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,a$
      5. UUID=60132171-b492-4dbe-afd7-f1a503fdc8e6 /srv/dev-disk-by-label-dp1 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,$
      6. /dev/disk/by-label/dp2 srv/dev-disk-by-label-dp2 ext4 defaults,nofail,user_xattr,exec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2

      Edit:


      I make the correction (added a / where needed) in the appropriate mtent section of config.xml and this seems to have solved it.


      I will try adding another disk later and see if it was a fluke or a bug.
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380

      The post was edited 1 time, last by gderf ().