System : Backup to NFS Got error rsync: rsync_xal_set: lsetxattr

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • System : Backup to NFS Got error rsync: rsync_xal_set: lsetxattr

      Hi there,

      I'm new to OMV and this is my first post :) .

      I'm trying to set OMV up as a home server in a way that OMV to be a CIFS server and also the destination of home backups (4 machines with windows of my family) using Urbackup, and at the same time that OMV do backup itself to another server (of name lacie-5big-n2) also at home network with NFS (this has also CIFS, FTP, ..).

      I want to say to all of you that I love OMV's first impression, its web interface is very comfortable once you get used to the idea of "its concepts", the plugins are great and I feel very nice with shellinabox ... thank you very much for all this software to all of you.

      Right now I have OMV (last version 4.1.5-1 and up-to-date) on a Virtual Box host until I make sure it works with out problems, then I will move or reintall it on a physical machine.

      I have read a lot in the forum about how to back up OMV and I find it too confusing, complicated and not very mature, I'm going to try anyway. I'm very sensitive to the backup issue because I've had bad experiences before. :(

      After all that I make the decissión to backup :

      1 - For the system stuff, to shutdown the server to backup it from time to time with clonezilla to a nfs share in my backup-server.

      2 - Also for the system stuff, to backup if before any update with System : Backup plugin, as this does not need to shutdown the server.

      3 - To backup data content on my backup-server using rsnapshot and in the future to the cloud with rclone or duplicati.

      So far:

      Point 1 went Ok, although I haven't restored it yet.

      When I do (System : Backup) on the NFS share, I receive this error:


      1. {
      2. Error #0:
      3. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf backup 2>&1': sending incremental file list
      4. rsync: rsync_xal_set: lsetxattr(""/srv/c6bc1cda-7d0b-4763-9ec6-e06adbeaec2e/de-omv4vm/omvbackup/usr/bin/fping"","security.capability") failed: Operation not supported (95)
      5. rsync: rsync_xal_set: lsetxattr(""/srv/c6bc1cda-7d0b-4763-9ec6-e06adbeaec2e/de-omv4vm/omvbackup/usr/bin/fping6"","security.capability") failed: Operation not supported (95)
      6. rsync: rsync_xal_set: lsetxattr(""/srv/c6bc1cda-7d0b-4763-9ec6-e06adbeaec2e/de-omv4vm/omvbackup/usr/lib/x86_64-linux-gnu/gstreamer1.0/gstreamer-1.0/gst-ptp-helper"","security.capability") failed: Operation not supported (95)
      7. var/cache/openmediavault/archives/
      8. var/cache/openmediavault/archives/Packages
      9. var/lib/samba/private/msg.sock/
      10. var/lib/systemd/timers/stamp-anacron.timer
      11. var/lib/systemd/timers/stamp-phpsessionclean.timer
      12. sent 2,395,934 bytes received 11,405 bytes 3,144.79 bytes/sec
      13. total size is 3,562,656,480 speedup is 1,479.91
      14. rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1196) [sender=3.1.2] in /usr/share/openmediavault/engined/rpc/
      15. Stack trace:
      16. #0 /usr/share/php/openmediavault/rpc/ OMVRpcServiceBackup->{closure}('/tmp/bgstatushx...', '/tmp/bgoutputTv...')
      17. #1 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      18. #2 [internal function]: OMVRpcServiceBackup->doBackup(NULL, Array)
      19. #3 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
      20. #4 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('doBackup', NULL, Array)
      21. #5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Backup', 'doBackup', NULL, Array, 1)
      22. #6 {main}
      23. }
      Display All

      NFS is mounted with the Storage : Remote Mount plugin and also shared.

      I tried to mount it with NFS v4 and NFS v3 without any changes, the server supports both versions. However, clonezilla only works well with NFS v3:


      1. root@omv4vm:~# rpcinfo -p lacie-5big-n2 | grep nfs
      2. 100003 2 tcp 2049 nfs
      3. 100003 3 tcp 2049 nfs
      4. 100003 4 tcp 2049 nfs
      5. 100003 2 udp 2049 nfs
      6. 100003 3 udp 2049 nfs
      7. 100003 4 udp 2049 nfs
      8. root@omv4vm:~#

      More info my /etc/fstab:


      1. root@omv4vm:~# cat /etc/fstab
      2. # /etc/fstab: static file system information.
      3. #
      4. # Use 'blkid' to print the universally unique identifier for a
      5. # device; this may be used with UUID= as a more robust way to name devices
      6. # that works even if disks are added and removed. See fstab(5).
      7. #
      8. # <file system> <mount point> <type> <options> <dump> <pass>
      9. # / was on /dev/sda1 during installation
      10. UUID=50f9f0e0-27fe-486d-933c-2be4d4c04d25 / ext4 noatime,nodiratime,errors=remount-ro 0 1
      11. # swap was on /dev/sda5 during installation
      12. # 20180502 lblanco comentado para poner un USB y evitar desgaste, plugin flashmemoryflashmemory
      13. #UUID=9ff5acde-f243-427e-a972-8dbaaaa69840 none swap sw 0 0
      14. /dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
      15. tmpfs /tmp tmpfs defaults 0 0
      16. # >>> [openmediavault]
      17. /dev/disk/by-label/Backup /srv/dev-disk-by-label-Backup ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 2
      18. /dev/disk/by-label/AlmacenE4 /srv/dev-disk-by-label-AlmacenE4 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 2
      19. lacie-5big-n2:/shares/BackupEspacio /srv/c6bc1cda-7d0b-4763-9ec6-e06adbeaec2e nfs4 rsize=8192,wsize=8192,timeo=14,intr,nofail 0 0
      20. # <<< [openmediavault]
      21. root@omv4vm:~#
      22. root@omv4vm:~#
      Display All

      I found out that the command generating the error is:

      rsync -aAXvxx /bin /boot /dev /etc /export /home /initrd.img /initrd.img.old /lib /lib64 /lost+found /media /mnt /opt /proc /root /run /sbin /sharedfolders /srv /sys /tmp /usr /var /vmlinuz /vmlinuz.old /srv/c6bc1cda-7d0b-4763-9ec6-e06adbeaec2e/de-omv4vm/omvbackup/ --delete --exclude=/dev --exclude=/proc --exclude=/sys --exclude=/tmp --exclude=/run --exclude=/mnt --exclude=/media --exclude=/lost+found --exclude=/export --exclude=/home/ftp --exclude=/srv

      and the related option is: -X, --xattrs preserve extended attributes

      Backup does not finish right because theses files


      are not in destination direstory. I made a local try to (srv/dev-disk-by-label-Backup) before.

      The error is strange as it have already copied arround 90.000 files !!

      Retrying the backup, it copies some files (or at least report directories), but it gives the error again in the same 3 files:

      Source Code

      1. /usr/bin/fping
      2. /usr/bin/fping6
      3. /usr/lib/x86_64-linux-gnu/gstreamer1.0/gstreamer-1.0/gst-ptp-helper

      And I can not find anything special about this files (i mean attributes). Lets see:


      1. root@omv4vm:~#
      2. root@omv4vm:~# ls -l /usr/bin/fping*
      3. -rwxr-xr-x 1 root root 39232 Jan 11 2017 /usr/bin/fping
      4. -rwxr-xr-x 1 root root 39232 Jan 11 2017 /usr/bin/fping6
      5. root@omv4vm:~#
      6. root@omv4vm:~# getfattr -d /usr/bin/fping*
      7. root@omv4vm:~# getfattr /usr/bin/fping*
      8. root@omv4vm:~#
      9. root@omv4vm:~# ls -l /srv/c6bc1cda-7d0b-4763-9ec6-e06adbeaec2e/de-omv4vm/omvbackup/usr/bin/fping*
      10. -rwxr-xr-x 1 root root 39232 Jan 11 2017 /srv/c6bc1cda-7d0b-4763-9ec6-e06adbeaec2e/de-omv4vm/omvbackup/usr/bin/fping
      11. -rwxr-xr-x 1 root root 39232 Jan 11 2017 /srv/c6bc1cda-7d0b-4763-9ec6-e06adbeaec2e/de-omv4vm/omvbackup/usr/bin/fping6
      12. root@omv4vm:~#
      13. root@omv4vm:~#
      14. root@omv4vm:~# getfattr -d /srv/dev-disk-by-label-Backup/Backup-4-server/omvbackup/usr/bin/fping*
      15. root@omv4vm:~# getfattr /srv/dev-disk-by-label-Backup/Backup-4-server/omvbackup/usr/bin/fping*
      16. root@omv4vm:~#
      Display All

      Why is this failing to copy attributes? I chose an NFS destination because it is a Linux protocol and the machines are also Linux. I intend to back up the data to this NFS server with rsnapshot as well, would it be better to use a CIFS? I don't think so because it doesn't support hard links, or at least I think so.

      What are attributes used for ?

      Any help or workarround is welcome !!
    • I share my findings in the hope that it helps others:

      1 - NFS v3 and NFS v4 do not support extended attributes.

      NFS v3 and NFS v4 do not supportes Extended Attributes at
      and proposed standard (RFC 8276) about this.

      2 - NFS supports access privileges (ACL).

      3 - There are only 3 files in MVNO that have extended privileges or ACLs. In shared folders if there is more content with ACL.


      1. root@omv4vm:~# find / \( -path /proc -o -path /dev -o -path /proc -o -path /sys -o -path /tmp -o -path /run -o -path /mnt -o -path /media -o -path /lost+found -o -path /expor
      2. t -o -path /home/ftp -o -path /srv -o -path /sharedfolders \) -prune -o -name '*' -exec getfattr -h -d -m "^" --absolute-names {} \; 2> /dev/null | more
      3. # file: /usr/bin/fping
      4. security.capability=0sAQAAAgAgAAAAAAAAAAAAAAAAAAA=
      5. # file: /usr/bin/fping6
      6. security.capability=0sAQAAAgAgAAAAAAAAAAAAAAAAAAA=
      7. # file: /usr/lib/x86_64-linux-gnu/gstreamer1.0/gstreamer-1.0/gst-ptp-helper
      8. security.capability=0sAQAAAgAUAAAAAAAAAAAAAAAAAAA=
      9. root@omv4vm:~#
      10. root@omv4vm:~# getcap /usr/bin/fping
      11. /usr/bin/fping = cap_net_raw+ep
      12. root@omv4vm:~# getcap /usr/bin/fping6
      13. /usr/bin/fping6 = cap_net_raw+ep
      14. root@omv4vm:~# getcap /usr/lib/x86_64-linux-gnu/gstreamer1.0/gstreamer-1.0/gst-ptp-helper
      15. /usr/lib/x86_64-linux-gnu/gstreamer1.0/gstreamer-1.0/gst-ptp-helper = cap_net_bind_service,cap_net_admin+ep
      16. root@omv4vm:~#
      Display All


      Options for backup:

      1 - Use cronezilla on NFS. It works with NFS v3 (in my case it does not recognize NFS v4), it is fast and its backups take up little space, they are compressed.

      2 - Use REAR (, is pending.

      3 - Removing the attributes of the 3 files before making the backup and putting them after and when making the restore... is cumbersome.

      I'll go for option 1: Tried and tested backup and restore and they work perfectly :)
    • Rizos39 wrote:

      Options for backup:
      fsarchiver is very good. I just added this as a backup option to the OMV 4.x version of openmediavault-backup.
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Thanks, i didn't found it at first because it is still in testing repo.

      I will give a try when I have omv running, I like the idea of making a backup without shutting down and, according to its web page, it supports extended attributes :) !!

      Ah !!! and fsarchiver is a tool included in SystemRescueCd .. soo very interesting indeep to restore in case OS Disk faillure !!

      The post was edited 1 time, last by Rizos39 ().