/srv/dev-disk....is not a mountpoint

    • OMV 4.x
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • /srv/dev-disk....is not a mountpoint

      After upgrade from 3.x to 4.x one filesystem of my nas is not mounted.
      This is a part of the syslog:

      May 13 21:36:38 nas monit[898]: 'mountpoint_srv_dev-disk-by-label-NasPool' status failed (1) -- /srv/dev-disk-by-label-NasPool is not a mountpoint
      May 13 21:37:00 nas systemd[1]: dev-disk-by\x2dlabel-NasPool.device: Job dev-disk-by\x2dlabel-NasPool.device/start timed out.
      May 13 21:37:00 nas systemd[1]: Timed out waiting for device dev-disk-by\x2dlabel-NasPool.device.
      May 13 21:37:00 nas systemd[1]: Dependency failed for /srv/dev-disk-by-label-NasPool.
      May 13 21:37:00 nas systemd[1]: srv-dev\x2ddisk\x2dby\x2dlabel\x2dNasPool.mount: Job srv-dev\x2ddisk\x2dby\x2dlabel\x2dNasPool.mount/start failed with result 'dependency'.
      May 13 21:37:00 nas systemd[1]: Dependency failed for File System Check on /dev/disk/by-label/NasPool.
      May 13 21:37:00 nas systemd[1]: systemd-fsck@dev-disk-by\x2dlabel-NasPool.service: Job systemd-fsck@dev-disk-by\x2dlabel-NasPool.service/start failed with result 'dependency'.
      May 13 21:37:00 nas systemd[1]: Startup finished in 6.246s (kernel) + 3min 3.926s (userspace) = 3min 10.172s.
      May 13 21:37:00 nas systemd[1]: dev-disk-by\x2dlabel-NasPool.device: Job dev-disk-by\x2dlabel-NasPool.device/start failed with result 'timeout'.
      May 13 21:37:08 nas monit[898]: 'mountpoint_srv_dev-disk-by-label-NasPool' status failed (1) -- /srv/dev-disk-by-label-NasPool is not a mountpoint
      May 13 21:37:38 nas monit[898]: 'mountpoint_srv_dev-disk-by-label-NasPool' status failed (1) -- /srv/dev-disk-by-label-NasPool is not a mountpoint
      May 13 21:38:08 nas monit[898]: 'mountpoint_srv_dev-disk-by-label-NasPool' status failed (1) -- /srv/dev-disk-by-label-NasPool is not a mountpoint
      May 13 21:38:38 nas monit[898]: 'mountpoint_srv_dev-disk-by-label-NasPool' status failed (1) -- /srv/dev-disk-by-label-NasPool is not a mountpoint

      Any suggestion?
      Thank you in advance
    • macom wrote:

      Probably you need to give some more information about your system.
      Sorry!

      I am running OMV3 on an HP Proliant System. I boot OMV from an SSD and currently have two HDD's in mirror config.

      Decided to update to OMV4 today - thought I'd read how to do it properly. Uninstalled all my plugins, ran the upload and thought it went fine.

      On reboot, I can see this:




      My concern is the missing filesystem, If I'm honest, I'm not entirely sure it's not something to do with the naming - I don't remember the "disk/by-label" bit from before I upgraded. But I could be wrong!

      What I see in the System Logs is this:




      I do not know why it is not a mountpoint now. I am unable to unmount and remount the system. Any suggestions would be gratefully received!

      Thanks
    • Some more info:

      I had the drives set up with software raid within the HP Proliant set up and the SSD as the boot drive. After upgrading to OMV, all these associations had been lost within the Proliant system, so I had reallocate the SSD for boot, which worked fine. I also had to recreate the Software RAID. I don't know if that's done something...
    • Hello,

      I have the same problem after activate the NFS plugin and share a folder. The HDD that contains the shared folder have the same problem than you.

      Here is a part of syslog :

      Source Code

      1. Aug 14 18:54:09 Juvalnas monit[1343]: 'mountpoint_srv_dev-disk-by-label-JBOD1To' status failed (1) -- /srv/dev-disk-by-label-JBOD1To is not a mountpoint
      2. Aug 14 18:54:39 Juvalnas monit[1343]: 'mountpoint_srv_dev-disk-by-label-JBOD1To' status failed (1) -- /srv/dev-disk-by-label-JBOD1To is not a mountpoint
      3. Aug 14 18:55:09 Juvalnas monit[1343]: 'mountpoint_srv_dev-disk-by-label-JBOD1To' status failed (1) -- /srv/dev-disk-by-label-JBOD1To is not a mountpoint
      4. Aug 14 18:55:22 Juvalnas systemd[1]: dev-disk-by\x2dlabel-JBOD1To.device: Job dev-disk-by\x2dlabel-JBOD1To.device/start timed out.
      5. Aug 14 18:55:22 Juvalnas systemd[1]: Timed out waiting for device dev-disk-by\x2dlabel-JBOD1To.device.
      6. Aug 14 18:55:22 Juvalnas systemd[1]: Dependency failed for /srv/dev-disk-by-label-JBOD1To.
      7. Aug 14 18:55:22 Juvalnas systemd[1]: srv-dev\x2ddisk\x2dby\x2dlabel\x2dJBOD1To.mount: Job srv-dev\x2ddisk\x2dby\x2dlabel\x2dJBOD1To.mount/start failed with result 'dependency'.
      8. Aug 14 18:55:22 Juvalnas systemd[1]: Dependency failed for File System Check on /dev/disk/by-label/JBOD1To.
      9. Aug 14 18:55:22 Juvalnas systemd[1]: systemd-fsck@dev-disk-by\x2dlabel-JBOD1To.service: Job systemd-fsck@dev-disk-by\x2dlabel-JBOD1To.service/start failed with result 'dependency'.
      10. Aug 14 18:55:22 Juvalnas systemd[1]: dev-disk-by\x2dlabel-JBOD1To.device: Job dev-disk-by\x2dlabel-JBOD1To.device/start failed with result 'timeout'.
      11. Aug 14 18:55:22 Juvalnas systemd[1]: Starting Enable File System Quotas...
      12. Aug 14 18:55:22 Juvalnas quotaon[3543]: quotaon: cannot find /srv/dev-disk-by-label-Sauvegardes/aquota.group on /dev/sdc1 [/srv/dev-disk-by-label-Sauvegardes]
      13. Aug 14 18:55:22 Juvalnas quotaon[3543]: quotaon: cannot find /srv/dev-disk-by-label-Sauvegardes/aquota.user on /dev/sdc1 [/srv/dev-disk-by-label-Sauvegardes]
      14. Aug 14 18:55:22 Juvalnas quotaon[3543]: quotaon: cannot find /srv/dev-disk-by-label-JBOD230Go/aquota.group on /dev/sda1 [/srv/dev-disk-by-label-JBOD230Go]
      15. Aug 14 18:55:22 Juvalnas quotaon[3543]: quotaon: cannot find /srv/dev-disk-by-label-JBOD230Go/aquota.user on /dev/sda1 [/srv/dev-disk-by-label-JBOD230Go]
      16. Aug 14 18:55:22 Juvalnas quotaon[3543]: quotaon: cannot find /srv/dev-disk-by-label-JBOD200Go/aquota.group on /dev/sdb1 [/srv/dev-disk-by-label-JBOD200Go]
      17. Aug 14 18:55:22 Juvalnas quotaon[3543]: quotaon: cannot find /srv/dev-disk-by-label-JBOD200Go/aquota.user on /dev/sdb1 [/srv/dev-disk-by-label-JBOD200Go]
      Display All
      After some research, it seems to bo be this ticket but I don't know how to force NFS3 to resolve the problem...

      I try to restore a backup of omv that I made a few days ago, but.... The backup didn't worked ;( . I think I have to learn how the omv-bachup plugin works....

      I delete the shared folder (in NFS) and desactivate NFS, restart the NAS but error is still alive!

      If somebody can help us, thanks a lot.

      PS: sorry for my bad english laguage, I'm not used to post on english forum ^^
    • Thank you for fast reply Aaron!

      Done and... Have this error:

      Source Code

      1. Erreur #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'nfs-kernel-server' 2>&1' with exit code '1': Job for nfs-server.service failed because the control process exited with error code.
      3. See "systemctl status nfs-server.service" and "journalctl -xe" for details. in /usr/share/php/openmediavault/system/process.inc:175
      4. Stack trace:
      5. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      6. #1 /usr/share/php/openmediavault/system/systemctl.inc(104): OMV\System\SystemCtl->exec('start', NULL, false)
      7. #2 /usr/share/openmediavault/engined/module/nfs.inc(71): OMV\System\SystemCtl->enable(true)
      8. #3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleNfs->startService()
      9. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      10. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      11. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      12. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusBj...', '/tmp/bgoutputv6...')
      13. #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      14. #9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      15. #10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      16. #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      17. #12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      18. #13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      19. #14 {main}
      Display All

      Seems to be the NFSVER=3 ?


      Source Code

      1. root@Juvalnas:~# service nfs-server status
      2. ● nfs-server.service - NFS server and services
      3. Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled; vendor preset: enabled)
      4. Active: failed (Result: exit-code) since Tue 2018-08-14 19:17:13 CEST; 42s ago
      5. Process: 7303 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=1/FAILURE)
      6. Main PID: 6169 (code=exited, status=0/SUCCESS)
      7. CPU: 3ms
      8. août 14 19:17:13 Juvalnas systemd[1]: Starting NFS server and services...
      9. août 14 19:17:13 Juvalnas exportfs[7303]: exportfs: /etc/exports:1: unknown keyword "nfsver=3"
      10. août 14 19:17:13 Juvalnas systemd[1]: nfs-server.service: Control process exited, code=exited status=1
      11. août 14 19:17:13 Juvalnas systemd[1]: Failed to start NFS server and services.
      12. août 14 19:17:13 Juvalnas systemd[1]: nfs-server.service: Unit entered failed state.
      13. août 14 19:17:13 Juvalnas systemd[1]: nfs-server.service: Failed with result 'exit-code'.
      Display All
      Images
      • 2018-08-14_19h21_28.png

        39.42 kB, 1,737×554, viewed 53 times

      The post was edited 1 time, last by Stealthvince ().

    • ryecoaaron wrote:

      Post the content of your options textbox.
      I just add nfsver=3 , subtree_check and insecure were at the origin in the textbox when I create the shared folder.

      Source Code

      1. subtree_check,insecure,nfsver=3
      Since I turn on NFS and made at first time the shared folder, my hdd which contains the shared folder "Vidéos" has disappeared...

      Look at the screenshot I made of my shared folder, when I edit the "Vidéos" shared folder, the name's device looks like an id... I don't understand. My HDD is invisible.

      Perhaps there is no relation, but HDD disappear in a very short time after turn on NFS and NFS shared folder.

      I hope I'm understandable...
      Images
      • 2018-08-14_22h14_18.png

        54.81 kB, 1,270×384, viewed 50 times

      The post was edited 1 time, last by Stealthvince ().

    • Stealthvince wrote:

      I just add nfsver=3 , subtree_check and insecure were at the origin in the textbox when I create the shared folder.
      nfsver=3 is supposed to be placed in the remotemount options textbox but not the nfs share options.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Stealthvince wrote:

      I just add nfsver=3 , subtree_check and insecure were at the origin in the textbox when I create the shared folder.
      nfsver=3 is supposed to be placed in the remotemount options textbox but not the nfs share options.
      Hi, some news.
      I can't try your solution aaron, because the hdd which have the problem is dead... After physically remove it, I still had wrong log "...is not a mountpoint".

      The problem disappear one day when I did "umount -f /dev-disk-by-label...." but reappear the next day.
      So I buy a new HDD and did a clean install.

      I actually no use the NFS plugin (It was a test to make a share for the xbox kodi app, but didn't work).
      Sorry for the inconveniance
    • Users Online 1

      1 Guest