Issues after upgrade to OMV4 (from OMV3)

    • OMV 4.x
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Issues after upgrade to OMV4 (from OMV3)

      HI,

      I just updated from OMV3 to OMV4 on my Bananapi. Seems to have worked quite well, but I now have some issues after installation:

      Setting up mariadb-server-10.1 (10.1.23-9+deb9u1) ...
      Job for mariadb.service failed because the control process exited with error code.
      See "systemctl status mariadb.service" and "journalctl -xe" for details.
      invoke-rc.d: initscript mysql, action "start" failed.
      mariadb.service - MariaDB database server
      Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
      Active: failed (Result: exit-code) since Mon 2018-05-14 19:53:32 CEST; 114ms ago
      Process: 14622 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=226/NAMESPACE)

      May 14 19:53:31 bananapi systemd[1]: Starting MariaDB database server...
      May 14 19:53:32 bananapi systemd[1]: mariadb.service: Control process exited, code=exited status=226
      May 14 19:53:32 bananapi systemd[1]: Failed to start MariaDB database server.
      May 14 19:53:32 bananapi systemd[1]: mariadb.service: Unit entered failed state.
      May 14 19:53:32 bananapi systemd[1]: mariadb.service: Failed with result 'exit-code'.
      dpkg: error processing package mariadb-server-10.1 (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of default-mysql-server:
      default-mysql-server depends on mariadb-server-10.1; however:
      Package mariadb-server-10.1 is not configured yet.

      dpkg: error processing package default-mysql-server (--configure):
      dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of mariadb-server:
      mariadb-server depends on mariadb-server-10.1 (>= 10.1.23-9+deb9u1); however:
      Package mariadb-server-10.1 is not configured yet.

      dpkg: error processing package mariadb-server (--configure):
      dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of openmediavault-mysql:
      openmediavault-mysql depends on mariadb-server | mysql-server; however:
      Package mariadb-server is not configured yet.
      Package mysql-server is not installed.

      dpkg: error processing package openmediavault-mysql (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      mariadb-server-10.1
      default-mysql-server
      mariadb-server
      openmediavault-mysql
      Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0xb60b3420>
      Traceback (most recent call last):
      File "/usr/lib/python3.5/weakref.py", line 117, in remove
      TypeError: 'NoneType' object is not callable
      Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0xb60b3420>
      Traceback (most recent call last):
      File "/usr/lib/python3.5/weakref.py", line 117, in remove
      TypeError: 'NoneType' object is not callable
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      root@bananapi:~#
      Any idea how to overcome that issues?

      By the way, will OMV3-Extras be automatically upgraded to OMV4-Extras or have OMV4-Extras to be installed separately (which I did)?

      Thanks
      Stefan
    • stefan1983 wrote:

      Any idea how to overcome that issues?
      Not sure if my latest changes to the mysql plugin will help but they require the omv-extras testing repo to be enabled. Give it a shot.

      stefan1983 wrote:

      By the way, will OMV3-Extras be automatically upgraded to OMV4-Extras
      If you have the latest omv-extras 3.x version, then it (and other omv-extras plugins) will be upgraded to the version in the 4.x repo (unless they are the same).
      omv 4.1.7 arrakis | 64 bit | 4.16 backports kernel | omvextrasorg 4.1.7
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • David B wrote:

      Has the mysql plugin been updated to no longer have dependencies on php5?
      Yes, many months ago - github.com/OpenMediaVault-Plug…af6deb9db66eb3103b7221d34
      omv 4.1.7 arrakis | 64 bit | 4.16 backports kernel | omvextrasorg 4.1.7
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • David B wrote:

      Well that's interesting. I was under the impression that it was still dependent on php5 because when upgrading from OMV 3 to OMV 4, php5 seems to remain installed and cause problems.
      If a 3.x plugin that is dependent on php version (nginx or mysql for example) is not upgraded for some reason, then php5 stays installed. Updating the plugin should remove the dependency and allow it to be removed. There is also a case where a plugin is dependent on php5 but has no OMV 4.x version causing the same problem.
      omv 4.1.7 arrakis | 64 bit | 4.16 backports kernel | omvextrasorg 4.1.7
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Users Online 1

      1 Guest