Docker containers losing internet connectivity

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Docker containers losing internet connectivity

      upgraded from omv3 to omv4 recently, did a fresh install, installed docker, pulled containers, and then copied the docker config directories over to the new installation. Everything is working fine. Except for the fact that the containers seem to lose internet connectivity periodically (3 times in the last 3 days). A system reboot, or a manual container restart fixes the problem.

      for example nzbget says: Could not resolve hostname

      to be clear: the system itself does have internet connectivity, only the docker containers fail.

      any ideas?

      thanks!

      The post was edited 1 time, last by wowter ().

    • What is your docker version and debian kernel version ? How do you install Docker ? This issue is known on MacOs for some version but never seen this on linux ...
      I'm a Docker Technical Sales Professional.

      1 NAS OMV 4 (Intel celeron G3930 2.9 GHz, Asrock H110M-ITX, 24 Gb DDR4, 2*4 To Seagate Ironwolf Nas, 2*4 To WD red)
      1 RPI 3 seedbox with omv 3.X
      1 Backup Server omv 4 (core 2 quad q6600, 4 Gb DDR2, 2*4To WD blue)
    • New

      4.16.0, i installed docker via the OMV extras repo.

      Version: 18.03.1-ce
      API version: 1.37
      Go version: go1.9.5
      Git commit: 9ee9f40
      Built: Thu Apr 26 07:17:14 2018
      OS/Arch: linux/amd64
      Experimental: false
      Orchestrator: swarm

      Server:
      Engine:
      Version: 18.03.1-ce
      API version: 1.37 (minimum version 1.12)
      Go version: go1.9.5
      Git commit: 9ee9f40
      Built: Thu Apr 26 07:15:24 2018
      OS/Arch: linux/amd64


      But everything is working currently...........sigh..... if you want things to fail, they seldom do......

      thanks for taking the time to reply!