OpenmediaVault 3.0.99 (erasmus) on Odroid C1+ CRASHES/ FREEZES every few days - how to solve

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OpenmediaVault 3.0.99 (erasmus) on Odroid C1+ CRASHES/ FREEZES every few days - how to solve

      Hello all,

      I recently switched from raspberry pi to odroid c1+ for a "simple" networkfileserver. Main reason was the networkspeed that is 1 GB for Odroid vs 100MB for raspberry.
      Now all works well, but only the system freezes or crashes every 10-20 hours. The longest time it was up and running before freezing was maybe 1.5-2 days...
      The raspberry would go on for weeks and months before crashing/ freezing...

      So, I have been trying to get some info from system-log files, but to be honest I am not sure where I should look for?

      I am thinking in two possible strategies to approach this:
      - trying to find the cause for the "freeze"/ crash and see if this can be solved, or
      - in case of a freeze/ crash, have the odroid automatically reboot

      I am not sure how the second strategy could be implemented (if at all) and using the first strategy I would need some guidance as to where to look for clues.

      Any help would be greatly appreciated!

      Thanks already!

    • Are you using armbian? On armbian you can use armbian-config armbianmonitor -v to check the root file system. Might be it is corrupt due to a dying SD card or something else.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:

      The post was edited 1 time, last by macom ().

    • hanscie wrote:

      trying to find the cause for the "freeze"/ crash and see if this can be solved

      It's always the same: Power supply or SD card issues. What you describe sounds like power supply issue (under-voltage). There's not much you can do to diagnose (you need an oscilloscope) other than trying out a good PSU especially if you power now the C1+ with the same PSU you used already on your RPi (they contain some sort of under-voltage masquerading/protection since powering through Micro USB is such a horribly sh*t show). -- adding to that: all PSUs die eventually and usually the first symptom is voltage dropping under load.
    • Thank you for your reply!

      @macom: I did check the root file system as you suggested: It appears you don't have any corrupt files or packages!

      @tkaiser: I have my system set up with the psu that came with the Odroid, it powers through the dedicated power input (not the micro-USB). Should I go back to micro-USB powering?

      I am trying to set up a netconsole log-drop between the ODROID and a spare raspberry I have. That seems not so obvious...
      Also I will try and limmit the use of resources of the ODROID to keep power use lower...
    • @ all:
      From another board I was advised to disable VPU and HDMI output, which I did.

      Otherwise I tried to set up netconsole, which seemed to complicated to get working on the SSH level. I than found in the diagnostics TAB > system logs > settings: REMOTE SYSLOG.
      I put in the ip address of one of the other raspberry's I have and it started recording. Probably because of the changes I made previously (netcolsole setup of receiver and sender).
      SOOOO... that is now ready to record any kernel panic that might occur...

      BUT: surprisingly the system is up now for 1 day and 10 hours, which is a record... This must have to do with the disabling VPU and HDMI as these are the only changes I made.

      I'll get back here if and when the system crashes.. If not in a few days: I consider this case solved.
      I'll keep you posted!
    • Mostly because it looked like this thread had died with the issue magically solving itself without a clear path to follow to fix. So rather than hijacking this thread with my issue, I thought I'd respond to this one to see if the OP would come back with an update, whilst at the same time post a new thread as - re-reading the issue here mine is slightly different. The OP says their system crashes, whereas mine does not crash, the network dies. Two different issues, hence, this seems to warrant a new thread.