OMV 4 on Debian 9 problem install

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • :/home/joao# apt-get --yes --auto-remove --show-upgraded --allow-downgrades --allow-change-held-packages --no-install-recommends --option Dpkg::Options::="--force-confdef" --option DPkg::Options::="--force-confold" --allow-unauthenticated install openmediavault
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      E: Unable to locate package openmediavault

    • root@debian-omv:/home/joao# apt-get clean all
      root@debian-omv:/home/joao# apt-get update
      Hit:1 security.debian.org/debian-security stretch/updates InRelease
      Get:2 ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease [21.3 kB]
      Ign:3 ftp.uk.debian.org/debian stretch InRelease
      Hit:4 ftp.uk.debian.org/debian stretch-updates InRelease
      Hit:5 ftp.uk.debian.org/debian stretch Release
      Ign:2 ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease
      Ign:8 mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease
      Get:6 netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease [12.7 kB]
      Get:9 mega.nz/linux/MEGAsync/Debian_9.0 ./ Release [976 B]
      Ign:6 netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease
      Fetched 35.0 kB in 1s (34.7 kB/s)
      Reading package lists... Done
      W: GPG error: ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FCAE110B1118213C
      W: The repository 'http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease' is not signed.
      N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      W: GPG error: netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease: The following signatures were invalid: 0F6BCC17C26BFADC27F221007E7A6C592EF35D13 The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 24863F0C716B980B
      W: The repository 'http://downloads.sourceforge.net/project/openmediavault/packages arrakis InRelease' is not signed.
      N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      root@debian-omv:/home/joao# apt-cache search openmediavault
      root@debian-omv:/home/joao# apt-get install openmediavault
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      E: Unable to locate package openmediavault

    • apt-get clean all
      apt-get update
      Hit:1 security.debian.org/debian-security stretch/updates InRelease
      Get:2 ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease [21.3 kB]
      Ign:3 ftp.uk.debian.org/debian stretch InRelease
      Hit:4 ftp.uk.debian.org/debian stretch-updates InRelease
      Hit:5 ftp.uk.debian.org/debian stretch Release
      Ign:2 ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease
      Ign:8 mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease
      Get:6 netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease [12.7 kB]
      Get:9 mega.nz/linux/MEGAsync/Debian_9.0 ./ Release [976 B]
      Ign:6 netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease
      Fetched 35.0 kB in 1s (34.7 kB/s)
      Reading package lists... Done
      W: GPG error: ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FCAE110B1118213C
      W: The repository 'http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease' is not signed.
      N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      W: GPG error: netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease: The following signatures were invalid: 0F6BCC17C26BFADC27F221007E7A6C592EF35D13 The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 24863F0C716B980B
      W: The repository 'http://downloads.sourceforge.net/project/openmediavault/packages arrakis InRelease' is not signed.
      N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      apt-cache search openmediavault
      apt-get install openmediavault
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      E: Unable to locate package openmediavault

    • apt-get clean all
      apt-get update
      Hit:1 security.debian.org/debian-security stretch/updates InRelease
      Get:2 ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease [21.3 kB]
      Ign:3 ftp.uk.debian.org/debian stretch InRelease
      Hit:4 ftp.uk.debian.org/debian stretch-updates InRelease
      Hit:5 ftp.uk.debian.org/debian stretch Release
      Ign:2 ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease
      Ign:8 mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease
      Get:6 netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease [12.7 kB]
      Get:9 mega.nz/linux/MEGAsync/Debian_9.0 ./ Release [976 B]
      Ign:6 netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease
      Fetched 35.0 kB in 1s (34.7 kB/s)
      Reading package lists... Done
      W: GPG error: ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FCAE110B1118213C
      W: The repository 'http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu cosmic InRelease' is not signed.
      N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      W: GPG error: netcologne.dl.sourceforge.net/…t/openmediavault/packages arrakis InRelease: The following signatures were invalid: 0F6BCC17C26BFADC27F221007E7A6C592EF35D13 The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 24863F0C716B980B
      W: The repository 'http://downloads.sourceforge.net/project/openmediavault/packages arrakis InRelease' is not signed.
      N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
      N: See apt-secure(8) manpage for repository creation and user configuration details.
      apt-cache search openmediavault
      apt-get install openmediavault
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      E: Unable to locate package openmediavault
    • wget -O - packages.openmediavault.org/public/archive.key | apt-key add -
      --2018-05-23 23:33:49-- packages.openmediavault.org/public/archive.key
      Resolving packages.openmediavault.org (packages.openmediavault.org)... 178.254.11.33
      Connecting to packages.openmediavault.org (packages.openmediavault.org)|178.254.11.33|:80... connected.
      HTTP request sent, awaiting response... 200 OK
      Length: 1747 (1.7K) [application/pgp-keys]
      Saving to: ‘STDOUT’

      - 100%[=====================================================================================================================>] 1.71K --.-KB/s in 0s

      2018-05-23 23:33:49 (64.2 MB/s) - written to stdout [1747/1747]

      OK

    • ....

      :/home/joao# apt-get --allow-unauthenticated install openmediavault
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      E: Unable to locate package openmediavault




      If you agree, I'd better leave for tomorrow, I wake up early and I have to sleep.
      Thanks.
    • Ok lets brute force this thing. Here are the dependencies a clean vm installed. paste.debian.net/1026490 Run each apt-get install line.

      wget http://packages.openmediavault.org/public/pool/main/o/openmediavault/openmediavault_4.1.6_all.deb


      apt-get install openmediavault_4.1.6_all.deb

      If it is missing some dependency apt-get install it.

      Good luck.
      If you make it idiot proof, somebody will build a better idiot.
    • After run each apt-get, the last, show this:

      /home/joao# apt-get install openmediavault_4.1.6_all.deb
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      E: Unable to locate package openmediavault_4.1.6_all.deb
      E: Couldn't find any package by glob 'openmediavault_4.1.6_all.deb'
      E: Couldn't find any package by regex 'openmediavault_4.1.6_all.deb
    • :/home/joao# dpkg -i openmediavault_4.1.6_all.deb
      Selecting previously unselected package openmediavault.
      (Reading database ... 254627 files and directories currently installed.)
      Preparing to unpack openmediavault_4.1.6_all.deb ...
      Unpacking openmediavault (4.1.6) ...
      dpkg: dependency problems prevent configuration of openmediavault:
      openmediavault depends on libjs-extjs6; however:
      Package libjs-extjs6 is not installed.
      openmediavault depends on php-fpm; however:
      Package php-fpm is not installed.
      openmediavault depends on php-mbstring; however:
      Package php-mbstring is not installed.
      openmediavault depends on php-pam; however:
      Package php-pam is not installed.
      openmediavault depends on openssh-server; however:
      Package openssh-server is not installed.
      openmediavault depends on libjavascript-minifier-xs-perl; however:
      Package libjavascript-minifier-xs-perl is not installed.

      dpkg: error processing package openmediavault (--install):
      dependency problems - leaving unconfigured
      Processing triggers for rsyslog (8.24.0-1) ...
      Errors were encountered while processing:
      openmediavaul
    • :/home/joao# dpkg -i openmediavault_4.1.6_all.deb
      Selecting previously unselected package openmediavault.
      (Reading database ... 254627 files and directories currently installed.)
      Preparing to unpack openmediavault_4.1.6_all.deb ...
      Unpacking openmediavault (4.1.6) ...
      dpkg: dependency problems prevent configuration of openmediavault:
      openmediavault depends on libjs-extjs6; however:
      Package libjs-extjs6 is not installed.
      openmediavault depends on php-fpm; however:
      Package php-fpm is not installed.
      openmediavault depends on php-mbstring; however:
      Package php-mbstring is not installed.
      openmediavault depends on php-pam; however:
      Package php-pam is not installed.
      openmediavault depends on openssh-server; however:
      Package openssh-server is not installed.
      openmediavault depends on libjavascript-minifier-xs-perl; however:
      Package libjavascript-minifier-xs-perl is not installed.

      dpkg: error processing package openmediavault (--install):
      dependency problems - leaving unconfigured
      Processing triggers for rsyslog (8.24.0-1) ...
      Errors were encountered while processing:
      openmediavaul


      No way! For each install:

      :/home/joao# apt-get install libjavascript-minifier-xs-perl
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      You might want to run 'apt --fix-broken install' to correct these.
      The following packages have unmet dependencies:
      openmediavault : Depends: libjs-extjs6 but it is not installable
      Depends: php-fpm
      Depends: php-mbstring
      Depends: php-pam but it is not installable
      Depends: openssh-server
      E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


      and

      :/home/joao# apt --fix-broken install
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Correcting dependencies... Done
      The following additional packages will be installed:
      openssh-server openssh-sftp-server
      Suggested packages:
      molly-guard monkeysphere rssh ufw
      The following packages will be REMOVED:
      openmediavault
      The following NEW packages will be installed:
      openssh-server openssh-sftp-server
      0 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
      1 not fully installed or removed.
      Need to get 372 kB of archives.
      After this operation, 9,189 kB disk space will be freed.
      Do you want to continue? [Y/n] y
      Get:1 ftp.uk.debian.org/debian stretch/main amd64 openssh-sftp-server amd64 1:7.4p1-10+deb9u3 [39.5 kB]
      Get:2 ftp.uk.debian.org/debian stretch/main amd64 openssh-server amd64 1:7.4p1-10+deb9u3 [332 kB]
      Fetched 372 kB in 0s (726 kB/s)
      Preconfiguring packages ...
      (Reading database ... 255886 files and directories currently installed.)
      Removing openmediavault (4.1.6) ...
      Selecting previously unselected package openssh-sftp-server.
      (Reading database ... 254672 files and directories currently installed.)
      Preparing to unpack .../openssh-sftp-server_1%3a7.4p1-10+deb9u3_amd64.deb ...
      Unpacking openssh-sftp-server (1:7.4p1-10+deb9u3) ...
      Selecting previously unselected package openssh-server.
      Preparing to unpack .../openssh-server_1%3a7.4p1-10+deb9u3_amd64.deb ...
      Unpacking openssh-server (1:7.4p1-10+deb9u3) ...
      Setting up openssh-sftp-server (1:7.4p1-10+deb9u3) ...
      Processing triggers for systemd (232-25+deb9u3) ...
      Processing triggers for man-db (2.7.6.1-2) ...
      Setting up openssh-server (1:7.4p1-10+deb9u3) ...

      Creating config file /etc/ssh/sshd_config with new version
      Creating SSH2 RSA key; this may take some time ...
      2048 SHA256:1fmxSl5bLbeZeOnSWv/fZgvtqEy/z5dNZ1vpvItmx70 root@debian-omv (RSA)
      Creating SSH2 ECDSA key; this may take some time ...
      256 SHA256:e4IaYOTtEZclKb4Ww4Veobvtr9kw6yblVfdVjSt4bd4 root@debian-omv (ECDSA)
      Creating SSH2 ED25519 key; this may take some time ...
      256 SHA256:N1I2ZXTSJw4HYtUTOlbvfZSY2fM81Z+g9yjIh4UVLsw root@debian-omv (ED25519)
      Created symlink /etc/systemd/system/sshd.service → /lib/systemd/system/ssh.service.
      Created symlink /etc/systemd/system/multi-user.target.wants/ssh.service → /lib/systemd/system/ssh.service.
      Processing triggers for systemd (232-25+deb9u3) ...

      and:

      :/home/joao# apt-get install openmediavault_4.1.6_all.deb
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      E: Unable to locate package openmediavault_4.1.6_all.deb
      E: Couldn't find any package by glob 'openmediavault_4.1.6_all.deb'
      E: Couldn't find any package by regex 'openmediavault_4.1.6_all.deb'

      The post was edited 1 time, last by pinajj ().