Autoshutdown issue after update to OMV4

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Autoshutdown issue after update to OMV4

      Hi!

      Since I've update my system to OMV4 yesterday (inplace using omv-release-upgrade) the autoshutdown plugin is not working anymore. There are some error logs in the system log:

      Source Code

      1. May 21 07:18:40 HPNAS autoshutdown.sh[1004]: expr: Syntaxfehler
      2. May 21 07:18:40 HPNAS autoshutdown.sh[1004]: expr: Syntaxfehler
      3. May 21 07:18:40 HPNAS autoshutdown.sh[1004]: expr: Syntaxfehler
      4. May 21 07:18:40 HPNAS autoshutdown.sh[1004]: expr: SyntaxfehlerMay 21 07:18:40 HPNAS autoshutdown.sh[1004]: /usr/sbin/autoshutdown.sh: Zeile 646: [: Zu viele Argumente.
      These lines repeat every three minutes.

      Any hint?
    • Source Code

      1. dpkg -l | grep autoshutdown
      2. ii openmediavault-autoshutdown 4.0.3 all OpenMediaVault AutoShutdown Plugin
      BTW: "Not working anymore" was derived by the system beeing up since the update. Also the autoshutdown log in the web UI ended with the update. Just found that the script ist still running and the output ist now in the boot section??
    • hi, i'm also having problems with autoshutdown after moving to omv4. (installed debian then installed omv on top)
      essentially it's not hybrid-suspending

      first of all autoshutdown logs shows lots of this:
      INFO: ' XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'

      then,this is what i've found:
      detailed logging shows the script is set to call systemctl hybrid
      local6 autoshutdown[6543]: INFO: ' SHUTDOWNCOMMAND is set to 'systemctl hybrid'' (configured as suspend-hybrid)
      which is unknown on my system
      # systemctl hybrid Unknown operation hybrid.

      so i've set it to suspend for now...
    • Users Online 1

      1 Guest