OpenVPN Setup

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OpenVPN Setup

      Hi all,

      I've had my RaspberyPi running OMV4 for a while. Recenty the OpenVPN plugin got released, and I'd like to use it to access my NAS even when I'm not connected to my own network.

      I've managed to setup the OpenVPN plugin, however, I'm struggling with the right configuration. I have already check most of the tutorials and posts, but I can't figure it out. This is my first time setting up a VPN connection to my own network, so I'd appreciate the help as I can't seem to figure out the correct DNS settings.

      What I've done so far:

      1. Enabled OpenVPN in OMV, local IP 192.168.0.8 (fixed)
        1. VPN address 10.8.0.0
        2. mask 255.255.255.0
        3. PAM authentication off
        4. DNS server: no idea
        5. public address: No-IP hostname
      2. Opened port 1194 on my router (TP-Link TL-WR840N)
      3. Requested No-IP DDNS hostname
      4. Exported certificate from OMV and opened with OpenVPN


      However, I get the following OpenVPN output:

      Sun May 20 15:39:28 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]94.209.48.38:1194
      Sun May 20 15:39:28 2018 Socket Buffers: R=[65536->65536] S=[65536->65536]
      Sun May 20 15:39:28 2018 UDP link local: (not bound)
      Sun May 20 15:39:28 2018 UDP link remote: [AF_INET]94.209.48.38:1194
      Sun May 20 15:39:28 2018 MANAGEMENT: >STATE:1526823568,WAIT,,,,,,
      "Goats are like mushrooms, if you shoot a duck, I'm scared of toasters."
    • OpenVPN Setup

      Zwei wrote:

      Hi all,

      I've had my RaspberyPi running OMV4 for a while. Recenty the OpenVPN plugin got released, and I'd like to use it to access my NAS even when I'm not connected to my own network.

      I've managed to setup the OpenVPN plugin, however, I'm struggling with the right configuration. I have already check most of the tutorials and posts, but I can't figure it out. This is my first time setting up a VPN connection to my own network, so I'd appreciate the help as I can't seem to figure out the correct DNS settings.

      What I've done so far:

      1. Enabled OpenVPN in OMV, local IP 192.168.0.8 (fixed)
        1. VPN address 10.8.0.0
        2. mask 255.255.255.0
        3. PAM authentication off
        4. DNS server: no idea
        5. public address: No-IP hostname
      2. Opened port 1194 on my router (TP-Link TL-WR840N)
      3. Requested No-IP DDNS hostname
      4. Exported certificate from OMV and opened with OpenVPN


      However, I get the following OpenVPN output:

      Sun May 20 15:39:28 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]94.209.48.38:1194
      Sun May 20 15:39:28 2018 Socket Buffers: R=[65536->65536] S=[65536->65536]
      Sun May 20 15:39:28 2018 UDP link local: (not bound)
      Sun May 20 15:39:28 2018 UDP link remote: [AF_INET]94.209.48.38:1194
      Sun May 20 15:39:28 2018 MANAGEMENT: >STATE:1526823568,WAIT,,,,,,


      I used the same Settings for the setup as you did.
      Can you access OMV via the DNS Name?
      Did you replace the sample OpenVPN config with your personal? You can also Check it with any editor.
    • I'm omv4 new user and I installed OpenVPN plug-in 4.0 and when I want to change settings every time I click save i get this message:

      Missing 'required' attribute 'gateway_interface' , because cannot set any value in the required field

      What is going wrong and how can I fix it?

      Thanks
    • flist wrote:

      Zwei wrote:

      Hi all,

      I've had my RaspberyPi running OMV4 for a while. Recenty the OpenVPN plugin got released, and I'd like to use it to access my NAS even when I'm not connected to my own network.

      I've managed to setup the OpenVPN plugin, however, I'm struggling with the right configuration. I have already check most of the tutorials and posts, but I can't figure it out. This is my first time setting up a VPN connection to my own network, so I'd appreciate the help as I can't seem to figure out the correct DNS settings.

      What I've done so far:

      1. Enabled OpenVPN in OMV, local IP 192.168.0.8 (fixed)
        1. VPN address 10.8.0.0
        2. mask 255.255.255.0
        3. PAM authentication off
        4. DNS server: no idea
        5. public address: No-IP hostname
      2. Opened port 1194 on my router (TP-Link TL-WR840N)
      3. Requested No-IP DDNS hostname
      4. Exported certificate from OMV and opened with OpenVPN


      However, I get the following OpenVPN output:

      Sun May 20 15:39:28 2018 TCP/UDP: Preserving recently used remote address: [AF_INET]94.209.48.38:1194
      Sun May 20 15:39:28 2018 Socket Buffers: R=[65536->65536] S=[65536->65536]
      Sun May 20 15:39:28 2018 UDP link local: (not bound)
      Sun May 20 15:39:28 2018 UDP link remote: [AF_INET]94.209.48.38:1194
      Sun May 20 15:39:28 2018 MANAGEMENT: >STATE:1526823568,WAIT,,,,,,
      I used the same Settings for the setup as you did.
      Can you access OMV via the DNS Name?
      Did you replace the sample OpenVPN config with your personal? You can also Check it with any editor.
      No, I can't access OMV via the DNS name. How would I do that?
      Should the IP of my RaspberryPi match the DNS input?
      "Goats are like mushrooms, if you shoot a duck, I'm scared of toasters."
    • I had the same problem with running OpenVPN in OMV on a ODROID XU4. Same output in OpenVPN client status window. Eventually it timed out and generated -amongst other- the following message:


      TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)


      After some research I found the probable cause of my particular problem to be in the server side server.conf file in /etc/openvpn.


      In the file there were 2 lines that in my opinion did not make sense:


      push "route 169.254.0.0
      192.168.2.0 255.255.255.0"


      After making a backup (cp server.conf server.conf.org) and changing the two lines into one single line:


      push "route 10.8.0.0 255.255.255.0"


      followed by restarting openvpn (service restart openvpn) it worked immediately.


      An additional problem is that after making a change to the OpenVPN settings in the GUI and saving this change, the 2 lines that caused the problem are back in the server.conf file.


      It seems that the 'VPN network' settings in the GUI are not properly translated into the appropriate statements in server.conf.


      As long as I don't make any change and save any of the settings in the OpenVPN GUI everything is working perfectly all right. And if I do make a change then I have to correct (or copy back) server.conf.


      I am sure this will be fixed in a future version of the OpenVPN plugin.