Debian Fresh UEFI . OMV install keyring issues

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Debian Fresh UEFI . OMV install keyring issues

      I'm banging my head against a wall here, It worked once yesterday. and now no longer works...

      i have a fresh install debian due to UEFI only board.

      I've added repo. to sources.list.d/openmediavault.. and when I command apt-get install openmediavault-keyring postfix it tells me it cant find it.. while it did yesterday?!?!?! on another install that got borked.

      deb arrakis main

      what am I missing as every "how-to" i've read is the same thing.. after adding this to sources list run apt-get update. of course if gives some hail mary roasted nuts about public signatures, no_pubkey 248 yada yada...
      Then I try to "apt-get install openmediavault-keyring" . I've tried --allow-unauthenticated etc.. its just not finding it.

      Can someone shed some light.. brain is melted.
    • Jbmeth007 wrote:

      ok, every "how to" in existence on setting up from scratch is wrong.
      It isn't really wrong and not "every" how to in existence is wrong. Obviously, you are adding a repo and then adding the package that installs the key for that repo from the repo itself. When you install the package, it will ask you if you want to install and unauthenticated package. Just say yes. Then after the next apt-get update, everything should install without it. There is no need to alter openmediavault.list especially since it will be overwritten.

      If you really can't handle saying yes the one time, then just do one of the following (they all install the same omv key):

      wget -O - | apt-key add -


      dpkg -i openmediavault-keyring_1.0_all.deb


      apt-get update, GPG error
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • sorry,

      If it were that easy to enter yes to a question like that.. I would have.. however it was not offered.

      setup was debian 9.4.... when attempting it said it was not secure therefor would not be used...

      i tried manually entering key using
      wget -O - | apt-key add -

      to no effect.

      I was unaware of

      dpkg -i openmediavault-keyring_1.0_all.deb


      apt-get update, GPG error

      either way I figured it out.. Thanks
    • Users Online 1

      1 Guest