Zoneminder using Docker

    • Zoneminder using Docker


      Has any one had any luck with OMV 4, Docker (using OMV-extras) and Zoneminder?
      i have upgraded from OMV 3 where docker and zoneminder worked fine using quantumobject/docker-zoneminder version.
      since upgrading i am no long able to use zoneminder, i have tried different versions of zoneminder from different people aswell but all encounter issues.

      when launching the zoneminder container it run but when i check my open ports using lsof docker is there but the container/ zm is not.

      any help would be great.

    • First note that Dockers go through an evolution that's controlled by the author. What I'm getting at is; while you may have downloaded the image name "quantumobject/docker-zoneminder" (the tag "latest" is assumed if the field is empty), the image you got in the past may not be the same as the image you downloaded, if you downloaded recently. (The current image is 4 days old.) That can create problems in itself.

      The only difference between OMV3 and OMV4, from a Docker perspective, is the kernel. If you want to run Kernel 4.9.0 in OMV 4 that's possible.

      Zoneminder appears to be a two part Docker, using 2 containers in the current image. And it listens to the same IP as the host, on port 80. This would conflict with OMV's console. So I have to ask -did you load the Docker in the GUI or on the command line?
      Either way, with what appears to be a port 80 conflict, how did you get it run?
      Good backup takes the "drama" out of computing
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)