Help: RAID 5 data Recovery

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Help: RAID 5 data Recovery

      Hello, I am new to This forum and I have a problem that i cant seem to find any information on. or at least is relevant to my situation.

      I set up a HP MicroServer N40L fitted with 5 3TB Hard drives (one hard drive mounted in the optical bay) in RAID 5

      I had this working for years until one day i discovered that the server wouldnt start up. CrystaldiskInfo indicated two of the 5 drives were Yellow and dying from bad sectors.

      I removed the dying drives, did a ddrecovery of the data onto new donor drives and slotted them into the server.
      drive 1 had 99.99% data copied, some bad sectors were unrecoverable. drive 4 had 100% data copied!

      Upon booting I got the failed code 8 error message.

      After crawling through the forum, not knowing what im looking for or what im looking at (im a linux command line n00b) i saw some people were having luck with the command:
      "mdadm --assemble /dev/md127 /dev/sd[abcde] --verbose --force"

      ...so i gave it a try. Picture appended showing results.

      As far as i can understand - 4 of the 5 drives are recognized and the filesystem is missing.

      open media vault indicates ext4 filesystem but its 'missing'

      honestly i'm at a loss as to what else i need to do at this stage.

      Any ideas on how to rebuild this raid 5 partition to accept the two 'replacement' drives?

      thanks
      -Adrian
      Images
      • 33379603_10216708593933635_559982036530495488_n.jpg

        531.5 kB, 1,536×2,048, viewed 68 times
      • 33530539_10216708520531800_3217926580634386432_n.jpg

        68.8 kB, 2,048×621, viewed 62 times
      • wsety1.jpg

        473.79 kB, 864×740, viewed 73 times
    • majorpayne wrote:

      ade86 wrote:

      Any ideas on how to rebuild this raid 5 partition to accept the two 'replacement' drives?

      thanks
      -Adrian
      Unfortunately, to my knowledge, a Raid 5 only allows the loss of 1 drive. Raid 6 allows the loss of 2 drives.
      I am aware of this scenario, but considering that one of the two failed drives was completely replaced, im thinking that there still may be a chance to recover files. the drive that was 99.99 percent copied may pose issues however.
    • If OMV reports the file system as missing, that's not a good omen.

      Take a look here. -> RAID Recovery

      Hopefully, you have backup.
      ___________________________________________

      If you get past this, as a suggestion, take the time to fill in System, Notification with your E-mail info and enable it. Then, in the Notifications Tab, under storage, enable SMART, Filesystem, and Software RAID.
      Then go to Storage, SMART, enable SMART and set short tests for your drives.

      If this is done, OMV will notify you before things are critical.
      "An ounce of prevention is worth a pound of cure."
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • Users Online 1

      1 Guest