OMV VirtualBox 4.1 - "Advanced configuration" switch doesn't work!

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • flmaxey wrote:

      You might be able to head off more inquiries by putting a note by the switch - "Toggling may cause a temporary Gateway Error."
      It isn't just the switch that can cause this. Any change to the plugin can potentially produce this.

      flmaxey wrote:

      Now,, tell me what you have installed on your production server

      Source Code

      1. ii openmediavault 4.1.7 all openmediavault - The open network attached storage solution
      2. ii openmediavault-backup 4.0.1 all backup plugin for OpenMediaVault.
      3. ii openmediavault-flashmemory 4.1 all folder2ram plugin for OpenMediaVault
      4. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      5. ii openmediavault-locate 3.4 all locate plugin for OpenMediaVault.
      6. ii openmediavault-omvextrasorg 4.1.7 all OMV-Extras.org Package Repositories for OpenMediaVault
      7. ii openmediavault-resetperms 3.3 all Reset Permissions
      8. ii openmediavault-rsnapshot 4.1.3 all OpenMediaVault rsnapshot backup plugin.
      9. ii openmediavault-sftp 3.1.6 all sftp server
      10. ii openmediavault-symlinks 3.1.4 all OpenMediaVault symlinks plugin
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      flmaxey wrote:

      Now,, tell me what you have installed on your production server

      Source Code

      1. ii openmediavault 4.1.7 all openmediavault - The open network attached storage solution
      2. ii openmediavault-backup 4.0.1 all backup plugin for OpenMediaVault.
      3. ii openmediavault-flashmemory 4.1 all folder2ram plugin for OpenMediaVault
      4. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      5. ii openmediavault-locate 3.4 all locate plugin for OpenMediaVault.
      6. ii openmediavault-omvextrasorg 4.1.7 all OMV-Extras.org Package Repositories for OpenMediaVault
      7. ii openmediavault-resetperms 3.3 all Reset Permissions
      8. ii openmediavault-rsnapshot 4.1.3 all OpenMediaVault rsnapshot backup plugin.
      9. ii openmediavault-sftp 3.1.6 all sftp server
      10. ii openmediavault-symlinks 3.1.4 all OpenMediaVault symlinks plugin
      That's actually very lean. Most of those plugins are GUI to config file entries or CLI translators (so to speak). It appears that the only plugin that would pull an external package would be rsnapshot. And, I see you're booting on a flash drive.

      I approve! :D (As if that was needed... :) )
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • flmaxey wrote:

      And, I see you're booting on a flash drive.
      Kind of. It is a VM running on my ESXi server and the backing storage is a 1 TB Samsung 960 Pro NVMe stick.

      flmaxey wrote:

      I approve!
      Good :)
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      flmaxey wrote:

      You might be able to head off more inquiries by putting a note by the switch - "Toggling may cause a temporary Gateway Error."
      It isn't just the switch that can cause this. Any change to the plugin can potentially produce this.
      Not to beat this to death, while noting (as you well know) I'm not a Dev;

      Do you think there's a way to insert a wait state, to delay the 502 error long enough to give nginx a chance to restart?
      If that seems plausible, I'll file a change request / bug report to votdev.
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • flmaxey wrote:

      Do you think there's a way to insert a wait state, to delay the 502 error long enough to give nginx a chance to restart?
      I think this would be problematic due to nginx restart time which would influenced by many things - system speed, nginx plugin with lots of config files, etc - but I guess it wouldn't hurt to ask.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Users Online 1

      1 Guest