OpenMediaVault connection stuck at 100mbps?

    • OMV 4.x
    • OpenMediaVault connection stuck at 100mbps?

      The title says it all. My motherboard has dual 1 gbps ethernet ports and my cables are more then capable of running at that speed, but my issue is Openmediavault only runs at 100mbps. It's deathly important for it to run at gigabit speeds seeing as I edit all my work videos from the box and can not move to a local copy on my workstation. Thank you.

      i.imgur.com/e9DijWw.png

      There's the specs if that helps.
    • Have you checked in the network settings in OMV? What motherboard are you using? Have you checked that the network chips are fully supported by Debian? Did you try updating the network drivers? Are any of the cables damaged? It could be a wide range of reasons for this and none of them are easy to figure out from a screenshot with next to no info.
      OMV 4.x, Gigabyte Z270N-WiFi, i7-6700K@3GHz, 16GB DDR4-3000, 4x 4TB Toshiba N300, 1x 60GB Corsair GT SSD (OS drive), 10Gbps Aquantia Ethernet
    • TheLostSwede wrote:

      Have you checked in the network settings in OMV? What motherboard are you using? Have you checked that the network chips are fully supported by Debian? Did you try updating the network drivers? Are any of the cables damaged? It could be a wide range of reasons for this and none of them are easy to figure out from a screenshot with next to no info.
      Nework cables are fine. Everything physically is fine. They're all supported and everything.
      ebay.com/i/282815593732?chn=ps
      That's my board, the same model. I'm 99.999% sure it's compatible in all ways.
      I'm not sure what you want by network settings, though.

      Stramm wrote:

      Hhow did you check the nic speed?
      Maybe verify the reuslts on the commandline.

      for i in $(netstat -i | cut -f1 -d" " | tail -n+3) ; do echo "$i: $(ethtool "$i" | grep Speed | sed 's/Speed://g')" ; done
      i.imgur.com/SETgmNj.png

      I checked the nic speed in the motherboard manual.
    • Well, eth0 seems to be lacking drivers, as it's not detected properly according to your first screenshot.
      You might want to try and install the correct drivers for both Ethernet controllers.
      According to Supermicro, the board has:
      • 1x Intel® 82573V Gigabit PCI-Express Ethernet
      • 1x Intel® 82573L Gigabit PCI-Express Ethernet
      Ethtool is clearly seeing it as connected at 100Mbps, so either it's a configuration issue or a cable issue.
      OMV 4.x, Gigabyte Z270N-WiFi, i7-6700K@3GHz, 16GB DDR4-3000, 4x 4TB Toshiba N300, 1x 60GB Corsair GT SSD (OS drive), 10Gbps Aquantia Ethernet
    • TheLostSwede wrote:

      Well, eth0 seems to be lacking drivers, as it's not detected properly according to your first screenshot.
      You might want to try and install the correct drivers for both Ethernet controllers.
      According to Supermicro, the board has:
      • 1x Intel® 82573V Gigabit PCI-Express Ethernet
      • 1x Intel® 82573L Gigabit PCI-Express Ethernet
      Ethtool is clearly seeing it as connected at 100Mbps, so either it's a configuration issue or a cable issue.
      Now both of my ethernet adapters are detected at 100mbps. How wouid one install drivers? I can't figure it out.
    • horsetaco wrote:

      Now both of my ethernet adapters are detected at 100mbps
      This may not be a driver issue it could be hardware related having gone through the same process after upgrading both my switches to 10/100/1Gb my server was still running at 100mb, changed the cable and my laptop now connects to the server at 1Gb.
      So this is either the cable or the switch/hub that's causing the reduced connection.
      Raid is not a backup! Would you go skydiving without a parachute?
    • So I am having a similar issue. My throughput is capped at 100mb/s but my connection details all say 1,000.

      I've updated to the official realtek 8168 driver. ethtool shows 1000 as the speed. Checked cables, switch, etc. My windows desktop is on the same switch and it's reporting full speed when I do a speedtest. I'm consistently showing ~100mbps when I do a speedtest from the OMV machine.

      Containers (sabnzb), chrome (via X desktop), speedtest-cli are all showing me the same results as low speed.

      I have gigbit fiber so my internet connection isn't the issue.

      Is there a possibility the docker config virtual network is causing a slowdown?

      root@widgetmv:~# lshw -C network
      *-network
      description: Ethernet interface
      product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
      vendor: Realtek Semiconductor Co., Ltd.
      physical id: 0
      bus info: pci@0000:03:00.0
      logical name: enp3s0
      version: 06
      serial: 50:e5:49:e4:45:e4
      size: 1Gbit/s
      capacity: 1Gbit/s
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
      configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.046.00-NAPI duplex=full ip=192.168.1.105 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
      resources: irq:24 ioport:d000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff
      *-network
      description: Ethernet interface
      physical id: 2
      logical name: docker0
      serial: 02:42:34:fc:ca:59
      capabilities: ethernet physical
      configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A ip=172.17.0.1 link=no multicast=yes



      root@widgetmv:~# ethtool enp3s0
      Settings for enp3s0:
      Supported ports: [ TP ]
      Supported link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Full
      Supported pause frame use: Symmetric Receive-only
      Supports auto-negotiation: Yes
      Advertised link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Full
      Advertised pause frame use: Symmetric Receive-only
      Advertised auto-negotiation: Yes
      Link partner advertised link modes: 10baseT/Half 10baseT/Full
      100baseT/Half 100baseT/Full
      1000baseT/Full
      Link partner advertised pause frame use: Symmetric
      Link partner advertised auto-negotiation: Yes
      Speed: 1000Mb/s
      Duplex: Full
      Port: Twisted Pair
      PHYAD: 0
      Transceiver: internal
      Auto-negotiation: on
      MDI-X: Unknown
      Supports Wake-on: pumbg
      Wake-on: g
      Current message level: 0x00000033 (51)
      drv probe ifdown ifup
      Link detected: yes

      root@widgetmv:~# speedtest-cli
      Retrieving speedtest.net configuration...
      Testing from Highwinds Network Group (209.197.16.151)...
      Retrieving speedtest.net server list...
      Selecting best server based on ping...
      Hosted by TRANSTELCO (Dallas, TX) [1.57 km]: 172.253 ms
      Testing download speed................................................................................
      Download: 85.62 Mbit/s
      Testing upload speed....................................................................................................
      Upload: 64.30 Mbit/s
    • Well it's actually not 100Mbps.. It's more like 200 now. But still well below the 1000. That leads me to believe it's not anything to do with the card setting limiting the hardware to 100. It's something to do with either actual hardware (error rates) or just a slow network stack or something.

      Any idea how I can troubleshoot this?

      EDIT: Scratch all this - it's something to do with an errant container config. If anyone is using the haugene/docker-transmission-openvpn container, beware. It hijacks the host networking so that everything bound for the internet goes out the vpn when run in host networking mode.

      The post was edited 1 time, last by smith000 ().