OMV 4 fresh install with missing drives (file systems)

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV 4 fresh install with missing drives (file systems)

      Hi I'm attempting a fresh OMV 4 install from scratch from a previous OMV 3.x updated install. I have an SSD for the OS and 5 HD's formatted with ext4 in the previous OMV version. Note no RAID. After the successful OMV 4 install I've noticed all drives are visible in the Physical Disks table but two drives are missing in the File Systems folder. No matter what I try, I can't get these drives in the file system and then mounted.
      I've tried:
      1. Multiple re-installs
      2. Manually created an entry in fstab and mounted successfully, but this vanishes with reboot
      3. "Create" file system: tried to recreate the file system wiping out all my old files. Formatting looks like it's working with Status=Initializing, but when done the entry vanishes again

      I'm out of ideas. Any guidance would be greatly appreciated.
    • Seems to be a problem with the kernel or userland tools like blkid in Debian 9.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • OhMyVirtual wrote:

      For me the "File Systems" option has disappeared entirely. Is this a kernel bug too?
      Gee, I wonder why I'm even still running OMV, since most, if not all, my issues involve admin and config outside of OMV.

      I installed and use Webmin, to handle these issues. It's quite good. It does all that OMV fails to do.

      Volker posted in the other thread on this issue it was a typo in the update.. I'm guessing he'll push an update to fix it as soon as time allows. (you're responding to a post that is 6mo old... this issue was fixed and is completely different currently causing the missing filesystems section)

      Some of you folks have absolutely zero patience.
      Air Conditioners are a lot like PC's... They work great until you open Windows.