OMV4 For Downloader & Media Server - Docker the Only Way?

    • OMV 4.x
    • Hi @topi

      Thanks for the recommendation. I have seen many videos from @TechnoDadLife and they are all excellent.

      Probably I wasn't clear on my previous post but Watchtower is up & running.

      The only question I have is under Status, it constantly shows "Restarting (X # of seconds)". Why?

      Shouldn't it say it say something along the lines of "2 days and X hours"?

      From the Status, seems to me the docker keeps constantly re-starting.

      No matter what change I make in configuration... From "always", to "unless stopped" , to "none".

      I'm running it as Host; name = watchtower; restart = "always".

      Any thoughts on this? Is this the way it is supposed to be?
      RaspberryPi 3B
      32 GB microSD Card
      Storage: 4TB WD Red NAS x 2 (One for Media, One for Backup)
      OMV 4.x
      Hey, I'm using Docker Images!
      - Plex
      - Watchtower
    • This is what I get from the container log:

      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error"
      standard_init_linux.go:190: exec user process caused "exec format error

      "
      RaspberryPi 3B
      32 GB microSD Card
      Storage: 4TB WD Red NAS x 2 (One for Media, One for Backup)
      OMV 4.x
      Hey, I'm using Docker Images!
      - Plex
      - Watchtower
    • javcsjc wrote:

      Hi @topi

      Thanks for the recommendation. I have seen many videos from @TechnoDadLife and they are all excellent.

      Probably I wasn't clear on my previous post but Watchtower is up & running.

      The only question I have is under Status, it constantly shows "Restarting (X # of seconds)". Why?

      Shouldn't it say it say something along the lines of "2 days and X hours"?

      From the Status, seems to me the docker keeps constantly re-starting.

      No matter what change I make in configuration... From "always", to "unless stopped" , to "none".

      I'm running it as Host; name = watchtower; restart = "always".

      Any thoughts on this? Is this the way it is supposed to be?
      please post a screen capture of how do you configure, restart is not good, must be stable.

      select watchtower and push the Modify button to see your config.
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • Thanks again @gderf

      I have installed fgabriel/rpi-watchtower and it seems to be running fine.

      However, when I opened the Info section of the Docker image, this is what I found:




      Last push was 2 years ago and the repository is no longer usable.
      RaspberryPi 3B
      32 GB microSD Card
      Storage: 4TB WD Red NAS x 2 (One for Media, One for Backup)
      OMV 4.x
      Hey, I'm using Docker Images!
      - Plex
      - Watchtower
    • Just gone through this again @javcsjc you're using the the wrong image!!

      When you click run image in the tags box next to vtec/watchtower you must enter armhf-latest if you leave it blank or type in latest it will download the wrong docker file....hence the fact it will not work!!

      The 'tag' defines what to download.
      Raid is not a backup! Would you go skydiving without a parachute?
    • geaves wrote:

      Just gone through this again @javcsjc you're using the the wrong image!!

      When you click run image in the tags box next to vtec/watchtower you must enter armhf-latest if you leave it blank or type in latest it will download the wrong docker file....hence the fact it will not work!!

      The 'tag' defines what to download.
      Sure would be nice if this was mentioned in the documentation.
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • OK guys. Appreciate the patience. Here we go again:

      Step #1: Download Docker Image from v2tec/watch:


      Step #2: Run Image:

      Name: watchtower

      Restart Policy: Until stopped

      Network mode: Host

      Extended Arguments: -v /var/run/docker.sock:/var/run/docker.sock

      Step #3: Image of Docker Dashboard:



      We'll see how it behaves. Thanks again!
      RaspberryPi 3B
      32 GB microSD Card
      Storage: 4TB WD Red NAS x 2 (One for Media, One for Backup)
      OMV 4.x
      Hey, I'm using Docker Images!
      - Plex
      - Watchtower
    • Users Online 2

      2 Guests